Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 515220 - media-sound/vorbis-tools-1.4.0-r1 fails eautoreconf (AM_CONFIG_HEADER)
Summary: media-sound/vorbis-tools-1.4.0-r1 fails eautoreconf (AM_CONFIG_HEADER)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2014-06-26 17:08 UTC by Arfrever Frehtes Taifersar Arahesis
Modified: 2014-06-26 17:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
vorbis-tools-1.4.0-r1.ebuild.patch (vorbis-tools-1.4.0-r1.ebuild.patch,234 bytes, patch)
2014-06-26 17:11 UTC, Arfrever Frehtes Taifersar Arahesis
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis 2014-06-26 17:08:45 UTC
>>> Preparing source in /var/tmp/portage/media-sound/vorbis-tools-1.4.0-r1/work/vorbis-tools-1.4.0 ...
 * Applying vorbis-tools-1.4.0-underlinking.patch ...                                                                                                 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-sound/vorbis-tools-1.4.0-r1/work/vorbis-tools-1.4.0' ...
/usr/lib64/python3.4/imp.py:32: PendingDeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
  PendingDeprecationWarning)
/usr/lib64/python3.4/imp.py:32: PendingDeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
  PendingDeprecationWarning)
 * Running libtoolize --install --copy --force --automake ...                                                                                         [ ok ]
 * Running aclocal -I m4 ...                                                                                                                          [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/media-sound/vorbis-tools-1.4.0-r1/temp/aclocal.out

 * ERROR: media-sound/vorbis-tools-1.4.0-r1::gentoo failed (prepare phase):
 *   Failed Running aclocal !



$ cat /var/tmp/portage/media-sound/vorbis-tools-1.4.0-r1/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/media-sound/vorbis-tools-1.4.0-r1/work/vorbis-tools-1.4.0
***** aclocal -I m4

/usr/share/aclocal/gtkglextmm-1.2.m4:225: warning: underquoted definition of AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD
/usr/share/aclocal/gtkglextmm-1.2.m4:225:   run info Automake 'Extending aclocal'
/usr/share/aclocal/gtkglextmm-1.2.m4:225:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.ac:17: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.14/obsolete.m4:11: AM_CONFIG_HEADER is expanded from...
configure.ac:17: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.14: error: echo failed with exit status: 1
Comment 1 Arfrever Frehtes Taifersar Arahesis 2014-06-26 17:11:18 UTC
Created attachment 379736 [details, diff]
vorbis-tools-1.4.0-r1.ebuild.patch
Comment 2 Samuli Suominen gentoo-dev 2014-06-26 17:19:17 UTC
fix in tree