Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 512690 - emerge --autounmask-write and dispatch-conf - Not a directory: '/etc/config-archive/etc/portage/package.unmask/unmask'; fatal
Summary: emerge --autounmask-write and dispatch-conf - Not a directory: '/etc/config-a...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2014-06-07 23:15 UTC by januszmk
Modified: 2014-08-04 02:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
error log (file_512690.txt,3.04 KB, text/plain)
2014-06-07 23:15 UTC, januszmk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description januszmk 2014-06-07 23:15:03 UTC
Created attachment 378440 [details]
error log

I have use files in /etc/portage/package.use/*, unmask in /etc/portage/package.unmask/* and I did emerge -NuDav world --autounmask-write, then dispath-conf, and I got errors when I run dispath-conf (attachment)
Comment 1 Jeroen Roovers gentoo-dev 2014-06-08 11:25:13 UTC
Please post your `emerge --info' output in a comment.
Comment 2 januszmk 2014-06-08 11:43:15 UTC
(In reply to Jeroen Roovers from comment #1)
> Please post your `emerge --info' output in a comment.

Portage 2.2.10 (default/linux/amd64/13.0/desktop/kde/systemd, gcc-4.8.2, glibc-2.19, 3.14.2-gentoo x86_64)
=================================================================
System uname: Linux-3.14.2-gentoo-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.2
KiB Mem:    20051928 total,    148848 free
KiB Swap:    4095996 total,   4061680 free
Timestamp of tree: Sat, 07 Jun 2014 21:30:02 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6-r1, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.5.4, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo steam-overlay mozilla qt dev-zero hasufell miramir booboo javer x-portage
Installed sets: @steam
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirror.pw.edu.pl/ http://gentoo.po.opole.pl http://gentoo.inode.at/"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/steam /var/lib/layman/mozilla /var/lib/layman/qt /var/lib/layman/dev-zero /var/lib/layman/hasufell /var/lib/layman/miramir /var/lib/layman/booboo /var/lib/layman/gentoo-overlay /usr/local/portage"
USE="X a52 aac acl acpi acpid alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm iconv infinality ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline savedconfig sdl semantic-desktop session spell sse sse2 ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vaapi vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl eng" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 3 Brian Dolbec gentoo-dev 2014-06-12 14:58:59 UTC
Ok, it looks like a bug in dispatch-conf.

Can you please confirm that you were using /etc/portage/package.* as files, not directories prior to your last emerge run.
If that is the case, then dispatch-conf was not handling that case when they converted to being directories.
Comment 4 januszmk 2014-06-12 15:03:22 UTC
(In reply to Brian Dolbec from comment #3)
> Ok, it looks like a bug in dispatch-conf.
> 
> Can you please confirm that you were using /etc/portage/package.* as files,
> not directories prior to your last emerge run.
> If that is the case, then dispatch-conf was not handling that case when they
> converted to being directories.

I am using directories in /etc/portage/ and my unmask files are in /etc/portage/package.unmask/*
Comment 5 Brian Dolbec gentoo-dev 2014-06-12 15:53:14 UTC
This bug is fixed in git:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=f55ab6a98e4042f570a8a56b13926fef66cbf22b

It is available now in portage-9999.  Please test that this fixes it for you.
It will be in portage-2.2.11.
Comment 6 januszmk 2014-06-14 21:33:37 UTC
(In reply to Brian Dolbec from comment #5)
> This bug is fixed in git:
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;
> h=f55ab6a98e4042f570a8a56b13926fef66cbf22b
> 
> It is available now in portage-9999.  Please test that this fixes it for you.
> It will be in portage-2.2.11.

still not working, now in emerge -NuDav world --autounmask-write I am getting:

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.
Traceback (most recent call last):
  File "/usr/bin/emerge", line 51, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 1054, in emerge_main
    return run_action(emerge_config)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 4066, in run_action
    emerge_config.args, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 327, in action_build
    mydepgraph.display_problems()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 7739, in display_problems
    self._display_autounmask()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 7661, in _display_autounmask
    if self.query(prompt, enter_invalid) == 'No':
TypeError: query() missing 1 required positional argument: 'enter_invalid'
Comment 7 Brian Dolbec gentoo-dev 2014-08-04 02:15:52 UTC
released in portage-2.2.11