Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510698 - media-video/mkvtoolnix-6.9.1 - checking for the Qt version /usr/bin/moc uses... too old: 4.8.5
Summary: media-video/mkvtoolnix-6.9.1 - checking for the Qt version /usr/bin/moc uses....
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt5-porting
  Show dependency tree
 
Reported: 2014-05-19 00:21 UTC by Thomas Capricelli
Modified: 2014-05-19 19:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Capricelli 2014-05-19 00:21:05 UTC
[ebuild     U ] media-video/mkvtoolnix-6.9.1 [6.7.0] USE="pch qt5%* wxwidgets -debug (-qt4%)" 

ends with 

checking if linking against libMatroska works and if it requires -DMATROSKA_DLL... yes, without -MATROSKA_DLL
checking for ZLIB... yes
checking for wx-config... /usr/lib64/wx/config/gtk2-unicode-3.0
checking for wxWidgets 2.8.0 or newer... 3.0.0 ok
checking for wxWidgets class wxBitmapComboBox... yes
checking for wxMenuBar member function SetMenuLabel... yes
checking for wxMenuItem member function SetItemlabel... yes
checking for moc-qt5... no
checking for moc... /usr/bin/moc
checking for the Qt version /usr/bin/moc uses... too old: 4.8.5

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-video/mkvtoolnix-6.9.1/work/mkvtoolnix-6.9.1/config.log
 * ERROR: media-video/mkvtoolnix-6.9.1::gentoo failed (configure phase):
 *   econf failed
 * 
 * Call stack:


From what i understand, qt is an option, but when qt is enabled, then only qt5 can be used. On gentoo, qt5 is provided by dev-qt/qtcore:5, which is indeed installed on my system. moc is then found in

    /usr/lib64/qt5/bin/moc

And the configure seems not aware of this, so i wonder how it was supposed to work ..???

Reproducible: Always
Comment 1 Davide Pesavento gentoo-dev 2014-05-19 00:49:58 UTC
In an autoconf-based build system, the location of moc should be determined via pkg-config.
Comment 2 Tim Harder gentoo-dev 2014-05-19 19:45:58 UTC
The qt5 use flag is masked for mkvtoolnix because qt5 isn't in the tree yet. If you're unmasking the use flag you're currently on your own.