Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510594 - app-cdr/nero - wget: ftp*.usw.nero.com - failed: Connection timed out.
Summary: app-cdr/nero - wget: ftp*.usw.nero.com - failed: Connection timed out.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
: 542922 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-17 19:25 UTC by Leonid Kopylov
Modified: 2015-10-24 08:54 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,3.76 KB, text/plain)
2014-05-17 19:25 UTC, Leonid Kopylov
Details
diff against nero-4.0.0.0b.ebuild (nero.patch,1.00 KB, patch)
2015-10-21 20:39 UTC, Ben Kohler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2014-05-17 19:25:59 UTC
Created attachment 377152 [details]
build.log

Fetch failed for 'app-cdr/nero-4.0.0.0b'
Comment 1 Pacho Ramos gentoo-dev 2015-07-03 09:23:24 UTC
*** Bug 542922 has been marked as a duplicate of this bug. ***
Comment 2 Pacho Ramos gentoo-dev 2015-07-03 09:24:27 UTC
I can neither download it => CCing treecleaners
Comment 3 Dion Moult (RETIRED) gentoo-dev 2015-09-24 10:44:26 UTC
# Dion Moult <moult@gentoo.org> (24 Sep 2015)
# Masked for removal in 30 days.
# Upstream disappeared. Bug #510594
app-cdr/nero
Comment 4 Göktürk Yüksek gentoo-dev 2015-09-25 06:44:47 UTC
I don't think upstream disappeared. It looks more like fetch restricted now:

http://www.nero.com/enu/downloads/previous-versions/download-linux4-update.php

It asks for your email address.
Comment 5 Brendan Horan 2015-09-26 05:53:38 UTC
(In reply to Gokturk Yuksek from comment #4)
> I don't think upstream disappeared. It looks more like fetch restricted now:
> 
> http://www.nero.com/enu/downloads/previous-versions/download-linux4-update.
> php
> 
> It asks for your email address.

Upstream has not disappeared.
I can use the following to download :
http://ftp20.us.nero.com/PUB/f65a1a62b63c78dbd5eaeb4ea187b30d/nerolinux-4.0.0.0b-x86_64.rpm 

I feel there should be fetch restrictions on this.
Do note upstream has not released a new version/patch since sometime around 2010.
Comment 6 Dion Moult (RETIRED) gentoo-dev 2015-09-26 23:26:21 UTC
Reverted package mask. https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=448b9137caaff0ba23ef4a67debbaef3e686a700
Comment 7 Dion Moult (RETIRED) gentoo-dev 2015-09-26 23:32:42 UTC
Removing treecleaner. Feel free to CC us again.
Comment 8 Pacho Ramos gentoo-dev 2015-10-03 13:40:16 UTC
(In reply to Brendan Horan from comment #5)
> (In reply to Gokturk Yuksek from comment #4)
> > I don't think upstream disappeared. It looks more like fetch restricted now:
> > 
> > http://www.nero.com/enu/downloads/previous-versions/download-linux4-update.
> > php
> > 
> > It asks for your email address.
> 
> Upstream has not disappeared.
> I can use the following to download :
> http://ftp20.us.nero.com/PUB/f65a1a62b63c78dbd5eaeb4ea187b30d/nerolinux-4.0.
> 0.0b-x86_64.rpm 
> 
> I feel there should be fetch restrictions on this.
> Do note upstream has not released a new version/patch since sometime around
> 2010.

That link simply points to:
---------------------------------------
- Welcome to the Nero AG FTP archives -
-_____________________________________-
-                                     -
-  ===============================    -
- | Actual software links you can |   -
- | find at http://www.nero.com   |   -
- |                               |   -
- |  PLEASE VISIT DOWNLOAD AREA   |   -
- |         - thank you ! -       |   -
-  ===============================    -
-                                     -
-      Nero AG                        -
-      Rueppurrer Strasse 1a          -
-      76137 Karlsruhe                -
-      Germany                        -
-      Tel: +49 721 627260            -
-      Fax: +49 721 62726499          -
-_____________________________________-
-				      -
-			              -
-     If you are experiencing any     -
-     problems with this server,      -
-     please email ftpadmin@nero.com  -
---------------------------------------
Comment 9 Dion Moult (RETIRED) gentoo-dev 2015-10-03 13:51:15 UTC
Can you provide instructions on where to download it from the website? If so, we can add it to the package to explain how to fetch it.
Comment 10 Göktürk Yüksek gentoo-dev 2015-10-08 05:13:40 UTC
My apologies. I guess the ftp URL is auto-generated individually. The download website is: http://www.nero.com/enu/downloads/previous-versions/download-linux4-update.php
Comment 11 Ben Kohler gentoo-dev 2015-10-21 20:39:55 UTC
Created attachment 415120 [details, diff]
diff against nero-4.0.0.0b.ebuild

This patch against the ebuild does 3 things:

1) add fetch to RESTRICT
2) implement pkg_nofetch to print download instructions when the user needs to fetch
3) remove mirror://nero/ from SRC_URI since this doesn't exist and the files are not downloadable
Comment 12 Pacho Ramos gentoo-dev 2015-10-23 19:06:09 UTC
[master 213506b] app-cdr/nero: This is now fetch restricted, also bump eapi (#510594 by Ben Kohler, Gokturk Yuksek, Brendan Horan and Leonid Kopylov)
 1 file changed, 21 insertions(+), 12 deletions(-)
 rename app-cdr/nero/{nero-4.0.0.0b.ebuild => nero-4.0.0.0b-r1.ebuild} (79%)
Comment 13 Ben Kohler gentoo-dev 2015-10-23 19:14:23 UTC
Thanks for the quick fix, would you mind removing the nero mirror list from profiles/thirdpartymirrors since this ebuild was the only one using it?  I meant to mention that in my comment above.

Thanks!
Comment 14 Pacho Ramos gentoo-dev 2015-10-24 08:54:04 UTC
Sure:
[master bb0ade9] thirdpartymirrors: nero is no longer used (#510594)
 1 file changed, 1 deletion(-)