Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 509998 - media-libs/mesa-10.1.1 fails to build (undefined references in egl.c)
Summary: media-libs/mesa-10.1.1 fails to build (undefined references in egl.c)
Status: RESOLVED DUPLICATE of bug 501328
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-10 18:33 UTC by Heiko Baums
Modified: 2014-05-10 18:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,41.94 KB, application/x-bzip)
2014-05-10 18:39 UTC, Heiko Baums
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Baums 2014-05-10 18:33:06 UTC
media-libs/mesa-10.1.1 fails to build due to several undefined references in egl.c.

This is the first error message:

libtool: relink: x86_64-pc-linux-gnu-g++  -fPIC -DPIC -shared -nostdlib /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../lib64/crti.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/crtbeginS.o  .libs/egl.o .libs/egl_pipe.o .libs/egl_st.o  -Wl,--whole-archive ../../../../src/gallium/auxiliary/.libs/libgallium.a ../../../../src/gallium/drivers/identity/.libs/libidentity.a ../../../../src/gallium/drivers/trace/.libs/libtrace.a ../../../../src/gallium/drivers/rbug/.libs/librbug.a ../../../../src/gallium/state_trackers/egl/.libs/libegl.a ../../../../src/loader/.libs/libloader.a ../../../../src/gallium/winsys/sw/xlib/.libs/libws_xlib.a ../../../../src/mesa/.libs/libmesagallium.a ../../../../src/gallium/state_trackers/vega/.libs/libvega.a ../../../../src/gallium/drivers/softpipe/.libs/libsoftpipe.a ../../../../src/gallium/drivers/llvmpipe/.libs/libllvmpipe.a -Wl,--no-whole-archive  -L/var/tmp/portage/media-libs/mesa-10.1.1/work/Mesa-10.1.1-amd64/src/gbm/.libs -L/var/tmp/portage/media-libs/mesa-10.1.1/work/Mesa-10.1.1-amd64/src/mapi/shared-glapi/.libs -L/usr/lib64 -Wl,--as-needed -L/var/tmp/portage/media-libs/mesa-10.1.1/image//usr/lib64 -lEGL -lX11-xcb -lxcb-dri2 -lxcb-xfixes -lxcb-render -lxcb-shape -lxcb -lX11 -lXext -lXfixes -lgbm -ludev -ldrm -lglapi -lOpenVG -lz -lpthread -lffi -lcurses -ldl -lLLVM-3.4.1 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/lib -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/crtendS.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../lib64/crtn.o  -march=amdfam10 -O2 -Wl,--no-undefined -Wl,--allow-multiple-definition -Wl,-O1 -Wl,--version-script=../../../../src/gallium/targets/egl-static/egl.link   -pthread -Wl,-soname -Wl,egl_gallium.so -o .libs/egl_gallium.so
.libs/egl.o: In function `create_drm_screen':
egl.c:(.text+0x57): undefined reference to `_eglLog'
egl.c:(.text+0xa7): undefined reference to `_eglLog'

Reproducible: Always




emerge --info:

Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.19, 3.14.2-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.14.2-gentoo-x86_64-AMD_Phenom-tm-_II_X4_945_Processor-with-gentoo-2.2
KiB Mem:     4045216 total,   2124780 free
KiB Swap:    1048572 total,   1035272 free
Timestamp of tree: Sat, 10 May 2014 01:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6-r1, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
INSTALL_MASK="/usr/lib/systemd /usr/lib64/firefox/browser/searchplugins"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aacs acl acpi alsa amd64 aspell audiofile bash-completion berkdb bluray branding bzip2 cairo caps cdda cddb cdparanoia cdr cli consolekit cracklib crypt cryptsetup css cups cxx dbus dga djvu dri dts dv dvb dvd dvdr emboss encode exif faac fam fbcon fbcondecor ffmpeg firefox flac foomaticdb ftp gcj gdbm gif gimp glamor gnome-keyring gnutls gpg gpm gtk gzip hddtemp hunspell iconv idn imagemagick imap ipod ipv6 jbig jpeg jpeg2k justify latex lcms ldap libnotify libsamplerate lirc lm_sensors lock lzma lzo mad maildir matroska mbox mikmod mime mms mmx mng modemmanager modplug modules mozilla mp3 mp4 mpeg multilib musicbrainz ncurses networkmanager nls nntp nptl nsplugin ntp ogg openal openexr opengl openmp opus pam pango pcre pdf pkcs11 png policykit posix postscript ppds qt3support quicktime raw readline rss rtmp rtsp scanner schroedinger sdl session sndfile sound speex spell sse sse2 sse3 ssl ssse3 startup-notification svg syslog taglib tcpd theora threads thunar tiff timidity tk truetype udev udisks unicode upower usb uvm v4l vcd vdpau vorbis wavpack webp win32codecs wmf wxwidgets x264 xcb xcomposite xface xft xml xorg xpm xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ice1712" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" LIRC_DEVICES="devinput" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


emerge -pqv '=media-libs/mesa-10.1.1::gentoo':
[ebuild     U ] media-libs/mesa-10.1.1 [10.1.0] USE="classic dri3 egl gallium gbm gles1 gles2 llvm nptl openvg osmesa vdpau xa xvmc -bindist -debug -opencl -pax_kernel -pic -r600-llvm-compiler (-selinux) -wayland (-llvm-shared-libs%*)" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware"
Comment 1 Heiko Baums 2014-05-10 18:39:09 UTC
Created attachment 376662 [details]
build.log.bz2
Comment 2 Jeroen Roovers gentoo-dev 2014-05-10 18:40:45 UTC

*** This bug has been marked as a duplicate of bug 501328 ***