Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 509498 - >=net-dialup/freeradius-3.0.2 - parallel make install fails
Summary: >=net-dialup/freeradius-3.0.2 - parallel make install fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Keywords: NeedPatch, UPSTREAM
: 601554 (view as bug list)
Depends on:
Blocks: parallel-make
  Show dependency tree
Reported: 2014-05-03 19:04 UTC by Kobboi
Modified: 2021-12-15 14:19 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2014-05-03 19:04:56 UTC
>>> Install freeradius-3.0.2 into /var/tmp/portage/net-dialup/freeradius-3.0.2/image/ category net-dialup
make -j4 R=/var/tmp/portage/net-dialup/freeradius-3.0.2/image/ install 
INSTALL rbmonkey
mkdir: cannot create directory ‘/var/tmp/portage/net-dialup/freeradius-3.0.2/image//usr/lib64’: File exists
scripts/ recipe for target '/var/tmp/portage/net-dialup/freeradius-3.0.2/image//usr/lib64/' failed
make: *** [/var/tmp/portage/net-dialup/freeradius-3.0.2/image//usr/lib64/] Error 1
make: *** Waiting for unfinished jobs....

No problem after setting MAKEOPTS="-j1"

Reproducible: Always
Comment 1 Kobboi 2014-05-03 19:13:31 UTC
Also, in src_prepare()

rm: cannot remove ‘src/modules/rlm_sql/drivers/rlm_sql_sybase’: No such file or directory
rm: cannot remove ‘libltdl’: No such file or directory
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2014-05-03 19:32:46 UTC
I dropped all the 2.2.0/2.2.5 patches and I didn't reimplement them for 3.0.2 yet. It looks like it should at least get the pkglibdir patch here.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2014-05-03 21:58:05 UTC
I've set emake -j1 ... install to work around this problem, and I have also tried to make sure the build system doesn't generate and install certificates.

It still installs all modules both static and dynamic, and it is impossible to tell configure/make to do otherwise, so this requires a patch. The 2.* branch installs modules to $libdir/$PN/ whereas a new patch is required to mae 3.* do the same. Right now everything ends up as $libdir/rlm_*.{a,so}.

And I dropped KEYWORDS for now.
Comment 4 Matt Turner gentoo-dev 2016-11-26 22:30:37 UTC
Should be fixed by

commit 8c83c3611244c719b89282aefd2738cbb1631d91
Author: Matt Turner <>
Date:   Wed Nov 23 10:08:13 2016 -0800

    net-dialup/freeradius: Allow parallel make.
Comment 5 Pacho Ramos gentoo-dev 2016-12-05 09:33:09 UTC
*** Bug 601554 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2016-12-05 09:33:31 UTC
it seems to still fail :/
Comment 7 Matt Turner gentoo-dev 2016-12-05 19:20:49 UTC
Dang. Thanks for reopening. Reverted the offending commit with 

commit 4a9039a4eceaa41719cfd119e6e990699cce767c
Author: Matt Turner <>
Date:   Mon Dec 5 11:19:38 2016 -0800

    net-dialup/freeradius: Revert "Allow parallel make."
Comment 8 Kobboi 2016-12-05 19:35:27 UTC
Uhm, not sure but how does reverting your attempted fix resolve this issue?
Comment 9 Matt Turner gentoo-dev 2016-12-05 19:37:23 UTC
(In reply to Kobboi from comment #8)
> Uhm, not sure but how does reverting your attempted fix resolve this issue?

Apologies. You're correct, the bug should still be open... I guess.

It's clearly an upstream issue.
Comment 10 Matt Turner gentoo-dev 2016-12-15 01:56:53 UTC
I am not planning to look into this, since it seems like it requires build system changes.
Comment 11 Xander 2017-04-29 10:30:33 UTC
Would the fix from version 3.0.12-r1 be helpfull to fix 3.0.13? 

As i found at:
Comment 12 Michael Palimaka (kensington) gentoo-dev 2017-05-01 13:00:57 UTC
(In reply to Xander from comment #11)
> Would the fix from version 3.0.12-r1 be helpfull to fix 3.0.13? 
> As i found at:
> freeradius-3.0.12-r1.ebuild?id=4a9039a4eceaa41719cfd119e6e990699cce767c

3.0.13 already has -j1 for install in the same place - does compiling also fail in parallel?
Comment 13 Xander 2017-05-01 15:19:37 UTC
@ Michael Palimaka (kensington)

At first it seemed to fail at the same place but i now noticed that it files during compile time. So i probably need to create a separate bug report for this. Sorry for bothering.
Comment 14 Geaaru 2018-10-13 21:48:21 UTC

as shared on ml I will take care of freeradius package as proxy maintainer.

FWIK after set "emake -j1" (present on both 3.0.15 and 3.0.17 on upstream) this issue is fixed.

We could considered fixed this issue ?

Comment 15 Pacho Ramos gentoo-dev 2018-10-14 07:55:00 UTC
Well, usually we keep that bugs opened as it's more a workaround than a fix... the idea would be to at least report it to upstream and paste here the bug to track the progress.
Comment 16 Geaaru 2019-06-05 14:02:13 UTC
Created upstream issue:
Comment 17 Jonas Stein gentoo-dev 2020-11-15 00:35:54 UTC
fixed upstream in ?
Comment 18 Kobboi 2021-07-01 09:35:38 UTC
No, removing the workaround from the 3.0.22-r2 ebuild, I can still reproduce immediately