Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 509418 - nvidia breaks bumblebee
Summary: nvidia breaks bumblebee
Status: RESOLVED DUPLICATE of bug 508196
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: Other Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-02 21:19 UTC by Bruno Santos
Modified: 2014-05-02 21:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Santos 2014-05-02 21:19:49 UTC
Hi ! 
I've been struggling with NVIDIA, ACPI and bumblebee for a few days now...

I have an Asus N56VM, Intel i7 with an Optimus Nvidia card GT-630M and using Gentoo kernel 3.12.13

My /var/log/messages has been filling up with messages like:
---
y  2 22:14:23 nightcrawler kernel: [  576.558850] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
May  2 22:14:23 nightcrawler kernel: [  576.558882] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
May  2 22:14:23 nightcrawler kernel: [  576.558882] NVRM: installed in this system is not supported by the 334.21
May  2 22:14:23 nightcrawler kernel: [  576.558882] NVRM: NVIDIA Linux driver release.  Please see 'Appendix
May  2 22:14:23 nightcrawler kernel: [  576.558882] NVRM: A - Supported NVIDIA GPU Products' in this release's
May  2 22:14:23 nightcrawler kernel: [  576.558882] NVRM: README, available on the Linux driver download page
May  2 22:14:23 nightcrawler kernel: [  576.558882] NVRM: at www.nvidia.com.
May  2 22:14:23 nightcrawler kernel: [  576.558892] nvidia: probe of 0000:01:00.0 failed with error -1
May  2 22:14:23 nightcrawler kernel: [  576.559091] NVRM: The NVIDIA probe routine failed for 1 device(s).
May  2 22:14:23 nightcrawler kernel: [  576.559093] NVRM: None of the NVIDIA graphics adapters were initialized!
May  2 22:14:23 nightcrawler kernel: [  576.559095] [drm] Module unloaded
May  2 22:14:23 nightcrawler kernel: [  576.559167] NVRM: NVIDIA init module failed!
----
and 

----

May  2 22:14:55 nightcrawler kernel: [  608.766526] nvidia 0000:01:00.0: irq 46 for MSI/MSI-X
May  2 22:14:55 nightcrawler kernel: [  608.775367] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775420] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775481] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775509] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775535] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775561] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775621] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.775648] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.776050] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.901313] nvidia 0000:01:00.0: irq 46 for MSI/MSI-X
May  2 22:14:55 nightcrawler kernel: [  608.910149] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910201] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910264] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910292] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910318] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910344] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910404] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910431] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
May  2 22:14:55 nightcrawler kernel: [  608.910826] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)

----

If I stop bumblebee the nvidia messages stop, but the ACPI messages keep showing up...


I've tried to update nvidia-drivers and bumblebee - even VirtualGL, but nothing helps...
Comment 1 Jeroen Roovers gentoo-dev 2014-05-02 21:33:43 UTC

*** This bug has been marked as a duplicate of bug 508196 ***