Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508678 - sys-kernel/genkernel initramfs with lvm raid and systemd fails to boot
Summary: sys-kernel/genkernel initramfs with lvm raid and systemd fails to boot
Status: RESOLVED DUPLICATE of bug 479730
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: genkernel (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-25 14:15 UTC by Piergiorgio Beruto
Modified: 2014-04-26 13:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piergiorgio Beruto 2014-04-25 14:15:43 UTC
I'm running a gentoo system with raid + lvm and a separate /usr partition.
Using openRC everything works fine.

When using systemd the initramfs won't boot because the default linuxrc script would test the presence of "/dev" and "init" in the NEWROOT at a time the /usr partition has not been mounted yet (and "systemd" which replaces "init" resides in /usr).

I've tried modifying the linuxrc removing the "init" sanity check (ugly hack) and the system booted OK.

I've tried also to anticipate the /usr mount so that the test is OK and this worked also but I am not sure of any possible drawback of this on different configurations.
Comment 1 Jeroen Roovers gentoo-dev 2014-04-25 14:56:21 UTC
*** Bug 508686 has been marked as a duplicate of this bug. ***
Comment 2 Mike Gilbert gentoo-dev 2014-04-26 13:04:02 UTC

*** This bug has been marked as a duplicate of bug 479730 ***