Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508418 - sys-devel/gcc-4.9.0 version bump
Summary: sys-devel/gcc-4.9.0 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Toolchain Maintainers
URL: http://gcc.gnu.org/gcc-4.9/
Whiteboard:
Keywords:
: 508484 (view as bug list)
Depends on: 494228 508364 PR61164
Blocks: 508152 508420
  Show dependency tree
 
Reported: 2014-04-22 15:32 UTC by Agostino Sarubbo
Modified: 2014-05-18 08:33 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-04-22 15:32:58 UTC
I know that you follow upstream and you are aware of it. This is just for tracking.
Comment 1 salamanderrake 2014-04-22 22:45:16 UTC
see https://bugs.gentoo.org/show_bug.cgi?id=gcc-4.9
Comment 2 Agostino Sarubbo gentoo-dev 2014-04-23 11:14:10 UTC
*** Bug 508484 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2014-05-01 05:56:57 UTC
Patchset has been ported, but there's a few more I still want to add.  The poison-directories patch is disabled for now waiting on an update from openembedded.

Magnus can you update the pie patches?
Comment 4 Magnus Granberg gentoo-dev 2014-05-11 22:23:12 UTC
(In reply to Ryan Hill from comment #3)
> Patchset has been ported, but there's a few more I still want to add.  The
> poison-directories patch is disabled for now waiting on an update from
> openembedded.
> 
> Magnus can you update the pie patches?
Will add the pie patches and enable ssp strong
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2014-05-12 02:32:09 UTC
Okay, but I might have to ask for your expertise if we run into any porting bugs with strong. ;)
Comment 6 Magnus Granberg gentoo-dev 2014-05-12 15:55:28 UTC
(In reply to Ryan Hill from comment #5)
> Okay, but I might have to ask for your expertise if we run into any porting
> bugs with strong. ;)
Do you hit the fortify prob on libitm #508852?
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2014-05-12 23:50:18 UTC
I don't know, I haven't done a bootstrap yet.  I was hoping debian/ubuntu would report it upstream and we could get a proper fix but I don't see anything.
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2014-05-13 01:04:46 UTC
BTW, on your next bump could you make all patches apply with -p1?  Also, we no longer regenerate info files from texi, so doc changes need to be made directly to gcc.info (if you're using git, you'll need to remove *.info from the toplevel .gitignore and add the files before making changes).  No need to do this now, just something to keep in mind.
Comment 9 Ryan Hill (RETIRED) gentoo-dev 2014-05-18 08:33:35 UTC
Fixed.