Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 507232 - sys-apps/dbus-1.8.0 USE=debug (--enable-stats) - In function ‘bus_stats_handle_get_stats’: .../work/dbus-1.8.0/bus/stats.c:51:57: error: dereferencing pointer to incomplete type
Summary: sys-apps/dbus-1.8.0 USE=debug (--enable-stats) - In function ‘bus_stats_handl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Low normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-09 11:20 UTC by Alpha Bravo
Modified: 2014-07-24 12:16 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,264.20 KB, text/plain)
2014-04-09 11:32 UTC, Alpha Bravo
Details
build.log for 1.8.4 (no-multilib) (build.log,274.85 KB, text/plain)
2014-07-01 13:03 UTC, igel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alpha Bravo 2014-04-09 11:20:12 UTC
Reproducible: Always

Steps to Reproduce:
1.USE="debug" emerge -1v sys-apps/dbus
2.
3.
Actual Results:  
 * ERROR: sys-apps/dbus-1.8.0::gentoo failed (compile phase):
 *   emake failed

Expected Results:  
compilation works

emerge --info
Portage 2.2.10 (hardened/linux/amd64/selinux, gcc-4.8.2, glibc-2.19, 3.13.8-hardened-r2 x86_64)                                                                                                                   
=================================================================                                                                                                                                                 
System uname: Linux-3.13.8-hardened-r2-x86_64-AMD_E-350_Processor-with-gentoo-2.2                                                                                                                                 
KiB Mem:     3632588 total,   2867620 free                                                                                                                                                                        
KiB Swap:    4718588 total,   4718588 free                                                                                                                                                                        
Timestamp of tree: Wed, 09 Apr 2014 06:15:01 +0000                                                                                                                                                                
ld GNU ld (GNU Binutils) 2.24                                                                                                                                                                                     
app-shells/bash:          4.2_p46-r1                                                                                                                                                                              
dev-lang/python:          2.7.6, 3.3.5, 3.4.0                                                                                                                                                                     
dev-util/cmake:           2.8.12.2                                                                                                                                                                                
dev-util/pkgconfig:       0.28-r1                                                                                                                                                                                 
sys-apps/baselayout:      2.2                                                                                                                                                                                     
sys-apps/openrc:          0.12.4                                                                                                                                                                                  
sys-apps/sandbox:         2.6-r1                                                                                                                                                                                  
sys-devel/autoconf:       2.13, 2.69                                                                                                                                                                              
sys-devel/automake:       1.11.6, 1.14.1                                                                                                                                                                          
sys-devel/binutils:       2.24-r2                                                                                                                                                                                 
sys-devel/gcc:            4.8.2                                                                                                                                                                                   
sys-devel/gcc-config:     1.8                                                                                                                                                                                     
sys-devel/libtool:        2.4.2                                                                                                                                                                                   
sys-devel/make:           4.0-r1                                                                                                                                                                                  
sys-kernel/linux-headers: 3.14 (virtual/os-headers)                                                                                                                                                               
sys-libs/glibc:           2.19                                                                                                                                                                                    
Repositories: gentoo                                                                                                                                                                                              
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                                                                                                    
ACCEPT_LICENSE="* -@EULA"                                                                                                                                                                                         
CBUILD="x86_64-pc-linux-gnu"                                                                                                                                                                                      
CFLAGS="-march=btver1 -O2 -pipe"                                                                                                                                                                                  
CHOST="x86_64-pc-linux-gnu"                                                                                                                                                                                       
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"                                                                                                                                                              
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"                                                  
CXXFLAGS="-march=btver1 -O2 -pipe"                                                                                                                                                                                
DISTDIR="/usr/portage/distfiles"                                                                                                                                                                                  
FCFLAGS="-O2 -pipe"                                                                                                                                                                                               
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/"
INSTALL_MASK="/lib/systemd /lib32/systemd /lib64/systemd /usr/lib/systemd /usr/lib32/systemd /usr/lib64/systemd /etc/systemd"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync11.de.gentoo.org/gentoo-portage/"
USE="X a52 aac alsa amd64 berkdb bindist bzip2 cli cracklib crypt cxx dbus dri dts ffmpeg gdbm hardened iconv ipv6 jpeg justify mad mmx mmxext modules mp3 mp4 mpeg multilib ncurses nls nptl ogg open_perms opengl openmp pam pax_kernel pcre readline sdl selinux session sse sse2 sse3 ssl ssse3 tcpd theora udev unicode urandom vdpau vorbis x264 xattr xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Alpha Bravo 2014-04-09 11:32:47 UTC
Created attachment 374590 [details]
build.log
Comment 2 Alpha Bravo 2014-04-09 11:33:36 UTC
emerge -pqv sys-apps/dbus
[ebuild     U ] sys-apps/dbus-1.8.0 [1.6.18-r1] USE="X debug (selinux) -doc -static-libs -systemd {-test}" ABI_X86="(64) -32 (-x32)"
Comment 3 Alpha Bravo 2014-04-09 11:53:42 UTC
selinux is in permissive mode
Comment 4 Binary Runner 2014-05-27 21:32:46 UTC
I'm getting the same error both for 1.8.0 and 1.8.2 - unmasked as ~amd64, multilib system. 

Used disabling of debug and stats in package.use as workaround: "sys-apps/dbus -debug -stats" .
Comment 5 Alpha Bravo 2014-05-29 13:38:49 UTC
problem persists here, too, with sys-apps/dbus-1.8.2
Comment 6 igel 2014-07-01 12:58:36 UTC
I have the same problem with sys-apps/dbus-1.8.4 on default/linux/amd64/13.0/no-multilib.
Comment 7 igel 2014-07-01 13:03:12 UTC
Created attachment 380038 [details]
build.log for 1.8.4 (no-multilib)
Comment 8 igel 2014-07-01 13:12:41 UTC
Oh, I forgot to mention: after the emerge failed, I did

cd /var/tmp/portage/portage/sys-apps/dbus-1.8.4/work/dbus-1.8.4 ; ./configure ; make

which _did_ compile dbus and there's even a bus/stats.o so this excludes patches I guess, leaving the ebuild as possible source of errors if I am not mistaken...
Comment 9 igel 2014-07-01 13:26:44 UTC
ah well, turns out that ./configure --enable-stats ; make  doesn't compile, so the successful compile before was just due to removed stats, sorry for spamming
Comment 10 Richard H. 2014-07-24 01:15:57 UTC
Still broken in 1.8.6 - I really would need the stats for debugging an upstream problem. How to fix this?
Comment 11 Richard H. 2014-07-24 11:56:50 UTC
I received this patch from upstream:

https://bugs.freedesktop.org/attachment.cgi?id=103382

It worked by using epatch_user() which fixed the issue.
Comment 12 Samuli Suominen gentoo-dev 2014-07-24 12:07:51 UTC
(In reply to Richard H. from comment #11)
> I received this patch from upstream:
> 
> https://bugs.freedesktop.org/attachment.cgi?id=103382
> 
> It worked by using epatch_user() which fixed the issue.

What's the upstream bug number?
Comment 13 Richard H. 2014-07-24 12:11:13 UTC
(In reply to Samuli Suominen from comment #12)
> (In reply to Richard H. from comment #11)
> > I received this patch from upstream:
> > 
> > https://bugs.freedesktop.org/attachment.cgi?id=103382
> > 
> > It worked by using epatch_user() which fixed the issue.
> 
> What's the upstream bug number?

https://bugs.freedesktop.org/show_bug.cgi?id=81043

But it's not really related.
Comment 14 Samuli Suominen gentoo-dev 2014-07-24 12:11:43 UTC
found it. 

https://bugs.freedesktop.org/show_bug.cgi?id=81043#c4
Comment 15 Samuli Suominen gentoo-dev 2014-07-24 12:16:16 UTC
in portage,

+  24 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+  +files/dbus-1.8.6-enable-stats_compile_failure.patch, dbus-1.8.6.ebuild:
+  Fix building with USE="debug" using a patch from upstream bugzilla wrt
+  #507232. Thanks to Richard H. and "Alpha Bravo" for reporting.

sorry for delay, this simply wasn't a high priority bug for me (USE="debug" in general)