Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 50700 - Something has killed GNOME sounds
Summary: Something has killed GNOME sounds
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 54281 54435 (view as bug list)
Depends on:
Reported: 2004-05-10 21:25 UTC by Vermyndax
Modified: 2004-07-20 02:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Vermyndax 2004-05-10 21:25:27 UTC
Something introduced over the weekend to portage (and I'm sorry, but I'm not sure what) has killed the ability for GNOME to play sounds for desktop events.

I emerge-sync'd, then emerge -up world...

Afterwards, the only sounds that would play are the login and logout sounds.  Trying to preview a sound with the desktop preferences --> sound applet produces no results.

There are no errors logged in /var/log/messages

Going to command mode and doing a manual "aplay <whatever>" works fine... the sound plays, so I know alsa is working.

All other apps work fine... XMMS, TVTime, etc.

I wish I knew more to tell you...

Reproducible: Always
Steps to Reproduce:
Comment 1 foser (RETIRED) gentoo-dev 2004-05-11 03:28:53 UTC
gnome uses esd to play sounds, it might be interfering with our alsa stuff in some way (blocking out eachother). Is esd running ? Do other apps that explicitly use esd work ?
Comment 2 Vermyndax 2004-05-11 05:40:43 UTC
Yes, esd is running:

asteria-linux init.d # ps ax | grep esd
16761 ?        Ss     0:00 /usr/bin/esd -terminate -nobeeps -as 2 -spawnfd 37
23349 pts/0    S+     0:00 grep esd

Any way I can specifically test esd's sound capabilities aside from hearing the login/logout sounds when I come in and out of GNOME?  That works fine - it's all of the desktop sounds while inside GNOME that do not work.
Comment 3 Vermyndax 2004-05-14 07:08:53 UTC
Alright... more info here.

I have a workstation at work that I haven't done an "emerge -u world" for a while.  I decided to try doing it on this machine to see if it exhibited the same behavior.  And guess what?  After an emerge -u world, the sound is now broken on this machine as well.

Here's the emerge -Dup world results:

Emerge before breaking sound:

miranda-linux root # emerge -Dup world
These are the packages that I would merge, in order:
Calculating world dependencies ...done!
[ebuild     U ] sys-apps/coreutils-5.2.0-r2 [5.2.0-r1]
[ebuild     U ] sys-devel/libperl-5.8.4 [5.8.3]
[ebuild     U ] dev-lang/perl-5.8.4 [5.8.3]
[ebuild     U ] sys-devel/gcc-config-1.3.5-r1 [1.3.5]
[ebuild     U ] sys-apps/shadow- []
[ebuild     U ] sys-apps/baselayout-1.9.1 [1.8.12]
[ebuild     U ] sys-apps/man-1.5m-r1 [1.5m]
[ebuild     U ] dev-libs/glib-2.4.1 [2.4.0]
[ebuild     U ] media-libs/libpng-1.2.5-r5 [1.2.5-r4]
[ebuild     U ] x11-libs/gtk+-2.4.1 [2.4.0-r1]
[ebuild     U ] gnome-base/libgnomecanvas- [2.6.0]
[ebuild     U ] app-crypt/mit-krb5-1.3.3 [1.3.1]
[ebuild     U ] gnome-base/libgnome- [2.6.0]
[ebuild     U ] gnome-base/libgnomeui- [2.6.0]
[ebuild     U ] gnome-base/libgtop-2.6.0 [2.5.2]
[ebuild     U ] gnome-extra/libgsf-1.9.0 [1.8.2]
[ebuild     U ] gnome-base/librsvg-2.6.5 [2.6.4]
[ebuild     U ] x11-libs/libwnck-2.6.1 []
[ebuild     U ] gnome-extra/libgtkhtml-2.6.1 [2.6.0]
[ebuild     U ] sys-apps/module-init-tools-3.0-r2 [3.0]
[ebuild  N    ] media-video/nvidia-kernel-1.0.5336-r3
[ebuild  N    ] dev-libs/libsigc++-2.0.1
[ebuild  N    ] dev-cpp/glibmm-2.4.1
[ebuild  N    ] dev-cpp/gtkmm-2.4.1
[ebuild     U ] dev-cpp/gconfmm-2.6.1 [2.0.1]
[ebuild     U ] app-crypt/heimdal-0.6.2 [0.6.1]
[ebuild     U ] app-editors/vim-core-6.2-r9 [6.2-r8]
[ebuild     U ] app-editors/vim-6.2-r9 [6.2-r8]
[ebuild     U ] net-im/gaim-0.77-r2 [0.77]
[ebuild     U ] app-office/gnucash-1.8.9 [1.8.8]
[ebuild     U ] sys-apps/diffutils-2.8.7 [2.8.4-r4]
[ebuild     U ] sys-fs/reiserfsprogs-3.6.16 [3.6.13]
[ebuild  N    ] app-text/recode-3.6-r1
[ebuild     UD] games-misc/fortune-mod-1.99.1 [9708-r1]
[ebuild     U ] games-misc/fortune-mod-dubya-20040506 [20031125]
[ebuild     U ] net-analyzer/gnome-netstatus-2.6.1 []
[ebuild     U ] x11-wm/metacity-2.8.1 [2.8.0]
[ebuild     U ] x11-libs/gtksourceview-1.0.1 [1.0.0]
[ebuild     U ] app-editors/gedit-2.6.1 [2.6.0]
[ebuild     U ] gnome-extra/gnome-media-2.6.1 [2.6.0]
[ebuild     U ] gnome-extra/gnome-games-2.6.1 []
[ebuild     U ] net-www/epiphany-1.2.5 [1.2.3]
[ebuild     U ] gnome-extra/bug-buddy-2.6.1 [2.6.0]
[ebuild     U ] app-text/ggv-2.6.1 [2.6.0]
[ebuild     U ] dev-cpp/libglademm-2.4.0 [2.0.1]
[ebuild     U ] dev-cpp/libgnomecanvasmm-2.6.0 [2.0.1]
[ebuild  N    ] dev-cpp/libgnomemm-2.6.0
[ebuild  N    ] dev-cpp/gnome-vfsmm-2.6.1
[ebuild  N    ] dev-cpp/libgnomeuimm-2.6.0
[ebuild     U ] x11-wm/openbox-3.2-r1 [3.2]


So I ran the emerge -Du world... afterwards, I had to do an etc-update, which I did.  It updated the following:


miranda-linux root # etc-update
Scanning Configuration files...
Automerging trivial changes in: bootmisc
Automerging trivial changes in: checkfs
Automerging trivial changes in: checkroot
Automerging trivial changes in: clock
Automerging trivial changes in: consolefont
Automerging trivial changes in: crypto-loop
Automerging trivial changes in: domainname
Automerging trivial changes in:
Automerging trivial changes in: hostname
Automerging trivial changes in: keymaps
Automerging trivial changes in: local
Automerging trivial changes in: modules
Automerging trivial changes in: net.lo
Automerging trivial changes in: netmount
Automerging trivial changes in: nscd
Automerging trivial changes in: numlock
Automerging trivial changes in:
Automerging trivial changes in: rmnologin
Automerging trivial changes in: serial
Automerging trivial changes in:
Automerging trivial changes in: urandom
The following is the list of files which need updating, each
configuration file is followed by a list of possible replacement files.
1) /etc/DIR_COLORS
2) /etc/gentoo-release
3) /etc/man.conf
4) /etc/init.d/localmount
5) /etc/init.d/net.eth0
6) /etc/sound/events/gataxx.soundlist
7) /etc/sound/events/gnect.soundlist
8) /etc/sound/events/gnibbles.soundlist
9) /etc/sound/events/gnobots2.soundlist
10) /etc/sound/events/gnome-2.soundlist
11) /etc/sound/events/gtk-events-2.soundlist
12) /etc/sound/events/iagno.soundlist
Please select a file to edit by entering the corresponding number.
              (-1 to exit) (-3 to auto merge all remaining files)
                           (-5 to auto-merge AND not use 'mv -i'):


I did a -5 since none of these were necessarily bad for my system's health.

...and voila, my desktop sound events are now broken.  The login/logout events work but none of the others do... even if I try to force playing them in the sound configuration parameters of GNOME they don't play.

ESD is running here as well...

So one of those packages in my emerge update broke it...
Comment 4 Yi Quang (RETIRED) gentoo-dev 2004-05-14 07:18:05 UTC
10) /etc/sound/events/gnome-2.soundlist
11) /etc/sound/events/gtk-events-2.soundlist

(I don't use system sounds so this is a rough guess) I think those two files may have affected your sounds, doing a -5 is never a good idea. If you can, find out what changed in those 2 files and try to either revert or merge the changes manually.  
Comment 5 Vermyndax 2004-05-14 14:55:52 UTC
I tried re-emerging gnome-media and gnome-sounds... downgraded them and did an etc-update to replace the sound list files that came with those sources, but it did not fix the problem.  The system continued to exhibit the same issues with GNOME desktop sounds.

I have noticed several other people with the same problem as me:

There is definitely a broken ebuild here that came out early this month that screwed something up... please investigate... I know it seems superficial to be wanting these sounds, but that newmail sound event is really really useful when you use an inbox checker.
Comment 6 Vermyndax 2004-05-14 15:03:31 UTC
Even more information... I have reupgraded those packages, sound still dead.

I went to the console and did:

cd /usr/share/sounds
esdplay info.wav

...and the sound plays fine.

If I do:


...and go to the sounds applet, I can play the sounds fine from inside there.  The sounds even play when I'm clicking around in there.

However, the sounds do *not* work anywhere else... I try them from anyplace else  in the environment and they don't work.  WEEEIRD.
Comment 7 Vermyndax 2004-05-14 17:17:57 UTC
Looks like this is a GNOME bug, not a Gentoo bug...

Two users in Slackware and Debian report the same problems.
Comment 8 foser (RETIRED) gentoo-dev 2004-05-15 11:14:46 UTC
seems to be a patch introduced in libgnome-
Comment 9 Vermyndax 2004-05-15 11:19:14 UTC
Oh, good... that'll be good to hear :)  har har har...

I'll keep an eye out for an updated libgnome in portage...
Comment 10 foser (RETIRED) gentoo-dev 2004-05-15 11:57:03 UTC
don't speak on our behalf upstream ok, we do that ourselves if we think it's needed. It's a patch _introduced_ in libgnome that broke this.

What is your 'emerge info' btw... you didn't provide that either.
Comment 11 Vermyndax 2004-05-15 12:09:05 UTC
Ooooookie, sorry about that...

emerge info:

Portage 2.0.50-r6 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3_pre20040420-r0, 2.6.5-gentoo-r1)
System uname: 2.6.5-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.26GHz
Gentoo Base System version 1.4.12
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="X aim alsa apm avi berkdb cjk crypt cups divx4linux dvb dvd encode esd ffmpeg foomaticdb gdbm gif gimpprint glade gnome gpm gstreamer gtk gtk2 gtkhtml imagemagick imlib jabber java jpeg kerberos ldap libg++ libwww mad mikmod mmx motif mozilla moznocompose moznoirc moznomail mpeg mpeg4 msn music ncurses nls nvidia offensive oggvorbis opengl oscar oss pam pdflib perl png python qt quicktime readline samba sdl slang spell sse ssl stencil-buffer svga tcltk tcpd tiff transcode truetype v4l v4l2 x86 xml2 xmms xv yahoo zlib"
Comment 12 m3x 2004-06-06 00:52:05 UTC
Same problem on my ibook. No sound at GNOME startup and from the apps. GAIM has no sound problems. From terminal esdplay 0815.wav is ok.

My emerge info:

Portage 2.0.50-r7 (default-ppc-2004.1, gcc-3.3.3, glibc-2.3.3_pre20040420-r1, 2.6.4-pegasos0)
System uname: 2.6.4-pegasos0 ppc 750FX
Gentoo Base System version 1.4.15
distcc 2.13 powerpc-unknown-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
CFLAGS="-O3 -pipe -mcpu=750 -fsigned-char -mpowerpc-gfxopt -fno-strict-aliasing"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -pipe -mcpu=750 -fsigned-char -mpowerpc-gfxopt -fno-strict-aliasing"
USE="X aalib alsa arts audiofile berkdb bonobo cdr crypt cups directfb dvd encode esd fbcon flac flash foomaticdb gdbm gif gnome gnome-libs gnomedb gphoto2 gpm gstreamer gtk gtk2 gtkhtml imap imlib java jpeg kde libgda libwww linguas_de linguas_pl mad maildir mitshm motif mozilla moznocompose moznoirc moznomail mozsvg mpeg nas ncurses nls nptl oggvorbis opengl oss pam pda perl png ppc ppds python qt quicktime radeon readline samba scanner sdl slang slp spell ssl tcpd tetex tiff truetype usb vim-with-x xinerama xml xml2 xv zlib"
Comment 13 foser (RETIRED) gentoo-dev 2004-06-19 13:16:28 UTC
*** Bug 54435 has been marked as a duplicate of this bug. ***
Comment 14 Vermyndax 2004-07-18 09:03:17 UTC
This is marked as resolved upstream... but I just updated my GNOME yesterday (7-17-04) and it's still not working correctly...
Comment 15 foser (RETIRED) gentoo-dev 2004-07-19 05:06:50 UTC
reopen .. patch needs to be added to libgnomeui
Comment 16 foser (RETIRED) gentoo-dev 2004-07-19 05:10:18 UTC
*** Bug 54281 has been marked as a duplicate of this bug. ***
Comment 17 foser (RETIRED) gentoo-dev 2004-07-19 05:44:40 UTC
patch added to libgnome- please test & see if that solves the problems.
Comment 18 Han Pilmeyer 2004-07-19 13:08:11 UTC
It fixes my problem with sounds in evolution. Thanks!
Comment 19 Vermyndax 2004-07-19 18:44:58 UTC
Verified that it's fixed for me as well... thanks!
Comment 20 foser (RETIRED) gentoo-dev 2004-07-20 02:18:50 UTC
ok added revision added to 2.6.1 & 2.6.2 meta