Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506684 - mail-client/evolution-3.* crashed without gnome-base/dconf installed
Summary: mail-client/evolution-3.* crashed without gnome-base/dconf installed
Status: RESOLVED DUPLICATE of bug 498436
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-03 17:52 UTC by Zentoo
Modified: 2015-01-10 14:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zentoo 2014-04-03 17:52:09 UTC
mail-client/evolution-3.* crashed without gnome-base/dconf installed.

I got two desktop boxes using lxdm/openbox-session without a gnome desktop.

Box 1:
- I use evolution
- I got gnome-base/dconf installed and GSETTINGS_BACKEND=dconf in my environment positionned by /etc/env.d/51dconf.
- gnome-base/dconf is a dependencie of app-emulation/virt-manager-0.10.0-r2 (gtk ? gnome-base/dconf) and not from mail-client/evolution
- Evolution works perfectly.

Box 2:
- I decided to use evolution but it crashed at launch time with a segmentation fault.
- gnome-base/dconf is not installed and GSETTINGS_BACKEND=gconf in this environment positionned by /etc/env.d/50gconf.
- Solution: installation of dconf and take in consideration the new environment to get GSETTINGS_BACKEND=dconf, then evolution works.

So dconf seems to replace gconf on gnome 3 applications and evolution-3.xx needs it. dconf must be a direct dependencie of dconf on desktop not using gnome (at least).
Comment 1 Pacho Ramos gentoo-dev 2014-04-03 20:00:55 UTC
This will probably affect to a lot of other packages relying on glib/dconf schemas, not sure if maybe would be interesting to make it an RDEPEND at gsettings-desktop-schemas, as it is usually in RDEPEND of this kind of packages

@gnome, any thoughts?
Comment 2 Gilles Dartiguelongue gentoo-dev 2014-04-06 11:59:15 UTC
what about running with GSETTINGS_BACKEND="memory" ?
Comment 3 Zentoo 2014-06-10 09:58:05 UTC
(In reply to Gilles Dartiguelongue from comment #2)
> what about running with GSETTINGS_BACKEND="memory" ?

With use of memory backend, you can't use the gnome keyring.
Comment 4 Enrique Domínguez 2014-09-11 23:42:26 UTC
evolution crashed (segfault) without gnome-base/dconf installed...
same here (amd64 lxde desktop)
Comment 5 Pacho Ramos gentoo-dev 2014-09-24 13:18:38 UTC
Please provide a backtrace as I guess evolution should fallback to "memory" if needed
https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
Comment 6 Christophe PEREZ 2015-01-05 03:31:53 UTC
I can confirm all.
I spent hours on thisevolution segfault, and finaly found this bug.

I use evolution under kde on 4 PC. On 3, I have gecko-mediaplayer which require gmtk which require dconf. I forgot to install it on 4th, so evolution segfault.

I just installed dconf, and evolution works like a charm.
Comment 7 Pacho Ramos gentoo-dev 2015-01-10 14:30:24 UTC

*** This bug has been marked as a duplicate of bug 498436 ***