Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506600 - dev-util/valgrind: -m64 is forced when building for ABI=x32
Summary: dev-util/valgrind: -m64 is forced when building for ABI=x32
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: x32
  Show dependency tree
 
Reported: 2014-04-02 19:49 UTC by Luke-Jr
Modified: 2017-11-10 08:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log for dev-util/valgrind-3.8.1 (build.log,64.09 KB, text/plain)
2014-04-02 19:49 UTC, Luke-Jr
Details
emerge --info (emerge--info,19.47 KB, text/plain)
2014-04-03 20:06 UTC, Luke-Jr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke-Jr 2014-04-02 19:49:32 UTC
Created attachment 374110 [details]
build log for dev-util/valgrind-3.8.1

/usr/include/gnu/stubs.h:10:27: fatal error: gnu/stubs-64.h: No such file or directory

stubs.h should probably only include gnu/stubs-x32.h
Comment 1 SpanKY gentoo-dev 2014-04-03 15:06:03 UTC
you already know better -- you must post `emerge --info` in all of your bug reports.  please stop forcing this round trip.
Comment 2 Luke-Jr 2014-04-03 20:06:22 UTC
Created attachment 374194 [details]
emerge --info
Comment 3 EoD 2017-11-10 01:08:07 UTC
If this bug is really about the forced "-m64":

Valgrind uses "-m64" intentionally, because upstream support for x32 is still missing: https://bugs.kde.org/show_bug.cgi?id=344401
Comment 4 Luke-Jr 2017-11-10 08:53:17 UTC
When/if x32 isn't supported, it just shouldn't IUSE the ABI=x32 option.