Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506492 - sys-apps/help2man - configure: error: perl module Locale::gettext required
Summary: sys-apps/help2man - configure: error: perl module Locale::gettext required
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 20:09 UTC by Michael Schubert
Modified: 2014-04-03 11:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,9.81 KB, text/plain)
2014-04-03 08:14 UTC, Rémi Cardona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Schubert 2014-04-01 20:09:58 UTC
Note: this happens on Alt/Prefix but should be applicable to general Gentoo as well.

emerge sys-apps/help2man
>>> Emerging (1 of 1) sys-apps/help2man-1.45.1
 * help2man-1.45.1.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                   [ ok ]
<snip>
configure: error: perl module Locale::gettext required

!!! Please attach the following file when seeking support:
!!! /dev/shm/portage/sys-apps/help2man-1.45.1/work/help2man-1.45.1/config.log
 * ERROR: sys-apps/help2man-1.45.1::gentoo_prefix failed (configure phase):
 *   econf failed


emerge dev-perl/Locale-gettext
<snip>
emerge sys-apps/help2man
<works fine>
Comment 1 Jeroen Roovers gentoo-dev 2014-04-01 23:09:55 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 2 Jeroen Roovers gentoo-dev 2014-04-01 23:10:13 UTC
oh wait
Comment 3 Jeroen Roovers gentoo-dev 2014-04-01 23:11:57 UTC
(In reply to Michael Schubert from comment #0)
> Note: this happens on Alt/Prefix but should be applicable to general Gentoo
> as well.

1) Please post your `emerge --info' output in a comment.

> emerge sys-apps/help2man
> >>> Emerging (1 of 1) sys-apps/help2man-1.45.1
>  * help2man-1.45.1.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...              
> [ ok ]
> <snip>

2) Please attach the entire build log to this bug report.

> configure: error: perl module Locale::gettext required
> 
> !!! Please attach the following file when seeking support:
> !!! /dev/shm/portage/sys-apps/help2man-1.45.1/work/help2man-1.45.1/config.log

3) This ^^
Comment 4 Rémi Cardona gentoo-dev 2014-04-03 08:14:34 UTC
Created attachment 374144 [details]
config.log
Comment 5 Rémi Cardona gentoo-dev 2014-04-03 08:15:12 UTC
Portage 2.2.8-r1 (default/linux/amd64/13.0, gcc-4.8.2, glibc-2.19, 3.13.2-gentoo x86_64)
=================================================================
System uname: Linux-3.13.2-gentoo-x86_64-Intel-R-_Pentium-R-_Dual_CPU_E2180_@_2.00GHz-with-gentoo-2.2
KiB Mem:     2043472 total,    804952 free
KiB Swap:    2066580 total,   2021316 free
Timestamp of tree: Wed, 02 Apr 2014 06:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p46
dev-lang/python:          2.7.6, 3.3.5
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 Q3AEULA AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LANG="fr_FR.utf8"
LDFLAGS="-Wl,-O1,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac alsa amd64 apng avahi bash-completion berkdb bluetooth bzip2 cairo cdda clang cli consolekit cracklib crypt cxx dbus dconf dri dts dvd dvdnav eds encode exif faac faad fontconfig fuse gbm gdbm glamor gnome gnome-keyring gnutls gstreamer gtk gtk3 iconv icu ipv6 jpeg libnotify live matroska mmx modules mp3 mpeg multilib nautilus ncurses networkmanager nls nptl ogg opengl pam pcre png policykit pulseaudio python readline rtsp session spell sse sse2 sse3 ssl ssse3 startup-notification svg systemd tcpd theora threads truetype udev udisks unicode uxa vala vorbis x264 xcb xv zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 6 Rémi Cardona gentoo-dev 2014-04-03 11:38:01 UTC
In my case it was a simple case of forgetting to run perl-cleaner after the upgrade to perl 5.18... I'll let the original reporter close the bug.
Comment 7 Michael Schubert 2014-04-03 11:47:18 UTC
I can confirm this now, closing as a duplicate of #41124.

My apologies for the report.

*** This bug has been marked as a duplicate of bug 41124 ***