Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506488 - dev-python/py-1.4.20 fails tests
Summary: dev-python/py-1.4.20 fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: REGRESSION
Depends on:
Blocks: 506042
  Show dependency tree
 
Reported: 2014-04-01 19:22 UTC by Markus Meier
Modified: 2014-07-19 18:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-python:py-1.4.20:20140401-185144.log (dev-python:py-1.4.20:20140401-185144.log,30.31 KB, text/plain)
2014-04-01 19:22 UTC, Markus Meier
Details
build.log (build.log,20.47 KB, text/plain)
2014-05-03 09:31 UTC, Markus Meier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Meier gentoo-dev 2014-04-01 19:22:45 UTC
Created attachment 374046 [details]
dev-python:py-1.4.20:20140401-185144.log

* Package:    dev-python/py-1.4.20
 * Repository: gentoo
 * Maintainer: python@gentoo.org
 * USE:        arm elibc_glibc kernel_linux python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 test userland_GNU
 * FEATURES:   preserve-libs sandbox test userpriv usersandbox

=========================================================================================================================== short test summary info ============================================================================================================================
XFAIL testing/code/test_source.py::TestSourceParsingAndCompiling::()::test_getstatementrange_bug2
XFAIL testing/path/test_local.py::TestLocalPath::()::test_long_filenames
  reason: [NOTRUN] unreliable est for long filenames
XFAIL testing/path/test_local.py::TestUnicodePy2Py3::()::test_read_write
  changing read/write might break existing usages
XFAIL testing/path/test_svnurl.py::TestSvnURLCommandPath::()::test_load
XFAIL testing/path/test_svnwc.py::TestWCSvnCommandPath::()::test_status_update
  svn-1.7 has buggy 'status --xml' output
========================================================================================================= 727 passed, 19 skipped, 5 xfailed, 3 error in 707.13 seconds =========================================================================================================
 * ERROR: dev-python/py-1.4.20::gentoo failed (test phase):
 * ERROR: dev-python/py-1.4.20::gentoo failed (test phase):
 *   testing failed with python3.3
 *   testing failed with python3.2
 * 
 * 
 * Call stack:
 * Call stack:
 *     ebuild.sh, line   93:  Called src_test
 *     ebuild.sh, line   93:  Called src_test
 *   environment, line 3441:  Called distutils-r1_src_test
 *   environment, line 3441:  Called distutils-r1_src_test
 *   environment, line 1164:  Called _distutils-r1_run_foreach_impl 'python_test'
 *   environment, line 1164:  Called _distutils-r1_run_foreach_impl 'python_test'
 *   environment, line  216:  Called python_parallel_foreach_impl 'distutils-r1_run_phase' 'python_test'
 *   environment, line  216:  Called python_parallel_foreach_impl 'distutils-r1_run_phase' 'python_test'
 *   environment, line 3279:  Called multibuild_parallel_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 3279:  Called multibuild_parallel_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2422:  Called multibuild_foreach_variant '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2422:  Called multibuild_foreach_variant '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2370:  Called _multibuild_run '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2370:  Called _multibuild_run '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2368:  Called _multibuild_parallel '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2368:  Called _multibuild_parallel '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2413:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2413:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_test'
 *   environment, line  638:  Called distutils-r1_run_phase 'python_test'
 *   environment, line  638:  Called distutils-r1_run_phase 'python_test'
 *   environment, line 1100:  Called python_test
 *   environment, line 1100:  Called python_test
 *   environment, line 3328:  Called die
 * The specific snippet of code:
 *   environment, line 3328:  Called die
 * The specific snippet of code:
 *       py.test || die "testing failed with ${EPYTHON}"
 *       py.test || die "testing failed with ${EPYTHON}"

Portage 2.2.8-r1 (default/linux/arm/13.0/armv5te/desktop, gcc-4.7.3, glibc-2.17, 3.10.25-gentoo armv5tel)
=================================================================
System uname: Linux-3.10.25-gentoo-armv5tel-with-gentoo-2.2
KiB Mem:      513244 total,    178124 free
KiB Swap:     614396 total,    591112 free
Timestamp of tree: Mon, 31 Mar 2014 11:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 armv5tel-softfloat-linux-gnueabi [disabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-lang/python:          2.6.8-r3, 2.7.6, 3.2.5-r3, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv5tel-softfloat-linux-gnueabi"
CFLAGS="-O2 -march=armv5te -pipe"
CHOST="armv5tel-softfloat-linux-gnueabi"
CONFIG_PROTECT="/etc /usr/lib/python2.7/site-packages/buildbot/status/web /usr/share/gnupg/qualified.txt /var/bind /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=armv5te -pipe"
DISTDIR="/mnt/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --jobs=2 --keep-going --with-bdeps=y"
FCFLAGS="-O2 -pipe -march=armv5te"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -march=armv5te"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://192.168.1.100/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 arm berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv jpeg kpathsea lcms ldap libnotify mad mng modules mp3 mp4 mpeg ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl session spell ssl startup-notification svg tcpd test tiff truetype udev udisks unicode upower usb vorbis wxwidgets xcb xml xv xvid zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-2 php5-3 php5-4 php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_6 python2_7 python3_2 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="exynos fbdev omap omapfb dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2014-04-02 16:37:17 UTC
Did not replicate.

~/cvsPortage/gentoo-x86/dev-python/py $ ebuild py-1.4.20.ebuild clean test

platform linux2 -- Python 2.6.9 -- py-1.4.20 -- pytest-2.5.2
== test session starts ==

platform linux2 -- Python 3.2.5 -- py-1.4.20 -- pytest-2.5.2
plugins: cov
== test session starts ==

platform linux -- Python 3.3.4 -- py-1.4.20 -- pytest-2.5.2
plugins: cov
== test session starts ==

platform linux2 -- Python 2.7.6 -- py-1.4.20 -- pytest-2.5.2
plugins: cov
== test session starts ==

platform linux2 -- Python 2.7.3[pypy-2.0.2-final] -- py-1.4.20 -- pytest-2.5.2


== 728 passed, 20 skipped, 4 xfailed, 2 xpassed in 35.58 seconds ==

== 729 passed, 20 skipped, 4 xfailed, 1 xpassed in 37.00 seconds ==

== 729 passed, 20 skipped, 5 xfailed in 38.15 seconds ==

== 729 passed, 20 skipped, 5 xfailed in 38.52 seconds ==

== 728 passed, 21 skipped, 4 xfailed, 1 xpassed in 47.45 seconds ==
Comment 2 Markus Meier gentoo-dev 2014-05-03 09:31:52 UTC
Created attachment 376268 [details]
build.log

the failure is (partially) reproducible on an other arm box. this box has less python packages installed - is it possible that the package is not pulling in all test-deps?
Comment 3 Ian Delaney (RETIRED) gentoo-dev 2014-06-27 13:20:47 UTC
hmm, from bug 514442

___________ ERROR at setup of TestCommonCrypto.test_supports_cipher ____________
Error evaluating 'skipif' expression
    True
Failed: expression is not a string

More than a coincidence.  I know nothing about alpha, however what we have here in common is alpha running testsuites using pytest on 2 arm boxes by you and one by your colleague klausman and seeing them do this oddity.  I wonder is it possible alpha has problem with pytest.

is it possible that the package is not pulling in all test-deps?

Generally this is quite evident from reports of failure to import a module of a dep not installed.
Comment 4 Ian Delaney (RETIRED) gentoo-dev 2014-07-01 05:18:26 UTC
Actually I misread arm as alpha however there is still this commonality between them.
Comment 5 Tobias Klausmann gentoo-dev 2014-07-19 17:45:54 UTC
I played around a bit with pytest and it looks like py-1.4.20 should depend on >=pytest-2.4.2 -- with both that and 2.5.2, the test suite completes just fine on alpha.
Comment 6 Mike Gilbert gentoo-dev 2014-07-19 18:53:26 UTC
  19 Jul 2014; Tobias Klausmann <klausman@gentoo.org> py-1.4.20.ebuild:
  Update pytest dep and drop ia64 and hppa stable keywords. Details in bug
  506042