Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504912 - media-video/vlc-2.1.4[-qt4,qt5] fails to build
Summary: media-video/vlc-2.1.4[-qt4,qt5] fails to build
Status: RESOLVED DUPLICATE of bug 489508
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Tom Wijsman (TomWij) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-17 22:26 UTC by Elias Probst
Modified: 2014-03-18 10:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-video/vlc-2.1.4[-qt4,qt5] fails - build.log (build.log,938.86 KB, patch)
2014-03-17 22:26 UTC, Elias Probst
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2014-03-17 22:26:37 UTC
Created attachment 372878 [details, diff]
media-video/vlc-2.1.4[-qt4,qt5] fails - build.log

Building media-video/vlc-2.1.4 with Qt4 support disabled, but Qt5 support enabled, fails.

It looks, like the build still tries to build Qt4 though.

Full build.log in attachment, some relevant lines here:

../../../doltlibtool  --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../..  -DMODULE_NAME=$(p="libqt4_plugin_la-qt4.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}") -DMODULE_NAME_IS_$(p="libqt4_plugin_la-qt4.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}") -DMODULE_STRING=\"$(p="libqt4_plugin_la-qt4.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}")\" -D__PLUGIN__  -I../../../include -I../../../include  -I/usr/include/samba-4.0  -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/include/qt4/QtCore   -march=core2 -O2 -pipe -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wvolatile-register-var -fvisibility=hidden -c -o libqt4_plugin_la-qt4.lo `test -f 'qt4.cpp' || echo './'`qt4.cpp
../../../doltlibtool  --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../..  -DMODULE_NAME=$(p="libqt4_plugin_la-menus.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}") -DMODULE_NAME_IS_$(p="libqt4_plugin_la-menus.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}") -DMODULE_STRING=\"$(p="libqt4_plugin_la-menus.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}")\" -D__PLUGIN__  -I../../../include -I../../../include  -I/usr/include/samba-4.0  -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/include/qt4/QtCore   -march=core2 -O2 -pipe -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wvolatile-register-var -fvisibility=hidden -c -o libqt4_plugin_la-menus.lo `test -f 'menus.cpp' || echo './'`menus.cpp
../../../doltlibtool  --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../..  -DMODULE_NAME=$(p="libqt4_plugin_la-main_interface.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}") -DMODULE_NAME_IS_$(p="libqt4_plugin_la-main_interface.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}") -DMODULE_STRING=\"$(p="libqt4_plugin_la-main_interface.lo"; p="${p##*/}"; p="${p#lib}"; echo "${p%_plugin*}")\" -D__PLUGIN__  -I../../../include -I../../../include  -I/usr/include/samba-4.0  -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/include/qt4/QtCore   -march=core2 -O2 -pipe -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wvolatile-register-var -fvisibility=hidden -c -o libqt4_plugin_la-main_interface.lo `test -f 'main_interface.cpp' || echo './'`main_interface.cpp
In file included from dialogs/open.hpp:35:0,
                 from dialogs_provider.hpp:36,
                 from menus.cpp:45:
./ui/open.h:14:29: fatal error: QtWidgets/QAction: No such file or directory
compilation terminated.
In file included from dialogs/open.hpp:35:0,
                 from dialogs_provider.hpp:36,
                 from qt4.cpp:36:
./ui/open.h:14:29: fatal error: QtWidgets/QAction: No such file or directory
compilation terminated.
make[6]: *** [libqt4_plugin_la-menus.lo] Error 1
make[6]: *** Waiting for unfinished jobs....
make[6]: *** [libqt4_plugin_la-qt4.lo] Error 1
In file included from ./dialogs/open.hpp:35:0,
                 from ./dialogs_provider.hpp:36,
                 from components/interface_widgets.hpp:38,
                 from main_interface.cpp:39:
./ui/open.h:14:29: fatal error: QtWidgets/QAction: No such file or directory
compilation terminated.
make[6]: *** [libqt4_plugin_la-main_interface.lo] Error 1





emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.13.6-gentoo x86_64)
=================================================================
System uname: Linux-3.13.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-3537U_CPU_@_2.00GHz-with-gentoo-2.2
KiB Mem:     8035048 total,    920408 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Mon, 17 Mar 2014 18:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2-r1::kde
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo eliasp eliasp-public gamerlay perl-experimental multimedia sunrise benf kde docker qt x11
Installed sets: @allback, @eliasp-kdenetwork-4.13, @fusioninventory, @gpxsync, @kde-telepathy, @kdeadmin-4.13, @kdeartwork-4.13, @kdebase-4.13, @kdebase-runtime-4.13, @kdebase-workspace-4.11, @kdegraphics-4.13, @kdelibs-4.13, @kdemultimedia-4.13, @kdepim-4.13, @kdeutils-4.13, @otrs
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4 --keep-going --load-average=2.5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://mirror.netcologne.de/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="en_US.utf8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/eliasp /var/lib/layman/eliasp-public /var/lib/layman/gamerlay /var/lib/layman/perl-experimental /var/lib/layman/multimedia /var/lib/layman/sunrise /var/lib/layman/benf /var/lib/layman/kde /var/lib/layman/docker /var/lib/layman/qt /var/lib/layman/x11"
USE="X a52 aac acl acpi alsa amd64 apache2 audiofile avahi berkdb bluetooth branding bzip2 cairo cdda cdparanoia cli cracklib crypt css cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fastcgi ffmpeg fftw firefox flac gdbm gif git gnutls gs gstreamer gtk gtk3 handbook hdri iconv icu imagemagick imap inotify ipv6 jabber java6 jpeg jpeg2k kde kdeprefix kerberos kipi kms lame lcms ldap libnotify libsamplerate lzma mac mad matroska mmap mmx mng modules mp3 mp4 mpeg mplayer multilib musicbrainz mysql ncurses networkmanager nls nptl nsplugin ogg opengl opus pam pango pcre pdf perl phonon plasma png policykit postgres ppds private-headers pulseaudio python qt qt3support qt4 qt5 rdesktop readline rss ruby samba sdl semantic-desktop session smp spell spice sqlite sse sse2 ssl startup-notification subversion svg systemd taglib tcpd theora tiff truetype udev udisks unicode upnp upower usb v4l2 vaapi vcd vim-syntax vnc vorbis wmf wxwidgets x264 xcb xcomposite xinerama xml xv xvid xvmc zeroconf zip zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi sheets" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth caps systemd" ELIBC="glibc" ENLIGHTENMENT_MODULES="backlight battery clock comp conf-applications conf-dialogs conf-display conf-edgebindings conf-interaction conf-intl conf-keybindings conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers cpufreq dropshadow everything fileman fileman-opinfo gadman ibar ibox illume2 mixer msgbus notification pager quickaccess start syscon systray tasks temperature tiling winlist wizard xkbswitch" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Davide Pesavento gentoo-dev 2014-03-18 00:39:31 UTC
Why is this assigned to qt?
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-03-18 10:56:59 UTC
Qt 5 is yet to be added to the Portage tree.

*** This bug has been marked as a duplicate of bug 489508 ***