Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504588 - www-client/w3m-0.5.3-r1 - ld: terms.o: undefined reference to symbol 'tgetflag'
Summary: www-client/w3m-0.5.3-r1 - ld: terms.o: undefined reference to symbol 'tgetflag'
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: CJK Team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2014-03-14 13:13 UTC by Dimitrios Semitsoglou-Tsiapos
Modified: 2014-03-15 10:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (w3m_build.log,31.84 KB, text/plain)
2014-03-14 13:30 UTC, Dimitrios Semitsoglou-Tsiapos
Details
w3m-0.5.3-tinfo.patch (w3m-0.5.3-tinfo.patch,634 bytes, patch)
2014-03-14 13:49 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitrios Semitsoglou-Tsiapos 2014-03-14 13:13:47 UTC
w3m fails to build with:
/lib64/libtinfo.so.5: could not read symbols: Invalid operation

This appears to be unrelated to #362249, since I have not set -j in MAKEOPTS.

Reproducible: Always

Steps to Reproduce:
1. emerge w3m



Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.13.5-tuxonice x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.13.5-tuxonice-x86_64-AMD_Sempron-tm-_M100-with-gentoo-2.2
KiB Mem:     1789640 total,    101108 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Fri, 07 Mar 2014 10:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.3.3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j4 --load-average=3.8 --nospinner"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bindist bluetooth bzip2 cairo cdda cdr cjk cli cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv icu ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png ppds qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev unicode upower usb vim-syntax vorbis wxwidgets x264 xcb xinerama xml xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel nouveau radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2014-03-14 13:25:09 UTC
Please attach the entire build log to this bug report.
Comment 2 Dimitrios Semitsoglou-Tsiapos 2014-03-14 13:30:00 UTC
Created attachment 372646 [details]
Build log

[ebuild  N    ] www-client/w3m-0.5.3-r1  USE="X gpm gtk nls ssl unicode -fbcon -imlib -lynxkeymap -migemo -nntp -xface" LINGUAS="-ja"
Comment 3 Jeroen Roovers gentoo-dev 2014-03-14 13:48:23 UTC
There seems to be a "fix" in -r4 but it's not quite correct.
Comment 4 Jeroen Roovers gentoo-dev 2014-03-14 13:49:54 UTC
Created attachment 372650 [details, diff]
w3m-0.5.3-tinfo.patch

The built in detection works fine as long as it includes tinfo and we don't force anything through --with-termlib=.

Index: w3m-0.5.3-r4.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-client/w3m/w3m-0.5.3-r4.ebuild,v
retrieving revision 1.1
diff -u -B -r1.1 w3m-0.5.3-r4.ebuild
--- w3m-0.5.3-r4.ebuild 6 Nov 2013 10:53:28 -0000       1.1
+++ w3m-0.5.3-r4.ebuild 14 Mar 2014 13:48:57 -0000
@@ -3,7 +3,7 @@
 # $Header: /var/cvsroot/gentoo-x86/www-client/w3m/w3m-0.5.3-r4.ebuild,v 1.1 2013/11/06 10:53:28 naota Exp $
 EAPI="3"
-inherit eutils
+inherit autotools eutils
 DESCRIPTION="Text based WWW browser, supports tables and frames"
 HOMEPAGE="http://w3m.sourceforge.net/"
@@ -37,7 +37,8 @@
                "${FILESDIR}/${PN}-0.5.2-gc72.patch" \
                "${FILESDIR}/${PN}-0.5.3-parallel-make.patch" \
                "${FILESDIR}/${PN}-0.5.3-glibc214.patch" \
-               "${FILESDIR}/${PN}-0.5.3-underlinking.patch"
+               "${FILESDIR}/${PN}-0.5.3-underlinking.patch" \
+               "${FILESDIR}/${PN}-0.5.3-tinfo.patch"
        use vanilla || \
                epatch "${FILESDIR}"/${PN}-0.5.3-button.patch \
                        "${FILESDIR}"/${P}-gdk-pixbuf.patch \
@@ -45,6 +46,7 @@
                        "${FILESDIR}"/${P}-url-schema.patch
        find . -name CVS -type d | xargs rm -r
        sed -i -e "/^AR=/s/ar/$(tc-getAR)/" {.,w3mimg,libwc}/Makefile.in || die
+       eautoconf
 }
 src_configure() {
@@ -89,13 +91,11 @@
                myconf="${myconf} --enable-keymap=w3m"
        fi
-       local termlib=$(pkg-config ncurses --libs|sed -e 's/-l//g')
-
        econf \ 
                --with-editor="${EPREFIX}/usr/bin/vi" \
                --with-mailer="${EPREFIX}/bin/mail" \
                --with-browser="${EPREFIX}/usr/bin/xdg-open" \
-               --with-termlib="${termlib}" \
+               --with-termlib=yes \
                --enable-image=${imageval:-no} \
                --with-imagelib="${imagelibval:-no}" \
                --with-migemo="${migemo_command}" \
Comment 5 Jeroen Roovers gentoo-dev 2014-03-14 13:56:33 UTC
Fixed in -r5.
Comment 6 Nikos Chantziaras 2014-03-15 10:44:33 UTC
Why is this a revbump? It gets re-emerged now for no reason.