Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504476 - kde-base/plasma-workspace: All Python plasmoids are broken
Summary: kde-base/plasma-workspace: All Python plasmoids are broken
Status: RESOLVED DUPLICATE of bug 501330
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-13 12:34 UTC by Tobias Leupold
Modified: 2014-03-16 13:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Leupold 2014-03-13 12:34:37 UTC
Some recent update broke the execution of all Python plasmoids. I'm not sure which one was it, I first thought of dev-python/PyQt4-4.10.3-r2, but a downgrade to 4.10.2 did not solve the problem. So it seems this is more complex.

When I start a plasmoid written in Python with plasma-windowed, I get:

--------------------
KCrash: Attempting to start /usr/bin/plasma-windowed from kdeinit
sock_file=/home/tobias/.kde4/socket-skoni/kdeinit4__0
plasma-windowed(2638): Communication problem with  "plasma-windowed" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 
--------------------

or only this:

--------------------
plasma-windowed(2753): Communication problem with  "plasma-windowed" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 
--------------------

When I try to add a Python plasmoid to the desktop, the whole Desktop crashes. Here's a backtrace (I don't know if this is useful ...):

--------------------
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x00007fdcdb4f8588 in QMetaObject::cast(QObject*) const () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fdcd021813a in ?? () from /usr/lib64/libplasma.so.3
#7  0x00007fdcd02189de in Plasma::loadScriptEngine(QString const&, Plasma::Applet*) () from /usr/lib64/libplasma.so.3
#8  0x00007fdcd01646d5 in ?? () from /usr/lib64/libplasma.so.3
#9  0x00007fdcd016bb5e in Plasma::Applet::Applet(QObject*, QList<QVariant> const&) () from /usr/lib64/libplasma.so.3
#10 0x00007fdcd01acba0 in Plasma::PluginLoader::loadApplet(QString const&, unsigned int, QList<QVariant> const&) () from /usr/lib64/libplasma.so.3
#11 0x00007fdcd017aba3 in ?? () from /usr/lib64/libplasma.so.3
#12 0x00007fdcd017eb9e in ?? () from /usr/lib64/libplasma.so.3
#13 0x00007fdcd01805dc in Plasma::Containment::dropEvent(QGraphicsSceneDragDropEvent*) () from /usr/lib64/libplasma.so.3
#14 0x00007fdcbf86d2cd in ?? () from /usr/lib64/kde4/plasma_containment_desktop.so
#15 0x00007fdcdabecbe7 in QGraphicsItem::sceneEvent(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007fdcdac1738c in ?? () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007fdcdac173cf in QGraphicsScene::dropEvent(QGraphicsSceneDragDropEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007fdcdac2afe0 in QGraphicsScene::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007fdcda6340cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007fdcda636a3b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007fdcdc30ab36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#22 0x00007fdcdb4f016c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007fdcdac445ed in QGraphicsView::dropEvent(QDropEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007fdcda68142c in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#25 0x00007fdcdaa2d616 in QFrame::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#26 0x00007fdcdac44cdb in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007fdcdb4f03fb in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007fdcda63409c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007fdcda6373e3 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#30 0x00007fdcdc30ab36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007fdcdb4f016c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#32 0x00007fdcda6bda11 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#33 0x00007fdcda6bde05 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#34 0x00007fdcda6bdff0 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#35 0x00007fdcdb4f02ff in QCoreApplicationPrivate::sendThroughApplicationEventFilters(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#36 0x00007fdcda634046 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#37 0x00007fdcda63729b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#38 0x00007fdcdc30ab36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#39 0x00007fdcdb4f016c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#40 0x00007fdcda63a16b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/qt4/libQtGui.so.4
#41 0x00007fdcda6acee4 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#42 0x00007fdcda6ab7e1 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#43 0x00007fdcda6d4522 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#44 0x00007fdcd6d32b55 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#45 0x00007fdcd6d32e98 in ?? () from /usr/lib64/libglib-2.0.so.0
#46 0x00007fdcd6d32f54 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#47 0x00007fdcdb52b6a7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#48 0x00007fdcda6d45fe in ?? () from /usr/lib64/qt4/libQtGui.so.4
#49 0x00007fdcdb4edc40 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#50 0x00007fdcdb4eddd4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#51 0x00007fdcda6bd493 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#52 0x00007fdcda645c68 in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib64/qt4/libQtGui.so.4
#53 0x00007fdc31efa1e5 in ?? () from /usr/lib64/kde4/imports/org/kde/draganddrop/libdraganddropplugin.so
#54 0x00007fdc31ef9e49 in ?? () from /usr/lib64/kde4/imports/org/kde/draganddrop/libdraganddropplugin.so
#55 0x00007fdcdac11da5 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#56 0x00007fdcdac166be in ?? () from /usr/lib64/qt4/libQtGui.so.4
#57 0x00007fdcdac172e0 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#58 0x00007fdcdac1fb0c in QGraphicsScene::mouseMoveEvent(QGraphicsSceneMouseEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#59 0x00007fdcdac2b030 in QGraphicsScene::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#60 0x00007fdcda6340cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#61 0x00007fdcda636a3b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#62 0x00007fdcdc30ab36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#63 0x00007fdcdb4f016c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#64 0x00007fdcdac42af4 in QGraphicsViewPrivate::mouseMoveEventHandler(QMouseEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#65 0x00007fdcdac42e7e in QGraphicsView::mouseMoveEvent(QMouseEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#66 0x00007fdcda6812ab in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#67 0x00007fdcdaa2d616 in QFrame::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#68 0x00007fdcdac44cdb in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#69 0x00007fdcdb4f03fb in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#70 0x00007fdcda63409c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#71 0x00007fdcda63729b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#72 0x00007fdcdc30ab36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#73 0x00007fdcdb4f016c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#74 0x00007fdcda63a16b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/qt4/libQtGui.so.4
#75 0x00007fdcda6acee4 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#76 0x00007fdcda6ab7e1 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#77 0x00007fdcda6d4522 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#78 0x00007fdcd6d32b55 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#79 0x00007fdcd6d32e98 in ?? () from /usr/lib64/libglib-2.0.so.0
#80 0x00007fdcd6d32f54 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#81 0x00007fdcdb52b6a7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#82 0x00007fdcda6d45fe in ?? () from /usr/lib64/qt4/libQtGui.so.4
#83 0x00007fdcdb4edc40 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#84 0x00007fdcdb4eddd4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#85 0x00007fdcdb4f07ee in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#86 0x00007fdcca9a9cb1 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#87 0x000000000040894a in _start ()
--------------------

This affects all Python plasmoids here. Until the latest updates (one or two days ago), everything worked. I'm on stable. I also tried to rebuild all packages having to do with Python, KDE, Plasma and Qt, but it didn't help. The system is also consistent, revdep-rebuild reported no breaking.

I'd really like to help to debug this, but I don't know how ...
Comment 1 Tobias Leupold 2014-03-13 12:36:28 UTC
Ps: I see this on two complete independent machines not being in the same network and not sharing anything (so I don't think this can be a distcc issue or so). Both are stable amd64.
Comment 2 Michael Palimaka (kensington) gentoo-dev 2014-03-14 10:21:33 UTC
Can you try with a brand new user and see if it still crashes?
Comment 3 Tobias Leupold 2014-03-14 17:07:39 UTC
I get the very same errors with a new user (without ~/.kde4, ~/.config and ~/.local).
Comment 4 Michael Palimaka (kensington) gentoo-dev 2014-03-15 01:39:19 UTC
What is the output of emerge -pv kde-base/plasma-workspace ?
Comment 5 Michael Palimaka (kensington) gentoo-dev 2014-03-15 01:44:15 UTC
Also, please try rebuilding pykde4
Comment 6 Tobias Leupold 2014-03-15 17:59:37 UTC
kde-base/plasma-workspace was the first package I rebuilt, as the whole plasma desktop crashed due to this problem after the kdm login and plasma-desktop belongs to kde-base/plasma-workspace. It did not fix the crash (I had to remove Plasma's settings in ~/.kde4) so that the plasmoid would not be loaded.

I already tried to rebuild all kinds of packages that seemed having something to do with it, namely: sys-apps/dbus dev-qt/qtdbus dev-python/dbus-python dev-python/PyQt4 kde-base/pykde4 kde-base/plasma-workspace

it did not change anything.

Just to mention it: another user in the forums could also reproduce the very same problem, cf. http://forums.gentoo.org/viewtopic-t-986280.html
Comment 7 Tobias Leupold 2014-03-15 18:00:16 UTC
Oh, here's the output of emerge -pv kde-base/plasma-workspace:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] kde-base/plasma-workspace-4.11.5:4/4.11  USE="handbook python semantic-desktop (-aqua) -debug -gps -json -qalculate" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Comment 8 Johannes Huber gentoo-dev 2014-03-16 12:47:47 UTC
Could you please test with latest stable dev-libs/glib-2.38.2-r1?
Comment 9 Tobias Leupold 2014-03-16 13:05:46 UTC
dev-libs/glib-2.38.2-r1 is already installed. The system is up-to-date on stable (as well as the other systems where I have the same problem).
Comment 10 Tobias Leupold 2014-03-16 13:49:29 UTC
Oh, sorry! I just saw the -r1 update just has been installed, I thought there has been no update to this package recently.

It seems that this actually fixed the issue! I can now start Python plasmoids as before, no error anymore.

But how does a GTK library affect Plasma?!
Comment 11 Johannes Huber gentoo-dev 2014-03-16 13:52:53 UTC
Please see original bug for more information

*** This bug has been marked as a duplicate of bug 501330 ***