Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 503630 - <dev-lang/php-{5.4.26,5.5.10}: Fileinfo libmagic Infinite Recursion Denial of Service Vulnerability (CVE-2014-{1943,2270})
Summary: <dev-lang/php-{5.4.26,5.5.10}: Fileinfo libmagic Infinite Recursion Denial of...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://secunia.com/advisories/56993/
Whiteboard: A3 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-06 14:57 UTC by Agostino Sarubbo
Modified: 2014-08-31 11:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-03-06 14:57:21 UTC
From ${URL} :

Description

A vulnerability has been reported in PHP, which can be exploited by malicious people to potentially cause a DoS (Denial of Service).

The vulnerability is caused due to an error in the libmagic library bundled in the Fileinfo extension when processing certain files and can be exploited to trigger infinite recursion and cause a crash via a specially crafted file.

The vulnerability is reported in versions 5.5.9 and prior and 5.4.25 and prior.


Solution:
Fixed in the source code repository.

Provided and/or discovered by:
Originally reported by Bernd Melchers against File via the File mailing list.

Original Advisory:
Bernd Melchers:
http://mx.gw.com/pipermail/file/2014/001327.html

PHP:
https://github.com/php/php-src/commit/89f864c547014646e71862df3664e3ff33d7143d
https://github.com/php/php-src/commit/fdb9b6e5ec73d37b9734c9f7c50b3946ed85b5e3


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Ole Markus With (RETIRED) gentoo-dev 2014-03-07 09:03:53 UTC
Fixed in 5.5.10 and 5.4.26, which should now be in the tree. You can goahead with stabilisation if necessary.
Comment 2 Yury German Gentoo Infrastructure gentoo-dev Security 2014-03-07 12:57:13 UTC
Arches, please test and mark stable:

=dev-lang/php-5.4.26
=dev-lang/php-5.5.10

Target Keywords : "alpha amd64 arm hppa ia64 ppc ppc64 spark x86"
Comment 3 Jeroen Roovers gentoo-dev 2014-03-07 22:39:20 UTC
Stable for HPPA.
Comment 4 Agostino Sarubbo gentoo-dev 2014-03-09 09:52:12 UTC
amd64 stable
Comment 5 Agostino Sarubbo gentoo-dev 2014-03-09 09:53:13 UTC
x86 stable
Comment 6 Agostino Sarubbo gentoo-dev 2014-03-12 10:37:40 UTC
sparc stable
Comment 7 Markus Meier gentoo-dev 2014-03-12 20:50:56 UTC
arm stable
Comment 8 Agostino Sarubbo gentoo-dev 2014-03-16 11:11:38 UTC
ppc stable
Comment 9 Agostino Sarubbo gentoo-dev 2014-03-18 16:12:11 UTC
ia64 stable
Comment 10 Agostino Sarubbo gentoo-dev 2014-03-19 14:21:24 UTC
alpha stable
Comment 11 Agostino Sarubbo gentoo-dev 2014-03-24 14:34:25 UTC
ppc64 stable.

Maintainer(s), please cleanup.
Security, please add it to the existing request, or file a new one.
Comment 12 Yury German Gentoo Infrastructure gentoo-dev Security 2014-03-24 22:21:05 UTC
Arches, Thank you for your work
Maintainer(s), please drop the vulnerable version.

Added to existing GLSA Request
Comment 13 Yury German Gentoo Infrastructure gentoo-dev Security 2014-05-15 04:06:07 UTC
Maintainer(s), Thank you for cleanup!
Comment 14 GLSAMaker/CVETool Bot gentoo-dev 2014-08-31 11:27:11 UTC
This issue was resolved and addressed in
 GLSA 201408-11 at http://security.gentoo.org/glsa/glsa-201408-11.xml
by GLSA coordinator Kristian Fiskerstrand (K_F).