Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 501668 - sys-apps/portage: emerge -K, says "there are no ebuilds" when it really means "there is no BINPKG"
Summary: sys-apps/portage: emerge -K, says "there are no ebuilds" when it really means...
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Portage team
Depends on:
Reported: 2014-02-18 08:36 UTC by Jesús Guerrero Botella (RETIRED)
Modified: 2022-10-20 02:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jesús Guerrero Botella (RETIRED) gentoo-dev 2014-02-18 08:36:12 UTC
The person in the URL I put above is having this issue, and I confirmed it with portage 2.2.7 (current stable).

He's trying to recover a foo-bar'ed system, that's unimportant though. The thing is that, if for some reason, portage can't find a binary package when you specify the -K parameter, then it complains with an error similar to this one:

emerge -K "=portage-2.2.7"

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=portage-2.2.7".

But the true problem is that it can't find the binary package. I just tested this in my own laptop. And got the same error.

After running "quickpkg portage", the same emerge -K command worked without problems.

This error message is misleading, and, as the URL to LQ shows, it confuses the newcomers. So it should be adjusted. I tried looking into the portage sources, but my python-foo is quasi-non-existent. I guess that that message is the way it is because that code is probably used in more places, so the change could be not as trivial as it might seem in first place. But I'll leave that to whoever knows what s/he's doing.

Reproducible: Always

Steps to Reproduce:
1. make sure you don't have $PKGDIR/sys-apps/portage-*.tar.bz2
2. emerge -K portage
3. read the message, it's misleading
4. quickpkg portage
5. try again emerge -K portage, it should work
Actual Results:  
It says it can't find the ebuild

Expected Results:  
It should say it can't find the binkpg