Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 501368 - dev-perl/glib-perl-1.301.0 - perl Makefile.PL: Can't locate ExtUtils/Depends.pm in @INC
Summary: dev-perl/glib-perl-1.301.0 - perl Makefile.PL: Can't locate ExtUtils/Depends....
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-15 09:53 UTC by Francisco Lloret
Modified: 2014-02-15 11:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Lloret 2014-02-15 09:53:17 UTC
glib-perl-1.301.0 compile error:

>>> Emerging (1 of 55) dev-perl/glib-perl-1.301.0
 * Glib-1.301.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                          [ ok ]
>>> Unpacking source...
>>> Unpacking Glib-1.301.tar.gz to /var/tmp/portage/dev-perl/glib-perl-1.301.0/work
>>> Source unpacked in /var/tmp/portage/dev-perl/glib-perl-1.301.0/work
>>> Preparing source in /var/tmp/portage/dev-perl/glib-perl-1.301.0/work/Glib-1.301 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-perl/glib-perl-1.301.0/work/Glib-1.301 ...
 * Using ExtUtils::MakeMaker
 * perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR=none DESTDIR=/var/tmp/portage/dev-perl/glib-perl-1.301.0/image/
Can't locate ExtUtils/Depends.pm in @INC (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at (eval 6) line 1.
BEGIN failed--compilation aborted at (eval 6) line 1.

Checking if your kit is complete...
Looks good
MakeMaker FATAL: prerequisites not found.
    ExtUtils::Depends not installed
    ExtUtils::PkgConfig not installed

Please install these modules first and rerun 'perl Makefile.PL'.
 * ERROR: dev-perl/glib-perl-1.301.0::gentoo failed (configure phase):
 *   Unable to build!
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 2363:  Called perl-module_src_configure
 *   environment, line 1973:  Called perl-module_src_prep
 *   environment, line 2045:  Called die
 * The specific snippet of code:
 *               perl Makefile.PL "$@" <<< "${pm_echovar}" || die "Unable to build!";
 * 
 * If you need support, post the output of `emerge --info '=dev-perl/glib-perl-1.301.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/glib-perl-1.301.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-perl/glib-perl-1.301.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-perl/glib-perl-1.301.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-perl/glib-perl-1.301.0/work/Glib-1.301'
 * S: '/var/tmp/portage/dev-perl/glib-perl-1.301.0/work/Glib-1.301'

>>> Failed to emerge dev-perl/glib-perl-1.301.0, Log file:

>>>  '/var/tmp/portage/dev-perl/glib-perl-1.301.0/temp/build.log'

 * Messages for package dev-perl/glib-perl-1.301.0:

 * ERROR: dev-perl/glib-perl-1.301.0::gentoo failed (configure phase):
 *   Unable to build!
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 2363:  Called perl-module_src_configure
 *   environment, line 1973:  Called perl-module_src_prep
 *   environment, line 2045:  Called die
 * The specific snippet of code:
 *               perl Makefile.PL "$@" <<< "${pm_echovar}" || die "Unable to build!";
 * 
 * If you need support, post the output of `emerge --info '=dev-perl/glib-perl-1.301.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/glib-perl-1.301.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-perl/glib-perl-1.301.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-perl/glib-perl-1.301.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-perl/glib-perl-1.301.0/work/Glib-1.301'
 * S: '/var/tmp/portage/dev-perl/glib-perl-1.301.0/work/Glib-1.301'
Core2Duo ~ #
Comment 1 Jeroen Roovers gentoo-dev 2014-02-15 11:31:13 UTC

*** This bug has been marked as a duplicate of bug 41124 ***