Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 499696 - x11-misc/shared-mime-info-1.2-r1: build failure due to missing build dependency dev-perl/XML-Parser
Summary: x11-misc/shared-mime-info-1.2-r1: build failure due to missing build dependen...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-29 16:46 UTC by Homer
Modified: 2014-01-29 16:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Homer 2014-01-29 16:46:52 UTC
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

Manually emerging dev-perl/XML-Parser fixes the problem.

Reproducible: Always

Steps to Reproduce:
1. emerge x11-misc/shared-mime-info-1.2-r1
Actual Results:  
Build failure.

Expected Results:  
Build shouldn't fail.

DEPEND="dev-perl/XML-Parser" needed in ebuild.
Comment 1 Ian Stakenvicius gentoo-dev 2014-01-29 16:50:21 UTC
Did you check if XML-Parser was already installed before you did this?  

I expect the reason for the failure had to do with a need to run "perl-cleaner --all"
Comment 2 Ben Kohler gentoo-dev 2014-01-29 16:53:30 UTC

*** This bug has been marked as a duplicate of bug 41124 ***