Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 499030 - app-text/fbreader-0.99.4-r1 - black background artifact
Summary: app-text/fbreader-0.99.4-r1 - black background artifact
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Grozin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-23 11:19 UTC by Eternal Sorrow
Modified: 2018-03-18 19:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info =app-text/fbreader-0.99.4-r1 (emerge_info,18.02 KB, text/plain)
2014-01-23 11:19 UTC, Eternal Sorrow
Details
screenshot (Снимок экрана от 2014-01-23 21:50:58.png,317.08 KB, image/png)
2014-01-23 11:26 UTC, Eternal Sorrow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eternal Sorrow 2014-01-23 11:19:18 UTC
Created attachment 368540 [details]
emerge --info =app-text/fbreader-0.99.4-r1

Fbreader has a black background of text, no matter whatever color I set in settings. Also, when I scroll text, text rendering works wrong (see screenshot attachment).

I have an optimus notebook, so I tried to run fbreader on nvidia discrete video card (using bumblebee+primus), and backround was color noise instead of just black on intel video card. So, I think, the bug is in hardware acceleration of fbreader or Qt.
Comment 1 Eternal Sorrow 2014-01-23 11:26:32 UTC
Created attachment 368542 [details]
screenshot

Screenshot is made after some scrolling.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2014-01-23 11:58:42 UTC
Please post your `emerge -vpq x11-drivers/nvidia-drivers' output in a comment.
Comment 3 Eternal Sorrow 2014-01-23 16:49:03 UTC
$ emerge -vpq x11-drivers/nvidia-drivers
[ebuild   R   ] x11-drivers/nvidia-drivers-331.38  USE="X acpi (multilib) tools -pax_kernel"

Artifact appears not only with nvidia. With intel there is black background, with nvidia color noise. Sorry, if it was not clear with my first post. I can attach screenshot with nvidia, if you want. The already posted screenshot created with intel.

And just in case:
$ emerge -vpq x11-drivers/xf86-video-intel
[ebuild   R   ] x11-drivers/xf86-video-intel-2.99.907-r1  USE="dri sna udev -glamor -uxa -xvmc"
Comment 4 Adam Feldman gentoo-dev 2014-10-13 13:50:48 UTC
Do you have this problem with all documents?  I tried both r1 and r2 on my optimus laptop (on intel [8086:0126] using i915  and on nvidia discrete GT 525M [10de:0df5]) without being able to reproduce the problem.
Comment 5 Eternal Sorrow 2014-10-13 23:05:51 UTC
I cant currently try to reproduce this, because I've unmerged fbreader along with qt and it's taking a lot of time to reemerge it back. I'm just not bothering it.
Comment 6 thegeekpirate 2014-10-21 10:14:48 UTC
I have this exact issue as well, and ```emerge --info =app-text/fbreader-0.99.4-r2``` simply returns ```zsh: app-text/fbreader-0.99.4-r2 not found```.

Portage 2.2.14 (python 3.4.2-final-0, default/linux/amd64/13.0, gcc-4.8.3, glibc-2.19-r1, 3.17.1-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.17.1-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.2
KiB Mem:    12331232 total,   4216208 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 21 Oct 2014 06:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30
dev-lang/perl:            5.20.1-r1
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.2
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo sublime-text steam-overlay qt eroen unity-gentoo x-portage
Installed sets: @qt5-addons, @qt5-essentials
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.gossamerhost.com http://gentoo.mirrors.tera-byte.com"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sublime-text /var/lib/layman/steam /var/lib/layman/qt /var/lib/layman/eroen /var/lib/layman/unity-gentoo /usr/local/portage"
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="X acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm iconv ipv6 mmx modules mouse multilib ncurses nls nptl openmp pam pcre pulseaudio readline session sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 systemd tcpd threads unicode vim-syntax zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 7 thegeekpirate 2014-10-21 10:15:49 UTC
Forgot to add:

emerge -vpq x11-drivers/nvidia-drivers

[ebuild   R   ] x11-drivers/nvidia-drivers-343.22-r2  USE="X multilib tools -acpi -pax_kernel -uvm"
Comment 8 thegeekpirate 2014-10-21 10:22:29 UTC
From https://code.google.com/p/epub-samples/downloads/list, I tried "accessible_epub_3-20121024.epub" and "epub30-spec-20121128.epub", both had this issue.

The background as well as previous pages aren't being redrawn so they are never removed, making the elements on new pages overlap the previous ones instead.

On start, it also seems to take portions of the current desktop as the background.
Comment 9 Andrey Grozin gentoo-dev 2018-03-18 19:19:22 UTC
I cannot reproduce this effect. I have >250 .epub books and >7500 .fb2.zip books in my personal library.