Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 497442 - cannot access /boot (ext2): BUG: unable to handle kernel paging request at ext2_get_page.clone
Summary: cannot access /boot (ext2): BUG: unable to handle kernel paging request at ex...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2014-01-07 19:54 UTC by Dave Kemper
Modified: 2014-07-29 15:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

excerpt from syslog (syslog_output,2.78 KB, text/plain)
2014-01-07 19:54 UTC, Dave Kemper
/usr/src/linux/.config (cc,69.24 KB, text/plain)
2014-01-07 19:57 UTC, Dave Kemper
emerge --info (,4.75 KB, text/plain)
2014-01-07 19:58 UTC, Dave Kemper

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Kemper 2014-01-07 19:54:24 UTC
Created attachment 367318 [details]
excerpt from syslog

(I am honestly not sure where to file this bug.  It might be more appropriate on, but although the problem is showing up in the ext2 file system module, I am not convinced it is completely kernel/filesystem related: everything used to work, and has only recently stopped, leading me to suspect some recent upgrade to some other package has destabilized the system.  I am not sure how to track down what, and hope that someone can provide some debugging guidance.)

/boot is an ext2 file system (the only ext2 system on this machine).  It is not mounted by default; when needed, I manually mount it.  This has always worked in the past, but not the last couple of times I've tried to access it.

The partition mounts without error, but as soon as I try to read from it (via "ls"), my terminal responds with "Killed", and I get a lot of syslog output (which I've attached), starting with the lines:

 BUG: unable to handle kernel paging request at ff96b004
 IP: [<f8026506>] ext2_get_page.clone.10+0xe6/0x261 [ext2]
 *pde = 377fd067 *pte = 00000000
 Oops: 0000 [#1] SMP

There is nothing actually wrong with the /boot partition: GRUB and the kernel both work correctly to boot the machine.  It is only on the running system that I can no longer access /boot.

The consequent problem is that, without access to /boot on the running system, I can do nothing to change the kernel or boot loader.  A newer kernel may have already fixed the bug that syslog is reporting, or a change to the current kernel's config may solve the issue or provide more info helpful to debugging.  But until I can access /boot, I cannot change the kernel.
Comment 1 Dave Kemper 2014-01-07 19:57:35 UTC
Created attachment 367320 [details]
Comment 2 Dave Kemper 2014-01-07 19:58:31 UTC
Created attachment 367322 [details]
emerge --info
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-04-02 15:57:16 UTC
3.2.12 is a 2 years old kernel; can you try the newest kernel and report back?
Comment 4 Dave Kemper 2014-04-03 03:17:18 UTC
I would very much like to; however, for the reason explained in the last paragraph of comment #0, I cannot until this bug is resolved.
Comment 5 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-04-03 10:16:28 UTC
(In reply to Dave Kemper from comment #4)
> I would very much like to; however, for the reason explained in the last
> paragraph of comment #0, I cannot until this bug is resolved.

Can you try to access it from a livecd? Might it be the case that there is a problem with the partition and not with the kernel?
Comment 6 Dave Kemper 2014-04-04 16:55:08 UTC
Hi Tom,

It seemed unlikely there was a problem with the partition; if /boot were corrupted, the machine wouldn't be able to boot.

But I did try booting the machine from a (non-Gentoo) CD-based Linux.  I was then able to mount /boot and successfully access it.  So the partition is fine.
Comment 7 Mike Pagano gentoo-dev 2014-05-01 18:04:31 UTC
Is this feasible?  Compile a kernel while in the livecd. mount the /boot

Copy over the new kernel, fix the grub cfg and boot into it?
Comment 8 Dave Kemper 2014-07-28 04:08:23 UTC
Mike: Yes, that did the trick.  I upgraded the kernel and /boot now mounts successfully.  Thank you!
Comment 9 Mike Pagano gentoo-dev 2014-07-29 15:45:34 UTC