Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 496800 - x11-libs/libxcb-1.10 version bump
Summary: x11-libs/libxcb-1.10 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matt Turner
URL:
Whiteboard:
Keywords: InOverlay
: 498506 (view as bug list)
Depends on:
Blocks: qt5-porting
  Show dependency tree
 
Reported: 2014-01-02 19:53 UTC by teidakankan
Modified: 2014-01-26 19:09 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description teidakankan 2014-01-02 19:53:30 UTC
http://xcb.freedesktop.org/dist/libxcb-1.10.tar.bz2

22-Dec-2013 07:12 	464K	

Reproducible: Always




Release 1.10 (2013-12-22)
=========================
* Bump libxcb-xkb SONAME due to ABI break introduced in 1.9.2
* Enable libxcb-xkb by default
* Bump libxcb-sync SONAME
* c_client.py: Fix _sizeof() functions
* c_client.py: Do not create pointers in unions
* c_client.py: Always initialize xcb_align_to
* Re-introduce xcb_ge_event_t (deprecated, xcb_ge_generic_event_t should be
  used instead)
* Fix alignment issues in FD passing code
* Fix poll() if POLLIN == ROLLRDNORM|POLLRDBAND
* Use /usr/spool/sockets/X11/ on HP-UX for UNIX sockets
* Make xsltproc optional
Comment 1 Dennis Schridde 2014-01-04 19:22:47 UTC
This should also fix https://bugreports.qt-project.org/browse/QTBUG-34748 and thus remove the need for =x11-libs/libxcb-1.9.1*[xkb] in dev-qt/qtgui-5.2.0::qt.
Comment 2 Dennis Schridde 2014-01-04 19:25:36 UTC
Also see the announcement for details: http://lists.x.org/archives/xorg-announce/2013-December/002383.html
Comment 3 Dennis Schridde 2014-01-04 20:03:15 UTC
Renaming the 9999 ebuild in x11 overlay to 1.10 and adjusting the xcb-proto dependencies from >=1.9 to >=1.10 works fine.
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-07 16:15:59 UTC
It may be a good idea to include http://cgit.freedesktop.org/xcb/libxcb/commit/?id=3b72a2c9d1d656c74c691a45689e1d637f669e3a when bumping.
Comment 5 Alexey Shvetsov gentoo-dev 2014-01-19 18:21:57 UTC
Bumped libxcb and xcb-proto in x11 overlay
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2014-01-21 15:40:29 UTC
*** Bug 498506 has been marked as a duplicate of this bug. ***
Comment 7 Matt Turner gentoo-dev 2014-01-26 19:09:19 UTC
Bumped. Thanks!