Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 496700 - xfce4-session does not emerge unless I emerge xml-parser first
Summary: xfce4-session does not emerge unless I emerge xml-parser first
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-01 20:34 UTC by Louis
Modified: 2014-01-02 13:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Louis 2014-01-01 20:34:05 UTC
xfce4-session will not emerge, it gives me errors.

if I emerge xml-parser, THEN go on to emerge xfce4-session, everything works fine. 

IMO, xml-parser should be a prerequisite before portage tries to compile xfce4-session. 

Here is what I get

	

    [32;01m * [39;49;00mPackage:    xfce-base/xfce4-session-4.10.0-r1
    [32;01m * [39;49;00mRepository: gentoo
    [32;01m * [39;49;00mMaintainer: xfce@gentoo.org
    [32;01m * [39;49;00mUSE:        amd64 consolekit elibc_glibc kernel_linux policykit udev userland_GNU xscreensaver
    [32;01m * [39;49;00mFEATURES:   preserve-libs sandbox userpriv usersandbox
    >>> Unpacking source...
    >>> Unpacking xfce4-session-4.10.0.tar.bz2 to /var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work
    >>> Source unpacked in /var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work
    >>> Preparing source in /var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work/xfce4-session-4.10.0 ...
     [32;01m*[0m Applying xfce4-session-4.10.0-multiple-interactive-session-save.patch ...
    [A[72C [34;01m[ [32;01mok[34;01m ][0m
     [32;01m*[0m Running elibtoolize in: xfce4-session-4.10.0/
     [32;01m*[0m   Applying portage/1.2.0 patch ...
     [32;01m*[0m   Applying sed/1.5.6 patch ...
     [32;01m*[0m   Applying as-needed/2.4.2 patch ...
     [32;01m*[0m   Applying target-nm/2.4.2 patch ...
    >>> Source prepared.
    >>> Configuring source in /var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work/xfce4-session-4.10.0 ...
     * econf: updating xfce4-session-4.10.0/config.guess with /usr/share/gnuconfig/config.guess
     * econf: updating xfce4-session-4.10.0/config.sub with /usr/share/gnuconfig/config.sub
    ./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-silent-rules --disable-dependency-tracking --docdir=/usr/share/doc/xfce4-session-4.10.0-r1 --with-xsession-prefix=/usr --disable-libgnome-keyring --enable-debug=minimum
    checking whether make sets $(MAKE)... yes
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking whether make supports nested variables... yes
    checking for style of include used by make... GNU
    checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
    checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
    checking dependency style of x86_64-pc-linux-gnu-gcc... none
    checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking minix/config.h usability... no
    checking minix/config.h presence... no
    checking for minix/config.h... no
    checking whether it is safe to define __EXTENSIONS__... yes
    checking for x86_64-pc-linux-gnu-gcc... (cached) x86_64-pc-linux-gnu-gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether x86_64-pc-linux-gnu-gcc accepts -g... (cached) yes
    checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... (cached) none needed
    checking dependency style of x86_64-pc-linux-gnu-gcc... (cached) none
    checking whether x86_64-pc-linux-gnu-gcc and cc understand -c and -o together... yes
    checking whether NLS is requested... yes
    checking for intltool-update... /usr/bin/intltool-update
    checking for intltool-merge... /usr/bin/intltool-merge
    checking for intltool-extract... /usr/bin/intltool-extract
    checking for xgettext... /usr/bin/xgettext
    checking for msgmerge... /usr/bin/msgmerge
    checking for msgfmt... /usr/bin/msgfmt
    checking for gmsgfmt... /usr/bin/gmsgfmt
    checking for perl... /usr/bin/perl
    checking for perl >= 5.8.1... 5.16.3
    checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
     
    !!! Please attach the following file when seeking support:
    !!! /var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work/xfce4-session-4.10.0/config.log
     [31;01m*[0m ERROR: xfce-base/xfce4-session-4.10.0-r1::gentoo failed (configure phase):
     [31;01m*[0m   econf failed
     [31;01m*[0m
     [31;01m*[0m Call stack:
     [31;01m*[0m          ebuild.sh, line   93:  Called src_configure
     [31;01m*[0m        environment, line 3463:  Called xfconf_src_configure
     [31;01m*[0m        environment, line 4016:  Called econf '--docdir=/usr/share/doc/xfce4-session-4.10.0-r1' '--with-xsession-prefix=/usr' '--disable-libgnome-keyring' '--enable-debug=minimum'
     [31;01m*[0m   phase-helpers.sh, line  577:  Called die
     [31;01m*[0m The specific snippet of code:
     [31;01m*[0m                          die "econf failed"
     [31;01m*[0m
     [31;01m*[0m If you need support, post the output of `emerge --info '=xfce-base/xfce4-session-4.10.0-r1::gentoo'`,
     [31;01m*[0m the complete build log and the output of `emerge -pqv '=xfce-base/xfce4-session-4.10.0-r1::gentoo'`.
     [31;01m*[0m The complete build log is located at '/var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/temp/build.log'.
     [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/temp/environment'.
     [31;01m*[0m Working directory: '/var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work/xfce4-session-4.10.0'
     [31;01m*[0m S: '/var/tmp/portage/xfce-base/xfce4-session-4.10.0-r1/work/xfce4-session-4.10.0'



here is the emerge --info for this package

	

    [ebuild  N    ] xfce-base/xfce4-session-4.10.0-r1  USE="consolekit policykit udev xscreensaver -debug -gnome-keyring"
     
     * IMPORTANT: 9 news items need reading for repository 'gentoo'.
     * Use eselect news to read news items.

here is the emerge --info for my machine

# emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     8007236 total,     99216 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 01 Jan 2014 09:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo mate-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.gtlib.gatech.edu/pub/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mate"
SYNC="rsync://rsync5.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dv dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran fuse gdbm gif gpm gtk hddtemp iconv imagemagick ios ipv6 jpeg lame lcms ldap libnotify lock mad matroska melt mmx mng modules mp3 mp4 mpeg mudflap multilib musepack ncurses nls nptl nvidia ogg opengl openmp opus pam pango pcre pda pdf png policykit ppds pulseaudio qt qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg synaptics tcpd thunar tiff truetype udev udisks unicode upower usb vdpau vorbis wavpack wifi win32codecs wxwidgets x264 xcb xine xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON




Reproducible: Always

Steps to Reproduce:
1.emerge xfce4-session
2.watch error
Actual Results:  
I received the error I put in the log

Expected Results:  
I expect xfce4-session to compile without issue
Comment 1 Jeroen Roovers gentoo-dev 2014-01-02 13:19:36 UTC

*** This bug has been marked as a duplicate of bug 41124 ***