Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 495126 - sys-apps/portage: --with-bdeps=n default leads to broken dependencies that break --depclean
Summary: sys-apps/portage: --with-bdeps=n default leads to broken dependencies that br...
Status: RESOLVED CANTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 155723
  Show dependency tree
 
Reported: 2013-12-23 13:23 UTC by Markus Oehme
Modified: 2015-05-15 06:05 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,5.58 KB, text/plain)
2013-12-23 13:23 UTC, Markus Oehme
Details
requested output of emerge --debug (xzipped) (debug.log.xz,368.84 KB, application/x-xz)
2013-12-23 16:44 UTC, Markus Oehme
Details
requested output of emerge --depclean --debug (xzipped) (depclean_debug.log.xz,497.54 KB, application/x-xz)
2013-12-24 00:11 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2013-12-23 13:23:08 UTC
Created attachment 365990 [details]
emerge --info

On my system 'emerge -c' fails due to the following error:

 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 * 
 *   sci-libs/hdf5:0/1.8.11= pulled in by:
 *     dev-python/pytables-3.0.0

Manually downgrading hdf5 to version 1.8.11 temporarily resolves this, but upon 'emerge -uD @world' it gets upgraded to version 1.8.12 again.

I'll try to give the relevant info, but tell me if I miss something. Output of 'emerge -vcp hdf5':

Calculating dependencies... done!
  sci-libs/hdf5-1.8.12 pulled in by:
    dev-python/pytables-3.0.0 requires sci-libs/hdf5:=
    media-libs/vigra-1.9.0 requires sci-libs/hdf5
    sci-libs/flann-1.8.4 requires sci-libs/hdf5

pytables is ultimately pulled in by sci-mathematics/sage on my system (although sage is not in main tree, the ebuilds for hdf5 and pytables are from the main tree).
Comment 1 Sebastian Luther (few) 2013-12-23 14:05:20 UTC
What's the output of "emerge -cp" when hdf-1.8.11 is installed?

Please attach the debug.log created by
"emerge -uD @world --pretend --debug &>debug.log"
when hdf-1.8.11 is installed.
Comment 2 Markus Oehme 2013-12-23 16:42:06 UTC
(In reply to Sebastian Luther (few) from comment #1)
> What's the output of "emerge -cp" when hdf-1.8.11 is installed?

It says everything is fine and nothing needs to be removed.

> Please attach the debug.log created by
> "emerge -uD @world --pretend --debug &>debug.log"
> when hdf-1.8.11 is installed.

In the works.
Comment 3 Markus Oehme 2013-12-23 16:44:12 UTC
Created attachment 366000 [details]
requested output of emerge --debug (xzipped)

HTH, it's rather large ...
Comment 4 Sebastian Luther (few) 2013-12-23 17:36:09 UTC
Please attach the depclean_debug.log created by
"emerge -cpv --debug &> depclean_debug.log".

According to your debug.log dev-python/pytables isn't a deep dependency of @world. This explains why its dependency on hdf5 is ignored with -uD. I would expect it to be removed by "emerge -c". Lets find out why it isn't.
Comment 5 Markus Oehme 2013-12-24 00:11:11 UTC
Created attachment 366052 [details]
requested output of emerge --depclean --debug (xzipped)

I manually pieced together the following dependency chain:

sci-libs/hdf5:0/1.8.11=
dev-python/pytables-3.0.0
dev-python/pandas-0.12.0
dev-python/rpy-2.3.8
sci-mathematics/sage-5.12

and I took a close look at my world file and sage is listed normally like every other atom.
Comment 6 Sebastian Luther (few) 2013-12-24 06:15:11 UTC
This seems to be a duplicate of bug 493374.

The problem is that the dependency between rpy and pandas is only build time.
This leads emerge to ignore it during -uD world, but consider it during -c.

As a workaround use either --with-bdeps=y for -uD or --with-bdeps=n for -c.
Comment 7 Sebastian Luther (few) 2014-01-01 18:36:43 UTC

*** This bug has been marked as a duplicate of bug 493374 ***
Comment 8 Sebastian Luther (few) 2014-01-18 17:53:40 UTC
I changed my mind. The issue is different and may be fixed in a different way.
Comment 9 Ian Delaney (RETIRED) gentoo-dev 2015-05-14 23:24:14 UTC
  17 Feb 2015; Justin Lecher <jlec@gentoo.org> -pytables-3.0.0.ebuild,
  -pytables-3.1.0.ebuild, -pytables-3.1.1.ebuild:
  Drop old
Comment 10 Zac Medico gentoo-dev 2015-05-15 00:11:48 UTC
(In reply to Sebastian Luther (few) from comment #6)
> This seems to be a duplicate of bug 493374.
> 
> The problem is that the dependency between rpy and pandas is only build time.
> This leads emerge to ignore it during -uD world, but consider it during -c.
> 
> As a workaround use either --with-bdeps=y for -uD or --with-bdeps=n for -c.

Unfortunately, there's no way do avoid inconsistencies like this when you have an option like --with-bdeps=n, so I recommend to put --with-bdeps=y in EMERGE_DEFAULT_OPTS if it bothers you.