Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 495054 - app-office/libreoffice-4.1.3.2 and r2 are missing Archive/Zip Perl dependency
Summary: app-office/libreoffice-4.1.3.2 and r2 are missing Archive/Zip Perl dependency
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-22 20:24 UTC by Sumit Khanna
Modified: 2013-12-23 02:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
configuration log (config.log,43.18 KB, text/plain)
2013-12-22 20:25 UTC, Sumit Khanna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Khanna 2013-12-22 20:24:35 UTC
During the ./configure phase, the build bombs out because libreoffice apparently now needs the Archive/Zip Perl module:

checking for perl... /usr/bin/perl
checking the Perl version... checked (perl 5)
checking for required Perl modules... Can't locate Archive/Zip.pm in @INC (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
configure: error: Failed to find some modules

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/libreoffice-4.1.3.2-r2/work/libreoffice-4.1.3.2/config.log
 * ERROR: app-office/libreoffice-4.1.3.2-r2::gentoo failed (configure phase):


Reproducible: Always
Comment 1 Sumit Khanna 2013-12-22 20:25:58 UTC
Created attachment 365914 [details]
configuration log
Comment 2 Sumit Khanna 2013-12-22 20:55:23 UTC
Turns out I had Archive-Zip emerged. I re-emerged it and libreoffice now compiles. Odd
Comment 3 Jeroen Roovers gentoo-dev 2013-12-23 02:03:30 UTC

*** This bug has been marked as a duplicate of bug 41124 ***