Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 494488 - =sys-fs/ntfs3g-2013.1.13[ntfsdecrypt]: error: unknown type name ‘gcry_module_t’ with >=dev-libs/libgcrypt-1.6.0
Summary: =sys-fs/ntfs3g-2013.1.13[ntfsdecrypt]: error: unknown type name ‘gcry_module_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Patrick McLean
URL: http://tuxera.com/forum/viewtopic.php...
Whiteboard:
Keywords:
: 494494 494736 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-17 05:29 UTC by Alexandre
Modified: 2014-02-27 08:11 UTC (History)
40 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Complete build log. (build.log,42.77 KB, text/plain)
2013-12-17 05:29 UTC, Alexandre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre 2013-12-17 05:29:02 UTC
'sys-fs/ntfs3g-2013.1.13' fail to compile against 'dev-libs/libgcrypt-1.6.0':

error: unknown type name ‘gcry_module_t’

Reproducible: Always




Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.17, 3.12.5-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.12.5-gentoo-x86_64-Intel-R-_Pentium-R-_Dual_CPU_T3400_@_2.16GHz-with-gentoo-2.2
KiB Mem:     2821568 total,     91560 free
KiB Swap:    1048572 total,    979860 free
Timestamp of tree: Tue, 17 Dec 2013 01:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.1-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo privacychain
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -g0"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -g0"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" ftp://gentoo.c3sl.ufpr.br/gentoo/ http://gentoo.c3sl.ufpr.br/ ftp://ftp.las.ic.unicamp.br/pub/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ "
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage/"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt css cups custom-cflags custom-optimization cxx dbus declarative dga dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac gdbm gif gnutls gpm gtk iconv infinality jpeg kde kipi lame lcms libnotify lzma lzo mad minimal mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl nvidia offensive ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline samba sdl semantic-desktop session spell sse sse2 sse3 ssl ssse3 startup-notification svg syslog tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vdpau vim-syntax vorbis vpx wavpack wxwidgets x264 xcb xcomposite xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel loopback" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-fs/ntfs3g-2013.1.13 was built with the following:
USE="acl crypt external-fuse ntfsprogs -debug -static-libs -suid -xattr"
Comment 1 Alexandre 2013-12-17 05:29:36 UTC
Created attachment 365496 [details]
Complete build log.
Comment 2 Marien Zwart (RETIRED) gentoo-dev 2013-12-17 10:18:58 UTC
Me too! (*ducks*)

From libgcrypt-1.6.0's NEWS file:

 * Removed the long deprecated gcry_ac interface.  Thus Libgcrypt is
   not anymore ABI compatible to previous versions if they used the ac
   interface.

 * Removed the module register subsystem.

It sounds as if the second one of these breaks ntfs-3g. I don't see a more recent release of ntfs-3g that copes with this, nor have I found their version control yet to see if it's fixed there. Still looking.
Comment 3 Marien Zwart (RETIRED) gentoo-dev 2013-12-17 10:22:56 UTC
*** Bug 494494 has been marked as a duplicate of this bug. ***
Comment 4 Marien Zwart (RETIRED) gentoo-dev 2013-12-17 11:27:33 UTC
The upstream commit to libgcrypt removing module support is http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commitdiff;h=e0fe4a5c862a1646066044dfe8e99264e2331752

Judging from the commit message ntfs-3g is out of luck and fixing this will take more than a few lines (a possible simpler replacement is mentioned ("dlopening modules at startup time from a dedicated directory") but judging from the NEWS file it hasn't been implemented yet, and it might not be appropriate for ntfs-3g).
Comment 5 piruthiviraj natarajan 2013-12-17 11:57:09 UTC
Since this breakage in ntfs3g is unwarranted, can libcrypt at least be masked?
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2013-12-17 12:05:45 UTC
(In reply to piruthiviraj natarajan from comment #5)
> Since this breakage in ntfs3g is unwarranted, can libcrypt at least be
> masked?

This is the only package that broke for me out of 29 packages that needed recompilation. I wouldn't mask it because of a one package breakage.
Comment 7 piruthiviraj natarajan 2013-12-17 12:10:05 UTC
How to let the people trying to upgrade know that this libgcrypt upgrade would break ntfs3g?
Comment 8 Jakub Caban 2013-12-17 13:12:38 UTC
Building with crypt USE flag disabled works for me. As I don't need it anyway this workaround suits me. Maybe some of you too ;)
Comment 9 Ben Kohler gentoo-dev 2013-12-17 16:31:41 UTC
I think the least disruptive 'fix' would probably be to package.use.mask the crypt flag here.  I think the vast majority of users will not care.

Forcing a lower version of libgcrypt in ntfs3g's dependencies is "correct" but will cause a lot of rebuilds, plus a lot of portage screaming about slot mismatches, dependency conflicts, etc.

I guess another 'not so disruptive' option would be to check for has_version ">dev-libs/libgcrypt-1.6" && use crypt, and throw a big warning during pkg_pretend or some other early phase.
Comment 10 Robert Cabrera 2013-12-18 02:18:40 UTC
I just got hit with this on my ~amd64 laptop. Disabling crypt use gets it to build and clear preserved-rebuild queue, but how will this affect applications that depend on it?
Comment 11 Marien Zwart (RETIRED) gentoo-dev 2013-12-18 09:43:09 UTC
Ah, derp, I should have noticed that USE flag.

There are remarkably few dependencies on ntfs3g in the tree. app-admin/testdisk[ntfs] depends on ntfs3g, sys-block/gparted[ntfs] depends on ntfs3g[ntfsprogs], and os-prober does not depend on ntfs3g but mentions it in an elog message. None of these mention the crypt USE flag, so they should still work with ntfs3g without crypt.

metadata.xml for ntfs3g explains (unsurprisingly) the crypt USE flag is needed to "Add support for encrypted NTFS drives/partitions.". So if you don't have one of those you're fine, and if you do the previously mentioned packages won't be able to access that data anymore.

Would it be worth changing the ntfs3g ebuild to have -crypt in IUSE?
Comment 12 Marien Zwart (RETIRED) gentoo-dev 2013-12-18 10:11:10 UTC
It's even less important than that: disabling crypt disables the ntfsdecrypt utility, which can be used to decrypt individual files. Unless I'm overlooking something this isn't supported by ntfs-3g itself (the FUSE filesystem). So disabling the USE flag should be fine, unless you or some utility explicitly runs ntfsdecrypt.

Also, all this is disabled by default upstream. A plain "./configure && make" succeeds. That seems like an argument for -crypt in IUSE.
Comment 13 piruthiviraj natarajan 2013-12-18 10:31:14 UTC
Even after sorting out ntfs3g with -crypt USE variable my chrome is spitting some errors with emerge @preserved-rebuild. How to solve this? I tried emerge @preserved-rebuild but chrome does build and gets installed but at the end showing this errors everytime.

!!! existing preserved libs:
>>> package: dev-libs/libgcrypt-1.6.0
 *  - /usr/lib64/libgcrypt.so.11
 *  - /usr/lib64/libgcrypt.so.11.8.2
 *      used by /opt/google/chrome/chrome (www-client/google-chrome-31.0.1650.63_p1)
Use emerge @preserved-rebuild to rebuild packages using these libraries
Comment 14 Samuli Suominen gentoo-dev 2013-12-18 11:28:12 UTC
(In reply to Marien Zwart from comment #12)
> It's even less important than that: disabling crypt disables the ntfsdecrypt
> utility, which can be used to decrypt individual files. Unless I'm
> overlooking something this isn't supported by ntfs-3g itself (the FUSE
> filesystem). So disabling the USE flag should be fine, unless you or some
> utility explicitly runs ntfsdecrypt.
> 
> Also, all this is disabled by default upstream. A plain "./configure &&
> make" succeeds. That seems like an argument for -crypt in IUSE.

poor argument when the USE_ORDER renders -crypt in ebuild meaningless, however package.use in profiles/ would be different case
the default order is "env:pkg:conf:defaults:pkginternal:repo:env.d" IIRC

also, please, there is no need for futher commenting on the bug unless it's the patch itself -- as in, the problem has been already confirmed
Comment 15 Lars Wendler (Polynomial-C) gentoo-dev 2013-12-18 11:41:49 UTC
(In reply to piruthiviraj natarajan from comment #13)
> Even after sorting out ntfs3g with -crypt USE variable my chrome is spitting
> some errors with emerge @preserved-rebuild. How to solve this? I tried
> emerge @preserved-rebuild but chrome does build and gets installed but at
> the end showing this errors everytime.
> 
> !!! existing preserved libs:
> >>> package: dev-libs/libgcrypt-1.6.0
>  *  - /usr/lib64/libgcrypt.so.11
>  *  - /usr/lib64/libgcrypt.so.11.8.2
>  *      used by /opt/google/chrome/chrome
> (www-client/google-chrome-31.0.1650.63_p1)
> Use emerge @preserved-rebuild to rebuild packages using these libraries

This bug is about sys-fs/ntfs3g. Your problem is tracked via bug #494596
Comment 16 tman 2013-12-18 21:01:13 UTC
same problem here :((

_3g_la-lcnalloc.o .libs/libntfs_3g_la-logfile.o .libs/libntfs_3g_la-logging.o .libs/libntfs_3g_la-mft.o .libs/libntfs_3g_la-misc.o .libs/libntfs_3g_la-mst.o .libs/libntfs_3g_la-object_id.o .libs/libntfs_3g_la-realpath.o .libs/libntfs_3g_la-reparse.o .libs/libntfs_3g_la-runlist.o .libs/libntfs_3g_la-security.o .libs/libntfs_3g_la-unistr.o .libs/libntfs_3g_la-volume.o .libs/libntfs_3g_la-xattrs.o .libs/libntfs_3g_la-unix_io.o   -march=corei7 -Wl,-O1 -Wl,--as-needed -Wl,-soname -Wl,libntfs-3g.so.84 -o .libs/libntfs-3g.so.84.0.0
(cd .libs && rm -f libntfs-3g.so.84 && ln -s libntfs-3g.so.84.0.0 libntfs-3g.so.84)
(cd .libs && rm -f libntfs-3g.so && ln -s libntfs-3g.so.84.0.0 libntfs-3g.so)
creating libntfs-3g.la
(cd .libs && rm -f libntfs-3g.la && ln -s ../libntfs-3g.la libntfs-3g.la)
make[2]: Leaving directory '/var/tmp/portage/sys-fs/ntfs3g-2013.1.13/work/ntfs-3g_ntfsprogs-2013.1.13/libntfs-3g'
Making all in ntfsprogs
make[2]: Entering directory '/var/tmp/portage/sys-fs/ntfs3g-2013.1.13/work/ntfs-3g_ntfsprogs-2013.1.13/ntfsprogs'
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsfix.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c utils.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsinfo.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfscluster.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c cluster.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsls.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfscat.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfscmp.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsdump_logfile.c
ntfsinfo.c: In function ‘ntfs_dump_attr_ea’:
ntfsinfo.c:2040:4: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
    printf("0%o\n", (unsigned)le32_to_cpu(*(le32*)
    ^
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfswipe.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c attrdef.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfstruncate.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsmove.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsmftalloc.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g    -march=corei7 -O2 -pipe -Wall -c ntfsck.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g     -march=corei7 -O2 -pipe -Wall -c -o ntfsdecrypt-ntfsdecrypt.o `test -f 'ntfsdecrypt.c' || echo './'`ntfsdecrypt.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g     -march=corei7 -O2 -pipe -Wall -c -o ntfsdecrypt-utils.o `test -f 'utils.c' || echo './'`utils.c
ntfsdecrypt.c:116:1: error: unknown type name ‘gcry_module_t’
 static gcry_module_t ntfs_desx_module;
 ^
ntfsdecrypt.c: In function ‘ntfs_crypto_deinit’:
ntfsdecrypt.c:397:3: warning: implicit declaration of function ‘gcry_cipher_unregister’ [-Wimplicit-function-declaration]
   gcry_cipher_unregister(ntfs_desx_module);
   ^
ntfsdecrypt.c:398:20: warning: assignment makes integer from pointer without a cast [enabled by default]
   ntfs_desx_module = NULL;
                    ^
ntfsdecrypt.c: At top level:
ntfsdecrypt.c:935:1: error: unknown type name ‘gcry_cipher_spec_t’
 static gcry_cipher_spec_t ntfs_desx_cipher = {
 ^
ntfsdecrypt.c:936:2: error: field name not in record or union initializer
  .name = "DES-X-MS128",
  ^
ntfsdecrypt.c:936:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:936:2: warning: initialization makes integer from pointer without a cast [enabled by default]
ntfsdecrypt.c:936:2: warning: (near initialization for ‘ntfs_desx_cipher’) [enabled by default]
ntfsdecrypt.c:936:2: error: initializer element is not computable at load time
ntfsdecrypt.c:936:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:937:2: error: field name not in record or union initializer
  .blocksize = 8,
  ^
ntfsdecrypt.c:937:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:937:2: warning: excess elements in scalar initializer [enabled by default]
ntfsdecrypt.c:937:2: warning: (near initialization for ‘ntfs_desx_cipher’) [enabled by default]
ntfsdecrypt.c:938:2: error: field name not in record or union initializer
  .keylen = 128,
  ^
ntfsdecrypt.c:938:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:938:2: warning: excess elements in scalar initializer [enabled by default]
ntfsdecrypt.c:938:2: warning: (near initialization for ‘ntfs_desx_cipher’) [enabled by default]
ntfsdecrypt.c:939:2: error: field name not in record or union initializer
  .contextsize = sizeof(ntfs_desx_ctx),
  ^
ntfsdecrypt.c:939:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:939:2: warning: excess elements in scalar initializer [enabled by default]
ntfsdecrypt.c:939:2: warning: (near initialization for ‘ntfs_desx_cipher’) [enabled by default]
ntfsdecrypt.c:940:2: error: field name not in record or union initializer
  .setkey = ntfs_desx_setkey,
  ^
ntfsdecrypt.c:940:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:940:2: warning: excess elements in scalar initializer [enabled by default]
ntfsdecrypt.c:940:2: warning: (near initialization for ‘ntfs_desx_cipher’) [enabled by default]
ntfsdecrypt.c:941:2: error: field name not in record or union initializer
  .decrypt = ntfs_desx_decrypt,
  ^
ntfsdecrypt.c:941:2: error: (near initialization for ‘ntfs_desx_cipher’)
ntfsdecrypt.c:941:2: warning: excess elements in scalar initializer [enabled by default]
ntfsdecrypt.c:941:2: warning: (near initialization for ‘ntfs_desx_cipher’) [enabled by default]
ntfsdecrypt.c: In function ‘ntfs_fek_import_from_raw’:
ntfsdecrypt.c:1099:4: warning: implicit declaration of function ‘gcry_cipher_register’ [-Wimplicit-function-declaration]
    err = gcry_cipher_register(&ntfs_desx_cipher,
    ^
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../include/ntfs-3g     -march=corei7 -O2 -pipe -Wall -c -o mkntfs-attrdef.o `test -f 'attrdef.c' || echo './'`attrdef.c
Makefile:801: recipe for target 'ntfsdecrypt-ntfsdecrypt.o' failed
make[2]: *** [ntfsdecrypt-ntfsdecrypt.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/var/tmp/portage/sys-fs/ntfs3g-2013.1.13/work/ntfs-3g_ntfsprogs-2013.1.13/ntfsprogs'
Makefile:335: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-fs/ntfs3g-2013.1.13/work/ntfs-3g_ntfsprogs-2013.1.13'
Makefile:248: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: sys-fs/ntfs3g-2013.1.13::gentoo failed (compile phase):
 *   emake failed
Comment 17 Samuli Suominen gentoo-dev 2013-12-19 09:41:52 UTC
Looks like gcry_module_t is part of the former module system that got punted entirely:

http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commitdiff;h=628ed5ba0ef4b1f04b5a77e29e4bc49a1fe13c07

Propably not going to be trivial to patch.
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2013-12-19 12:01:12 UTC
*** Bug 494736 has been marked as a duplicate of this bug. ***
Comment 19 Billy DeVincentis 2013-12-20 02:58:14 UTC
I het this too. I wonder if ntfs3g-ar ebuilds in bugzilla work?
Comment 20 devsk 2013-12-20 03:36:55 UTC
Since libgcrypt-1.6 breaks two packages (ntfs3g and sys-power/suspend), can we at least mask it? Is there a feature from 1.6 that gentoo folks are craving for?
Comment 21 Markos Chandras (RETIRED) gentoo-dev 2013-12-20 19:46:06 UTC
(In reply to devsk from comment #20)
> Since libgcrypt-1.6 breaks two packages (ntfs3g and sys-power/suspend), can
> we at least mask it? Is there a feature from 1.6 that gentoo folks are
> craving for?

You are free to mask it yourself in /etc/portage/package.mask
Comment 22 Johannes Hirte 2013-12-20 20:06:09 UTC
(In reply to devsk from comment #20)
> Since libgcrypt-1.6 breaks two packages (ntfs3g and sys-power/suspend), can
> we at least mask it? Is there a feature from 1.6 that gentoo folks are
> craving for?

media-sound/spotify seems to be broken too
Comment 23 Samuli Suominen gentoo-dev 2013-12-21 03:29:56 UTC
like said, there is no need to comment on this bug whatsoever unless it's the patch. as in, the bug has been verified and everything else is just noise.

please stop the bugspam ;)
Comment 24 devsk 2013-12-21 04:29:29 UTC
(In reply to Markos Chandras from comment #21)
> (In reply to devsk from comment #20)
> > Since libgcrypt-1.6 breaks two packages (ntfs3g and sys-power/suspend), can
> > we at least mask it? Is there a feature from 1.6 that gentoo folks are
> > craving for?
> 
> You are free to mask it yourself in /etc/portage/package.mask

Wait...why should thousands of gentoo users edit files to avoid build failures? Is this the first time a package has broken a bunch of packages and is being masked in portage?

What is the criteria for package to move to portage's package.mask? I am just curious.
Comment 25 Kenton Groombridge 2013-12-21 16:24:22 UTC
(In reply to devsk from comment #24)

> Wait...why should thousands of gentoo users edit files to avoid build
> failures? Is this the first time a package has broken a bunch of packages
> and is being masked in portage?
> 
> What is the criteria for package to move to portage's package.mask? I am
> just curious.


And why should thousands of Gentoo users who aren't having build problems because they aren't using affected packages revert back?

You are using Gentoo testing for a reason.  It is called testing.  If you don't want build failures, go back to Gentoo stable.
Comment 26 devsk 2013-12-21 19:42:54 UTC
(In reply to Kenton Groombridge from comment #25)
> (In reply to devsk from comment #24)
> 
> > Wait...why should thousands of gentoo users edit files to avoid build
> > failures? Is this the first time a package has broken a bunch of packages
> > and is being masked in portage?
> > 
> > What is the criteria for package to move to portage's package.mask? I am
> > just curious.
> 
> 
> And why should thousands of Gentoo users who aren't having build problems
> because they aren't using affected packages revert back?
>

May be because you err on the side of caution....:) Isn't the world a better place if nobody has build breakages (including the people who are not using the affected packages...Yes, I am thinking of YOU!)?

Reverting does not break the build!
Comment 27 Mart Raudsepp gentoo-dev 2013-12-21 22:37:27 UTC
Just make ntfs3g[crypt] rdepend on <libgcrypt-1.6 in the meantime or something? chutzpah?
Comment 28 jospezial 2013-12-21 23:44:44 UTC
(In reply to Mart Raudsepp from comment #27)
> Just make ntfs3g[crypt] rdepend on <libgcrypt-1.6 in the meantime or
> something? chutzpah?

Two thumbs up!
Comment 29 Markos Chandras (RETIRED) gentoo-dev 2013-12-22 00:33:32 UTC
(In reply to Mart Raudsepp from comment #27)
> Just make ntfs3g[crypt] rdepend on <libgcrypt-1.6 in the meantime or
> something? chutzpah?

meantime? given the status of ntfs3g the 'meantime' may actually be 'forever'. It's also advisable to not require downgrades on the same stabilization level.

Again, users running testing are expected to be able to workaround the situation for now (mask libgcrypt or disable USE=crypto). Such breakages happen all the time in testing. I don't quite see the reason for so much noise in this particular case.
Comment 30 Samuli Suominen gentoo-dev 2013-12-22 05:54:43 UTC
people comment on the bug without reading the bug.  how very retarded.
Comment 31 devsk 2013-12-22 21:33:54 UTC
Please save this elitist attitude (I am referring to calling others retarded!) for something else. May be for your office. Collaborative work like Gentoo can use less of it, particularly when we can't make eye contact when we "speak".

When you say packages break build all the time in testing, can you give me an example? I have been running ~amd64 for last 10 years. I don't recall an incident where there were many packages build (note that I say "build" and not run time) broken because of one package and the change was not rolled back.
Comment 32 Markos Chandras (RETIRED) gentoo-dev 2013-12-22 21:52:00 UTC
(In reply to devsk from comment #31)
> Please save this elitist attitude (I am referring to calling others
> retarded!) for something else. May be for your office. Collaborative work
> like Gentoo can use less of it, particularly when we can't make eye contact
> when we "speak".
> 
> When you say packages break build all the time in testing, can you give me
> an example? I have been running ~amd64 for last 10 years. I don't recall an
> incident where there were many packages build (note that I say "build" and
> not run time) broken because of one package and the change was not rolled
> back.

Stop this offtopic discussion and move it to forums if you want to continue discussing about the testing tree. Bugzilla is not the place for that.
Comment 33 devsk 2013-12-23 02:10:20 UTC
(In reply to Markos Chandras from comment #32)
> (In reply to devsk from comment #31)
> > Please save this elitist attitude (I am referring to calling others
> > retarded!) for something else. May be for your office. Collaborative work
> > like Gentoo can use less of it, particularly when we can't make eye contact
> > when we "speak".
> > 
> > When you say packages break build all the time in testing, can you give me
> > an example? I have been running ~amd64 for last 10 years. I don't recall an
> > incident where there were many packages build (note that I say "build" and
> > not run time) broken because of one package and the change was not rolled
> > back.
> 
> Stop this offtopic discussion and move it to forums if you want to continue
> discussing about the testing tree. Bugzilla is not the place for that.

How is this offtopic? Someone is saying sys-fs/ntfs3g and sys-power/suspend build breakage is normal because that's what happens all the time. I am asking for an example to substantiate that claim. How is that offtopic? Last build breakage I recall led to masking of freetype.

And whatever happened to a bit of courtesy. At least answer the questions which devs can answer: "What is the criteria for a package to move to portage's package.mask? I am just curious." Asked like 10 posts earlier. Instead of answers all I have gotten so far is insults and elitist attitude.
Comment 34 Justin Lecher gentoo-dev 2013-12-23 11:40:26 UTC
(In reply to devsk from comment #33)
> How is this offtopic? 
...
> And whatever happened to a bit of courtesy. At least answer the questions
> which devs can answer: "What is the criteria for a package to move to
> portage's package.mask? I am just curious." Asked like 10 posts earlier.
> Instead of answers all I have gotten so far is insults and elitist attitude.

Exactly this is offtopic to this bug. Please move to other locations for this question.
Comment 35 Samuli Suominen gentoo-dev 2013-12-23 12:25:01 UTC
can we just stop the bugspam already? it's really just noise.

there is nothing to be done before libgcrypt is slated for stabilization, at which point, if ntfs-3g isn't fixed by then, the USE="crypt" will be package.use.mask'd *for the stabilization*

leaving this fail to build in ~arch meanwhile is fine, expected, perfectly normal, that's what ~arch is for.
Comment 36 Marien Zwart (RETIRED) gentoo-dev 2014-01-10 22:24:32 UTC
http://tuxera.com/forum/viewtopic.php?f=3&t=30541 now has a patch! Unfortunately I won't have time to test it myself until about 2 weeks from now. It should make it build with both old and new libgcrypt.
Comment 37 Samuli Suominen gentoo-dev 2014-02-27 08:11:29 UTC
looks like chutzpah added new 2014 version of the ntfs3g to Portage today that fixes this problem