Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493944 - app-emulation/xen-4.3.1-r1 removes old version but doesn't install itself, on x86/32 -- system unbootable
Summary: app-emulation/xen-4.3.1-r1 removes old version but doesn't install itself, on...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Ian Delaney (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-11 14:22 UTC by Mark H. Wood
Modified: 2014-01-01 11:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark H. Wood 2013-12-11 14:22:04 UTC
xen 4.3.1-r1 appeared in portage last night, so I thought I'd try it this morning.  After updating xen and xen-tools, I booted and was told by grub "no such file" or words to that effect.  Sure enough, the xen kernel is gone!  I got the box up without xen, reinstalled xen 4.3.1-r1 and saw flying by a message that 4.3.x no longer supports x86/32, which means this box can't run it.  I'm falling back to 4.2 and will set up a keyword to block >4.2.99 on my x86/32 boxes.

It would be less surprising if the emerge would *fail* on a box where it can't run.  Ideally the upgrade wouldn't even be offered on such hardware.

Reproducible: Always

Steps to Reproduce:
1.emerge -u xen xen-tools

Actual Results:  
Boot loader says no such file.

Expected Results:  
System boots xen, xen boots domains, everything runs.

theo log # emerge --info
Portage 2.2.7 (default/linux/x86/13.0, gcc-4.7.3, glibc-2.15-r3, 3.10.7-gentoo-r1 i686)
=================================================================
System uname: Linux-3.10.7-gentoo-r1-i686-Intel-R-_Xeon-TM-_CPU_2.80GHz-with-gentoo-2.2
KiB Mem:     2591580 total,   1798484 free
KiB Swap:   10485756 total,  10485756 free
Timestamp of tree: Tue, 10 Dec 2013 23:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo/ http://csociety-ftp.ecn.purdue.edu/pub/gentoo/ http://distfiles.gentoo.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://johncock.ulib.iupui.edu/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx modules mudflap ncurses nptl openmp pam pcre readline session sse sse2 ssl tcpd unicode x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Yixun Lan gentoo-dev 2013-12-11 15:28:44 UTC
could you provide more output/messages of the xen error?
you can use serial console to get this, adjust following line in your grub [1]

kernel       /xen.gz dom0_mem=512M loglvl=all guest_loglvl=all com1=38400,8n1 console=com1

I vaguely remembered that xen *dom0* removing support for x86, just can't find when they've done this.. but you can still running 32bit domU

[1] http://wiki.xenproject.org/wiki/XenSerialConsole
Comment 2 Yixun Lan gentoo-dev 2013-12-11 15:54:32 UTC
I was not correct in my previous comment..
see following release notes, and upstream commit[3]

Remove x86 32-bit and ia64 (itanium) hypervisors. 32bit VMs, including 32bit dom0, are still supported on a x86_64 64bit hypervisor. 

[1] http://wiki.xenproject.org/wiki/Xen_4.3_Release_Notes
[2] http://wiki.xenproject.org/wiki/Xen_4.3_Feature_List

[3] http://xenbits.xen.org/gitweb/?p=xen.git;a=commitdiff;h=5d1181a5ea5e0f11d481a94b16ed00d883f9726e
Comment 3 Ian Delaney (RETIRED) gentoo-dev 2013-12-16 16:41:23 UTC
Well it seems you're about the first to have attempted to boot a 32 bit system dom0, and file, since the release of 4.3.0 in July.  Leaving xen-4.2.2 so as to have a xen that provides a 32 bit dom0, but somewhere down the track as 32 bit xen host will be a deprecated memory of history.

*xen-4.3.1-r2 (16 Dec 2013)
*xen-4.3.0-r5 (16 Dec 2013)

  16 Dec 2013; Ian Delaney <idella4@gentoo.org> +xen-4.3.0-r5.ebuild,
  +xen-4.3.1-r2.ebuild, -xen-4.3.0-r4.ebuild, metadata.xml:
  KEYWORDS.dropped, x86, along with IUSE pae, in 4.3.x, wrt Bug #493944
Comment 4 Brian Dolbec gentoo-dev 2013-12-30 19:29:26 UTC
Re-opening as it is apparently not completely fixed.

[11:04] <elbryan> I notice that the XEN problem I rose a couple of weeks ago is still there :/
[11:06] <jdhore> bugs don't get fixed instantly, sorry
[11:07] <dwfreed> which bug?
[11:08] <dwfreed> elbryan: ^
[11:09] <elbryan> I didn't open it.. I mentioned here that xen-4.3.1 should not be marked as stable for x86
[11:09] <elbryan> as it completely breaks things up
[11:10] <dwfreed> well
[11:10] <dwfreed> >=4.3 no longer supports being a 32 bit hypervisor, but that doesn't stop you from running it under a 32 bit dom0
[11:13] <dwfreed> and all of the userspace tools still work in 32 bit
[11:13] * fau has quit (Quit: Lost terminal)
[11:18] <elbryan> dwfreed: it wipes out your xen modules
[11:18] <elbryan> therefore, you cannot boot anymore
[11:19] <elbryan> the ebuild compiles 0 files and installs 0 files.. thus it deletes your old installation of xen (the xen module in /boot). I think this is a problem.
[11:20] <dwfreed> yeah, idella4 missed one ebuild
[11:20] <dwfreed> bug 493944 is not fixed
[11:20] <willikins> dwfreed: https://bugs.gentoo.org/493944 "app-emulation/xen-4.3.1-r1 removes old version but doesn't install itself, on x86/32 -- system unbootable"; Gentoo Linux, Applications; RESO, FIXE; mwood:idella4
[11:21] <dwfreed> also he needs to fix the 9999 source, because the mercurial repo will be going away, if it hasn't already
[11:23] <dol-sen> dwfreed, can you re-open it? or you want me to, so you can comment on what's missed?
[11:23] <dol-sen> if there isn't one, make a new bug for 9999
[11:24] <elbryan> In the meanwhile marking it unstable should be an intelligent move, I believe
[11:25] <dwfreed> dol-sen: I don't have perms to modify bugs I'm not the creator or the assignee of
[11:25] <dwfreed> dol-sen: but I can update it, at least :)
[11:25] <dol-sen> so, you want me to re-open it?
[11:25] <dwfreed> sure :)
Comment 5 dwfreed 2013-12-30 19:34:39 UTC
app-emulation/xen-4.3.1-r1 is the version in question that still has x86 keyword.  I'd suggest using -x86, so that somebody doesn't try to re-add either a ~x86 or an x86 keyword in the future.
Comment 6 Ian Delaney (RETIRED) gentoo-dev 2013-12-31 02:49:11 UTC
  31 Dec 2013; Ian Delaney <idella4@gentoo.org> xen-4.3.0-r5.ebuild,
  xen-4.3.1-r1.ebuild, xen-4.3.1-r2.ebuild:
  After some further 'discussion', stabalised version corrected to resolve
  residual QA issues, other ebuilds updated to follow suit