Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493018 (vmware-preserved) - app-emulation/vmware-player-6.0.0.1295980 with gnome-base/gnome-keyring-3.8.2 - preserved libs at /usr/lib64/libgcr.so.0 /usr/lib64/libgp11.so.0
Summary: app-emulation/vmware-player-6.0.0.1295980 with gnome-base/gnome-keyring-3.8.2...
Status: RESOLVED OBSOLETE
Alias: vmware-preserved
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
: 480674 485948 503182 515586 519992 522324 534252 (view as bug list)
Depends on: 565792
Blocks:
  Show dependency tree
 
Reported: 2013-12-01 10:44 UTC by Alexander Weber
Modified: 2017-11-30 11:20 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Weber 2013-12-01 10:44:14 UTC
After updating gnome-keyring to 3.8.2 preserved libs exists for vmware-player-6.0.0.1295980

!!! existing preserved libs:
>>> package: gnome-base/gnome-keyring-3.8.2
 *  - /usr/lib64/libgcr.so.0
 *  - /usr/lib64/libgcr.so.0.0.0
 *      used by /opt/vmware/lib/vmware/lib/libvmplayer.so/libvmplayer.so (app-emulation/vmware-player-6.0.0.1295980)
 *      used by /opt/vmware/lib/vmware/lib/libvmware-enter-serial.so/libvmware-enter-serial.so (app-emulation/vmware-player-6.0.0.1295980)
 *      used by /opt/vmware/lib/vmware/lib/libvmware-fuseUI.so/libvmware-fuseUI.so (app-emulation/vmware-player-6.0.0.1295980)
 *      used by 4 other files
 *  - /usr/lib64/libgp11.so.0
 *  - /usr/lib64/libgp11.so.0.0.0


Re-emerging of vmware-player does not fix the issue because of closed-source. 

# emerge --info 

Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8200_@_2.33GHz-with-gentoo-2.2
KiB Mem:     4055048 total,   1512104 free
KiB Swap:    2618588 total,   2070944 free
Timestamp of tree: Sat, 30 Nov 2013 21:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo crossdev gamerlay games proaudio rion roslin pcsx2 spring myoverlay local_nslu2
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/crossdev-overlay /mnt/overlays/gamerlay /mnt/overlays/games /mnt/overlays/pro-audio /mnt/overlays/rion /mnt/overlays/roslin /mnt/overlays/pcsx2 /mnt/overlays/Spring /usr/local/myoverlay /usr/local/nslu2-overlay"
USE="X a52 aac aalib acl acpi alsa amd64 apic arch_perfmon bash-completion berkdb bluetooth bluray bogofilter branding bts bzip2 cairo caps cdda cddax cddb cdio cdr cdrom cleartype clflush cli cmov consolekit constant_tsc cracklib crypt cups cx16 cx8 cxx dbus de device-mapper djvu dri ds_cpl dssi dts dvd dvdr emboss encode est exif fam ffmpeg firefox flac fluidsynth fortran fpu fxsr g3dvl gdbm gif gnutls gphoto2 gstreamer gtk gtkstyle hddtemp ht iconv jack jackmidi java joystick jpeg ladspa lahf_lm lame lcms ldap libnotify lm lm_sensors mad mca mce midi mmx mng modules monitor mp3 mp4 mpeg msr mtrr mudflap multilib ncurses nls nptl nsplugin nvidia nx ogg opencl opengl openmp pae pam pango pat pbe pcre pdf pebs pge png pni policykit ppds pse pse36 qt3support quicktime readline rep_good samba scanner sdl sep session smp spell sqlite ss sse sse2 sse3 sse4_1 ssl ssse3 startup-notification stk svg syscall taglib tcpd threads tiff tm tm2 truetype tsc udev udisks unicode upower usb vaapi vdpau videos vme vmware_guest_freebsd vmware_guest_linux vmware_guest_netware vmware_guest_solaris vmware_guest_winPre2k vmware_guest_windows vorbis vst wxwidgets x264 xcb xcomposite xml xtpr xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2 canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="*" LINGUAS="de en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="*" QEMU_USER_TARGETS="*" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Frank Krömmelbein 2013-12-01 21:33:28 UTC
I run into the same problem with vmware-workstation.
I could solve the problem by 
emerge -C vmware-workstation && emerge vmware-workstation 

Probably the same work around for vmware-player...
Comment 2 Alexander Weber 2013-12-01 21:45:35 UTC
Yes, uninstalling removed the preserved files and emerge again does not have the issue. The Issue is solved for me. To the gentoo dev's, it is possible to hide the preserved files for the build process during re-emerge?
Comment 3 Andreas K. Hüttel gentoo-dev 2013-12-02 16:24:54 UTC
(In reply to Alexander Weber from comment #2)
> Yes, uninstalling removed the preserved files and emerge again does not have
> the issue. The Issue is solved for me. To the gentoo dev's, it is possible
> to hide the preserved files for the build process during re-emerge?

Well, does it still run then? because re-emerging vmware-workstation won't magically change its prebuilt binaries... :)

In particular, what happens e.g. if you want to enter a license number? ("libvmware-enter-serial.so")
Comment 4 Alexander Weber 2013-12-02 16:36:55 UTC
It works fine. 

Seems vmware uses the provided /opt/vmware/lib/vmware/lib/libgcr.so.0/libgcr.so.0
Comment 5 Andreas K. Hüttel gentoo-dev 2013-12-02 17:19:36 UTC
(In reply to Alexander Weber from comment #4)
> It works fine. 
> 
> Seems vmware uses the provided
> /opt/vmware/lib/vmware/lib/libgcr.so.0/libgcr.so.0

Hmm yeah. This looks more like a quirk in @preserved-rebuild handling. VMware provides its own library, but portage tries to preserve the global one.
Comment 6 Sebastian Luther (few) 2013-12-02 18:01:49 UTC

*** This bug has been marked as a duplicate of bug 215242 ***
Comment 7 Martin von Gagern 2013-12-23 20:55:19 UTC
In bug #265372 comment #10, it was decided that a similar bug for googleearth was not a duplicate of bug #215242, since the issue can be addressed at the package level. More precisely, patchelf can be used to set the rpath of the involved ELF files such that ldd and portage know that these link against their own libs in preference to system libs. Maybe the same approach would work here, too.
Comment 8 Sebastian Luther (few) 2013-12-23 21:09:59 UTC
(In reply to Martin von Gagern from comment #7)
> In bug #265372 comment #10, it was decided that a similar bug for
> googleearth was not a duplicate of bug #215242, since the issue can be
> addressed at the package level. More precisely, patchelf can be used to set
> the rpath of the involved ELF files such that ldd and portage know that
> these link against their own libs in preference to system libs. Maybe the
> same approach would work here, too.

Thank you for the reminder.
Comment 9 Andreas K. Hüttel gentoo-dev 2014-04-12 18:15:38 UTC
*** Bug 485948 has been marked as a duplicate of this bug. ***
Comment 10 Andreas K. Hüttel gentoo-dev 2014-04-12 18:16:43 UTC
*** Bug 480674 has been marked as a duplicate of this bug. ***
Comment 11 Andreas K. Hüttel gentoo-dev 2014-04-12 19:32:36 UTC
*** Bug 503182 has been marked as a duplicate of this bug. ***
Comment 12 Andreas K. Hüttel gentoo-dev 2015-09-18 23:42:18 UTC
*** Bug 522324 has been marked as a duplicate of this bug. ***
Comment 13 Andreas K. Hüttel gentoo-dev 2015-09-18 23:42:41 UTC
*** Bug 519992 has been marked as a duplicate of this bug. ***
Comment 14 Andreas K. Hüttel gentoo-dev 2015-09-18 23:47:42 UTC
*** Bug 515586 has been marked as a duplicate of this bug. ***
Comment 15 Andreas K. Hüttel gentoo-dev 2015-09-18 23:47:58 UTC
*** Bug 534252 has been marked as a duplicate of this bug. ***
Comment 16 Andreas K. Hüttel gentoo-dev 2015-09-27 21:47:04 UTC
Just as a general heads up, this bug will resolve itself automatically once the handling of bug 508070 is complete... Work in progress.
Comment 17 Manfred Knick 2017-07-07 22:19:14 UTC
Current [Overlay] includes:

           vmware-player-7.1.4.3848939.ebuild   ! not supported any more !

and        vmware-player-12.5.7.5813279.ebuild

but no
           vmware-player-6.*.*.*******.ebuild   ! not supported any more !
any more.

To me, this Bug looks OBSOLETE.
Comment 18 Manfred Knick 2017-11-30 11:20:39 UTC
VMware Products have been removed from Main Portage Tree during Nov-2017.

Further development has been relegated to [vmware] Overlay.

Situation as of today, 30-Nov-2017:
Workstation : stable in [vmware] = 12.5.8  / released = 14.0.0  : Bug 634770
Player      : stable in [vmware] = 12.5.8  / released = 14.0.0  : Bug 639162
Modules     : stable in [vmware] = 308.5.8 / released = 329.0.0 : Bug 634862
Tools       : stable in [vmware] = 10.1.6  / released = 10.1.15 : Bug 634854