Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 492594 - media-gfx/hugin-2013.0-r1 with dev-libs/boost-1.54.0 - ../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::named_slot_map::end()'
Summary: media-gfx/hugin-2013.0-r1 with dev-libs/boost-1.54.0 - ../hugin_base/libhugin...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 503450 (view as bug list)
Depends on:
Blocks: boost-1.54 528330
  Show dependency tree
 
Reported: 2013-11-26 09:38 UTC by David Kredba
Modified: 2014-12-22 10:05 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,11.58 KB, application/gzip)
2013-11-26 09:44 UTC, David Kredba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kredba 2013-11-26 09:38:47 UTC
cd /var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/celeste
srv5 celeste # /usr/bin/x86_64-pc-linux-gnu-g++   -O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin     -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin CMakeFiles/celeste_standalone.dir/Main.cpp.o  -o celeste_standalone -rdynamic libceleste.so.0.0 ../foreign/vigra/vigra_impex/libhuginvigraimpex.so.0.0 -lImath -lIlmImf -lIex -lHalf -lIlmThread -ljpeg -ltiff -lpng -lz -lz -lexiv2 ../hugin_base/libhuginbase.so.0.0 -lboost_thread-mt -lboost_date_time-mt -lboost_regex-mt -lboost_filesystem-mt -lboost_iostreams-mt -lboost_system-mt -lpano13 -llapack /usr/lib64/blas/reference/libblas.so -lGLEW ../foreign/levmar/libhuginlevmar.a ../foreign/vigra/vigra_impex/libhuginvigraimpex.so.0.0 -lpthread -lImath -lIlmImf -lIex -lHalf -lIlmThread -ljpeg -lpng -lz ../hugin_base/makefilelib/libmakefilelib.so.0.0 -lpthread -lGLU -lGL -lSM -lICE -lX11 -lXext -lglut -lXmu -lXi -lpthread -lGLU -lGL -lSM -lICE -lX11 -lXext -lglut -lXmu -lXi -ltiff -lexiv2 -llensfun -lboost_thread-mt -lboost_date_time-mt -lboost_regex-mt -lboost_filesystem-mt -lboost_iostreams-mt -lboost_system-mt -lpano13 -llapack /usr/lib64/blas/reference/libblas.so -lGLEW -Wl,-rpath,/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/celeste:/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/foreign/vigra/vigra_impex:/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/hugin_base:/usr/lib64/blas/reference:/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/hugin_base/makefilelib
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::named_slot_map::end()'
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::signal_base::~signal_base()'
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::signal_base::signal_base(boost::function2<bool, boost::signals::detail::stored_group, boost::signals::detail::stored_group> const&, boost::any const&)'
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::call_notification::~call_notification()'
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::call_notification::call_notification(boost::shared_ptr<boost::signals::detail::signal_base_impl> const&)'
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::detail::named_slot_map::begin()'
../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::signals::trackable::~trackable()'
collect2: error: ld returned 1 exit status


After added missing library:

 /usr/bin/x86_64-pc-linux-gnu-g++   -O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin     -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin CMakeFiles/celeste_standalone.dir/Main.cpp.o  -o celeste_standalone -rdynamic libceleste.so.0.0 ../foreign/vigra/vigra_impex/libhuginvigraimpex.so.0.0 -lImath -lIlmImf -lIex -lHalf -lIlmThread -ljpeg -ltiff -lpng -lz -lz -lexiv2 ../hugin_base/libhuginbase.so.0.0 -lboost_thread-mt -lboost_date_time-mt -lboost_regex-mt -lboost_filesystem-mt -lboost_iostreams-mt -lboost_system-mt -lpano13 -llapack /usr/lib64/blas/reference/libblas.so -lGLEW ../foreign/levmar/libhuginlevmar.a ../foreign/vigra/vigra_impex/libhuginvigraimpex.so.0.0 -lpthread -lImath -lIlmImf -lIex -lHalf -lIlmThread -ljpeg -lpng -lz ../hugin_base/makefilelib/libmakefilelib.so.0.0 -lpthread -lGLU -lGL -lSM -lICE -lX11 -lXext -lglut -lXmu -lXi -lpthread -lGLU -lGL -lSM -lICE -lX11 -lXext -lglut -lXmu -lXi -ltiff -lexiv2 -llensfun -lboost_thread-mt -lboost_date_time-mt -lboost_regex-mt -lboost_signals-mt -lboost_filesystem-mt -lboost_iostreams-mt -lboost_system-mt -lpano13 -llapack /usr/lib64/blas/reference/libblas.so -lGLEW -Wl,-rpath,/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/celeste:/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/foreign/vigra/vigra_impex:/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/hugin_base:/usr/lib64/blas/reference:/var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/hugin_base/makefilelib

Reproducible: Always

Steps to Reproduce:
1.Be ~amd64 and use boost-1.54
2.
3.



Dtto in /var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/hugin-2013.0.0_build/src/tools subdirs.

Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.17, 3.12.1-gentoo x86_64)
=================================================================
System uname: Linux-3.12.1-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.2
KiB Mem:     8170364 total,   3430620 free
KiB Swap:    8396796 total,   8396796 free
Timestamp of tree: Tue, 26 Nov 2013 08:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r4, 3.2.5-r3, 3.3.3
dev-util/cmake:           2.8.12.1-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin"
GENTOO_MIRRORS="ftp://gentoo.mirror.web4u.cz/"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -O2 -pipe -march=native -mtune=native -flto=4 -fuse-linker-plugin"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="echo"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="X a52 aac acl acpi alsa amd64 berkdb blas bluetooth branding bzip2 cairo caps cdda cddb cdparanoia cdr cli consolekit cracklib crypt cups cvs cxx dbus declarative djvu dri dts dv dvb dvd dvdr emboss encode exif fam ffmpeg fftw firefox flac fontconfig fortran ftp gd gdbm geoip gif gmp gnuplot gpm gps graphviz gsl gsm gstreamer gtk hdf5 iconv icu idn ieee1394 imagemagick imlib ipv6 ithreads javascript jbig jpeg jpeg2k kde kipi ladspa lame lapack lcms ldap libass libnotify libsamplerate lzma lzo mad matroska mms mmx mmxext mng modplug modules mp3 mp4 mpeg mplayer msn mtp mudflap multilib musepack musicbrainz ncurses netcdf nls nptl ocaml ocamlopt odbc ogg openal openexr opengl openmp pam pango pch pcre pdf perl phonon plasma plotutils png policykit postscript ppds pulseaudio python qt3support qt4 quicktime rdesktop readline ruby samba scanner sdl semantic-desktop session slang smp sndfile sox speex spell sse sse2 ssl ssse3 startup-notification svg szip tcpd theora threads tidy tiff truetype udev udisks unicode upower usb v4l vcd vdpau vnc vorbis wavpack wmf wxwidgets x264 xattr xcb xcomposite xft xine xinerama xml xosd xpm xscreensaver xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2 canon hp215 sony_dscf1 sony_dscf55" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher ffhash" GPSD_PROTOCOLS="aivdm ashtech earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 navcom nmea ntrip oceanserver oncore rtcm104v2 rtcm104v3 sirf superstar2 tnt tripmate tsip ubx fury geostar nmea2000" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer scripting-beanshell scripting-javascript nlpsolver" LINGUAS="cs en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3" QEMU_SOFTMMU_TARGETS="x86_64 arm i386" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
Comment 1 David Kredba 2013-11-26 09:44:21 UTC
Created attachment 364006 [details]
build.log.gz
Comment 2 David Kredba 2013-12-15 10:27:34 UTC
I think that I found it.

After CMakeLists.txt in /var/tmp/portage/media-gfx/hugin-2013.0.0-r1/work/ patched there is:

FIND_PACKAGE(Boost 1.54 COMPONENTS thread date_time regex filesystem iostreams system)
IF(NOT Boost_FOUND)
  FIND_PACKAGE(Boost 1.44 COMPONENTS thread date_time regex filesystem iostreams system signals)

"signals" a the end of 1.54 line is missing.

It should look like

FIND_PACKAGE(Boost 1.54 COMPONENTS thread date_time regex filesystem iostreams system signals)
Comment 3 Dennis Schridde 2014-01-21 15:13:02 UTC
I think this is fixed in 2014.0.0_beta1.
Comment 4 David Kredba 2014-01-23 10:07:56 UTC
(In reply to Dennis Schridde from comment #3)
> I think this is fixed in 2014.0.0_beta1.

Yes, beta works even with Boost 1.55.
Comment 5 Jeroen Roovers gentoo-dev 2014-03-04 21:39:36 UTC
*** Bug 503450 has been marked as a duplicate of this bug. ***
Comment 6 Markus Meier gentoo-dev 2014-03-05 21:17:14 UTC
removed media-gfx/hugin-2014.0.0_rc1 mask to fix tree for ~arch users...

+  05 Mar 2014; Markus Meier <maekke@gentoo.org> package.mask:
+  remove hugin-2014 mask regarding dev-libs/boost-1.55 unmasking, bug #492594
+
Comment 7 Jaak Ristioja 2014-09-26 19:19:45 UTC
Wow, this bug is old :P

So... when will this be fixed in stable?
Comment 8 wyvern5 2014-11-13 05:11:04 UTC
I'm hitting this issue too.
Comment 9 Paul Osmialowski 2014-11-13 10:04:24 UTC
quick and dirty workaround:

LIBS=-lboost_signals LDFLAGS=-lboost_signals emerge hugin
Comment 10 Richard Freeman gentoo-dev 2014-11-13 14:03:36 UTC
FYI - lots of users are going to start hitting this in stable due to the boost-1.55 stabilization.  It would make sense to fix the build issue or stabilize the newer version.  The stable version is effectively broken, unless you apply a workaround.
Comment 11 Pierre AUSSAGUEL 2014-11-15 14:50:52 UTC
I am also concerned by this bug.
Comment 12 Triton Circonflexe 2014-11-18 20:59:05 UTC
CONFIRMED
Updating boost to 1.55 made me hit the problem.
Comment 13 Peter Albrecht 2014-11-22 19:36:00 UTC
I can confirm this, too. Doing an "emerge -vauND world" today, made me crash into this problem.

Very much thanks to Paul Osmialowski! His comment 9 made me rebuild hugin again.
Comment 14 Alexander Puchmayr 2014-12-14 10:48:50 UTC
Same here. Paul's comment 9 solved it.
Comment 15 Sergey Popov gentoo-dev 2014-12-22 10:05:56 UTC
+  22 Dec 2014; Sergey Popov <pinkbyte@gentoo.org> hugin-2012.0.0.ebuild,
+  hugin-2013.0.0-r1.ebuild:
+  Restrict versions of dev-libs/boost dependency, wrt bug #492594, thanks to
+  David Kredba <nheghathivhistha AT gmail.com> for discovering this issue