Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 491710 - xkeyboard-config needs to depend on dev-perl/XML-Parser
Summary: xkeyboard-config needs to depend on dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-19 20:36 UTC by Nolan Eakins
Modified: 2013-11-19 21:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nolan Eakins 2013-11-19 20:36:32 UTC
xkeyboard-config failed to emerge on its libxml test for intltool. Per http://forums.gentoo.org/viewtopic-t-617786-start-0.html I emerged dev-perl/XML-Parser and xkeyboard-config emerged. XML-Parser needs to be added as a dependency.

Reproducible: Always

Steps to Reproduce:
1. emerge --unmerge dev-perl/XML-Parser
2. emerge xkeyboard-config

Actual Results:  
Emerge fails as xkeyboard-config's configure fails to detect Perl's libxml.

Expected Results:  
Emerge succeeds.
Comment 1 Jeroen Roovers gentoo-dev 2013-11-19 21:53:33 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 2 Jeroen Roovers gentoo-dev 2013-11-19 21:54:40 UTC
For good measure, it already DEPENDs on intltool, which depends on both perl and XML-Parser... The error you saw was because you didn't run perl-cleaner.