Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 490788 - =sci-geosciences/osm2pgsql-20100413 fails to compile due to "i686-pc-linux-gnu-gcc: error: directory": No such file or directory"
Summary: =sci-geosciences/osm2pgsql-20100413 fails to compile due to "i686-pc-linux-gn...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-08 21:36 UTC by John Lips
Modified: 2014-01-29 00:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,10.93 KB, application/octet-stream)
2013-11-10 20:47 UTC, John Lips
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Lips 2013-11-08 21:36:56 UTC
This happened after upgrading gcc to version 4.7.3-r1 and while trying to reinstall osm2pgsql-20100413 

I think the problem stems from the argument of -DVERSION shown below which has a space in it (even though it is quoted). However, this is just a guess. 

i686-pc-linux-gnu-gcc -O2 -march=i686 -pipe -g -O2 -Wall -Wextra -I/usr/include/libxml2 -I/usr/include -I/usr/include/postgresql-9.1 -DVERSION=\"0.69-Unversioned directory\" -DHAVE_PTHREAD -DDATADIR=\"/usr/share/osm2pgsql\" -c -o sprompt.o sprompt.c 

I reported this same info in the gentoo forums:
https://forums.gentoo.org/viewtopic-p-7433342.html#7433342

I was told there that this a result of a bug in the build system.

Unfortunately I cannot provide the output of emerge --info as I am not at that system right now and that system is not connected to the internet.  I will try to get it and append to this report next week.
Comment 1 Jeroen Roovers gentoo-dev 2013-11-09 17:01:05 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log for the failing ebuild to this bug report.
Comment 2 John Lips 2013-11-10 20:45:14 UTC
Portage 2.1.12.2 (default/linux/x86/13.0, gcc-4.6.3, glibc-2.15-r3, 3.10.7-gentoo-r1 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.10.7-gentoo-r1-i686-Intel-R-_Atom-TM-_CPU_N570_@_1.66GHz-with-gentoo-2.2
KiB Mem:     1022888 total,    102112 free
KiB Swap:    1464316 total,   1464316 free
Timestamp of tree: Mon, 28 Oct 2013 20:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo my_local_overlay
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 acl acpi alsa berkdb bzip2 cli cracklib crypt cxx dbus dri extras fortran gdbm iconv icu ipv6 jpeg libnotify mmx modules mudflap ncurses nls nptl openmp pam pcre png python readline session sse sse2 ssl tcpd tiff udev unicode x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sci-geosciences/osm2pgsql-20100413 was built with the following:
USE=""
Comment 3 John Lips 2013-11-10 20:47:18 UTC
Created attachment 363026 [details]
build log
Comment 4 John Lips 2013-11-10 20:48:59 UTC
This does not appear to be related to the upgrade of gcc since this is happening on all of my systems x86 and x86_64.
Comment 5 Jeremy Stent 2014-01-19 01:45:06 UTC
This seems similar to bug 397877 - https://bugs.gentoo.org/show_bug.cgi?id=397877 .  Editing the makefile to change the "CFLAGS += -DVERSION" line gets me past this error.
I still need the same patch as well.
Comment 6 Aaron W. Swenson gentoo-dev 2014-01-29 00:11:41 UTC
*osm2pgsql-0.84.0 (29 Jan 2014)

  29 Jan 2014; Aaron W. Swenson <titanofold@gentoo.org>
  +osm2pgsql-0.84.0.ebuild, osm2pgsql-99999999.ebuild, metadata.xml:
  Fix bug 421325: Fixed by version bump
  Fix bug 427668: Thanks Christoph Brill
  Fix bug 469374: Added lua USE flag
  Fix bug 397877: Fixed by version bump
  Fix bug 490788: Fixed by version bump

Please give 0.84.0 a go. I'll remove the old version in a couple days.