Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489662 - @live-rebuild set should include git-r3.eclass users
Summary: @live-rebuild set should include git-r3.eclass users
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2013-10-28 16:03 UTC by darkbasic
Modified: 2014-01-06 00:40 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darkbasic 2013-10-28 16:03:50 UTC
When you emerge @live-rebuild llvm is not among the packages.

Reproducible: Always
Comment 1 Ben Kohler gentoo-dev 2013-10-28 16:30:35 UTC
I believe portage will need to be patched to include git-r3 in the live-rebuild set:

/usr/share/portage/config/sets/portage.conf:

[live-rebuild]
class = portage.sets.dbapi.VariableSet
variable = INHERITED
includes = bzr cvs darcs git git-2 mercurial subversion tla
Comment 2 Rick Farina (Zero_Chaos) gentoo-dev 2013-10-28 17:58:24 UTC
it is important to note, smart-live-rebuild is vastly more useful than the built in @live-rebuild
Comment 3 darkbasic 2013-10-28 21:50:29 UTC
Didn't know about it, thanks!
Comment 4 darkbasic 2013-11-01 22:15:09 UTC
It seems smart-live-rebuild isn't smart enough for llvm, maybe because it pulls from multiples repos.
Comment 5 Rick Farina (Zero_Chaos) gentoo-dev 2013-11-02 01:34:03 UTC
(In reply to darkbasic from comment #4)
> It seems smart-live-rebuild isn't smart enough for llvm, maybe because it
> pulls from multiples repos.

When I wrote my first ebuild that pulled from multiple git repos it became painfully obvious that the eclasses were not designed for that.  Nothing has changed since then.
Comment 7 Brian Dolbec gentoo-dev 2014-01-06 00:40:36 UTC
Released in sys-apps/portage-2.2.8.