Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 489552 - media-libs/libmimic and media-plugins/gst-plugins-mimic removal request
Summary: media-libs/libmimic and media-plugins/gst-plugins-mimic removal request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard: Pending removal: 2016-02-05
Keywords: PMASKED
: 540798 (view as bug list)
Depends on: gnome-3.14-stable
Blocks:
  Show dependency tree
 
Reported: 2013-10-27 10:03 UTC by Pacho Ramos
Modified: 2016-02-20 17:40 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2013-10-27 10:03:03 UTC
That was the custom microsoft codec for the webcam protocol in the old MSN
protocol (there is also a gst-plugins-mimic that should die with it).
Comment 1 Pacho Ramos gentoo-dev 2013-10-27 10:05:01 UTC
This will need gst-plugins-libmimic to die and msn USE flags from farstream and farsight2 too -> reassigning to gstreamer team to confirm as looks like gst plugin is still active
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-10-27 13:00:41 UTC
The plugin is updated but there is no special reason to keep it afaik.
Comment 3 Mart Raudsepp gentoo-dev 2013-12-21 16:25:14 UTC
Isn't it (MSN) still available in mainland China? I don't know though; I was wondering the same thing if there's a point or not..
Comment 4 Dion Moult (RETIRED) gentoo-dev 2014-01-19 02:25:23 UTC
MSN actually seems to be still running according to some bitlbee developers who still connect to it.
Comment 5 Pacho Ramos gentoo-dev 2014-01-19 07:48:09 UTC
What app in the tree is still using this concrete support? (I mean, maybe people in other countries is still using MSN but I don't know what apps in the tree are still working for that in the tree and are using this)
Comment 6 Mart Raudsepp gentoo-dev 2014-02-14 04:33:57 UTC
any telepathy-butterfly+farsight2 using app probably could?
Comment 7 Pacho Ramos gentoo-dev 2014-02-14 06:04:00 UTC
But I don't see such app grepping in the tree (or, at least, if that apps is present, if doesn't has correct dependencies indicating this harddependency)
Comment 8 Pacho Ramos gentoo-dev 2014-08-31 12:05:24 UTC
Also, looks like it will be completely dropped in October (also for China):
http://www.independent.co.uk/life-style/gadgets-and-tech/news/msn-messenger-to-shut-down-after-15-years-of-service-9700852.html
Comment 9 Mart Raudsepp gentoo-dev 2014-09-24 23:45:27 UTC
Yes, lets last rite this now with a removal date of 1 Nov 2014
Comment 10 Mart Raudsepp gentoo-dev 2014-09-24 23:46:27 UTC
Note that net-libs/farstream has a USE=msn that pulls this in. We should look for other such cases too, and in general IUSE=msn usages across the tree by 31st Oct
Comment 11 Pacho Ramos gentoo-dev 2015-02-20 14:38:30 UTC
*** Bug 540798 has been marked as a duplicate of this bug. ***
Comment 12 Pacho Ramos gentoo-dev 2016-02-20 17:40:09 UTC
removed