Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 488156 - sys-apps/portage-2.2.7 Please stabilize
Summary: sys-apps/portage-2.2.7 Please stabilize
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2013-10-16 02:13 UTC by Brian Dolbec
Modified: 2013-12-23 16:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Dolbec gentoo-dev 2013-10-16 02:13:34 UTC
Current stage3's are broken due to bugs in current stable portage that prevent portage from downloading and installing the gentoo (portage) tree.

This is a bit early for the normal 30 day stabilization process.  Current open bugs tagged portage-2.2.7 appear to be ongoing bugs in several versions, nothing to stop stabilization.  Current release media and stage3's need this release.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2013-10-16 13:17:10 UTC
Stable for HPPA.
Comment 2 Elijah "Armageddon" El Lazkani (amd64 AT) 2013-10-18 03:21:51 UTC
I've been using it since it came out, no problems here.


NOTE: "sys-apps/portage/portage-2.2.7.ebuild: Unquoted Variable on line: 494"

Please fix this before stabilization.
Comment 3 Tony Vroon gentoo-dev 2013-10-20 22:57:20 UTC
(In reply to Elijah "Armageddon" El Lazkani (amd64 AT) from comment #2)
> NOTE: "sys-apps/portage/portage-2.2.7.ebuild: Unquoted Variable on line: 494"
> Please fix this before stabilization.

Other arches have already stabilised, and it would not be fair on them to move the goal posts. I will live with the warning.
Comment 4 Tony Vroon gentoo-dev 2013-10-20 22:59:05 UTC
+  20 Oct 2013; Tony Vroon <chainsaw@gentoo.org> portage-2.2.7.ebuild:
+  Marked stable on AMD64 based on arch testing by Elijah "Armageddon" El
+  Lazkani in bug #488156.

(The use of a tree-wide deprecated EAPI bothered me more than the unquoted variable ever could...)
Comment 5 Markus Meier gentoo-dev 2013-10-23 17:15:20 UTC
arm stable
Comment 6 Greg Kubaryk 2013-11-01 00:48:17 UTC
portage-2.2.7 works for me on both amd64 and x86, for whatever that's worth.  We're still getting a bunch of people in IRC #gentoo running into bug #484730 -- current release media and stage3 are still broken.  Additionally, we are now beyond the usual 30 day stabilization process.

My apologies if it was inappropriate to comment here.
Comment 7 Matt Turner gentoo-dev 2013-11-03 23:57:51 UTC
alpha stable.
Comment 8 Jeff (JD) Horelick (RETIRED) gentoo-dev 2013-11-30 03:45:52 UTC
x86 stable
Comment 9 Agostino Sarubbo gentoo-dev 2013-12-21 16:28:09 UTC
ppc stable
Comment 10 Agostino Sarubbo gentoo-dev 2013-12-22 12:06:26 UTC
ppc64 stable
Comment 11 SpanKY gentoo-dev 2013-12-23 09:26:38 UTC
ia64 stable
Comment 12 Agostino Sarubbo gentoo-dev 2013-12-23 16:24:42 UTC
sparc stable. Closing.