Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 488136 - app-arch/tar-1.27 checking for working re_compile_pattern... takes forever
Summary: app-arch/tar-1.27 checking for working re_compile_pattern... takes forever
Status: RESOLVED DUPLICATE of bug 487700
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2013-10-15 17:11 UTC by Randy Andy
Modified: 2013-10-16 06:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Randy Andy 2013-10-15 17:11:18 UTC
When lost of checks come to this one it stops and take forever:
checking for working re_compile_pattern... 

For it's similar to this bug I'm also affected by:

More output of the tar ebuild here:

>>> Emerging (1 of 8) app-arch/tar-1.27                                                                                              
 * tar-1.27.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                      [ ok ] 
>>> Unpacking source...                                                                                                              
>>> Unpacking tar-1.27.tar.bz2 to /var/tmp/portage/app-arch/tar-1.27/work                                                            
>>> Source unpacked in /var/tmp/portage/app-arch/tar-1.27/work                                                                       
>>> Preparing source in /var/tmp/portage/app-arch/tar-1.27/work/tar-1.27 ...                                                         
>>> Source prepared.                                                                                                                 
>>> Configuring source in /var/tmp/portage/app-arch/tar-1.27/work/tar-1.27 ...                                                       
 * econf: updating tar-1.27/build-aux/config.guess with /usr/share/gnuconfig/config.guess                                            
 * econf: updating tar-1.27/build-aux/config.sub with /usr/share/gnuconfig/config.sub                                                
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --enable-backup-scripts --bindir=/bin --libexecdir=/usr/sbin --enable-nls --with-xattrs                                                                                                 
configure: loading site script /usr/share/                                                                                
checking for a BSD-compatible install... /usr/lib64/portage/bin/ebuild-helpers/xattr/install -c                                      
checking whether build environment is sane... yes                                                                                    
checking for a thread-safe mkdir -p... /bin/mkdir -p                                                                                 
checking for gawk... gawk                                                                                                            
checking whether make sets $(MAKE)... yes                                                                                            
checking whether make supports nested variables... yes                                                                               
checking how to create a ustar tar archive... gnutar                                                                                 
checking whether make supports nested variables... (cached) yes                                                                      
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc                                                                      
checking whether the C compiler works... yes                                                                                         
checking for C compiler default output file name... a.out                                                                            
checking for suffix of executables...                                                                                                
checking whether we are cross compiling... no                                                                                        
checking for suffix of object files... o                                                                                             
checking whether we are using the GNU C compiler... yes                                                                              
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes                                                                           
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed                                                         
checking for style of include used by make... GNU                                                                                    
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3                                                                         
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib                                                                
checking for bison... bison -y                                                                                                       
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E                                                                 
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for Minix Amsterdam compiler... no
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking whether x86_64-pc-linux-gnu-gcc and cc understand -c and -o together... yes
checking for ANSI C header files... yes
lots of additional lines I cut here and insert the last few instead, cause attaching lines limitation :-(
hecking whether mbsrtowcs works... guessing yes
checking for mempcpy... (cached) yes
checking for memrchr... yes
checking whether mkdir handles trailing slash... yes
checking whether mkdir handles trailing dot... yes
checking for mkdtemp... yes
checking whether mkfifo rejects trailing slashes... yes
checking whether mknod can create fifo without root privileges... yes
checking for working mktime... yes
checking whether YESEXPR works... yes
checking for obstacks... yes
checking whether open recognizes a trailing slash... yes
checking for opendir... yes
checking for struct tm.tm_zone... yes
checking for getppriv... no
checking whether program_invocation_name is declared... (cached) yes
checking whether program_invocation_short_name is declared... (cached) yes
checking for sys/acl.h... (cached) yes
checking for library containing acl_get_file... (cached) -lacl
checking for acl_get_file... yes
checking for acl_get_fd... yes
checking for acl_set_file... yes
checking for acl_set_fd... yes
checking for acl_free... yes
checking for acl_from_mode... yes
checking for acl_from_text... yes
checking for acl_delete_def_file... yes
checking for acl_extended_file... yes
checking for acl_delete_fd_np... no
checking for acl_delete_file_np... no
checking for acl_copy_ext_native... no
checking for acl_create_entry_np... no
checking for acl_to_short_text... no
checking for acl_free_text... no
checking for working acl_get_file... yes
checking acl/libacl.h usability... yes
checking acl/libacl.h presence... yes
checking for acl/libacl.h... yes
checking for acl_entries... yes
checking for ACL_FIRST_ENTRY... yes
checking for ACL_TYPE_EXTENDED... no
checking for raise... yes
checking for rawmemchr... yes
checking for readdir... yes
checking whether readlink signature is correct... yes
checking whether readlink handles trailing slash correctly... yes
checking for working re_compile_pattern...
Comment 1 Randy Andy 2013-10-15 17:11:48 UTC
emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.1, glibc-2.17, 3.10.12-gentoo x86_64)
System uname: Linux-3.10.12-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.2
KiB Mem:     8169360 total,    387708 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 15 Oct 2013 15:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.2
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.3-r1, 4.8.1-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=core2 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -mno-sse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase -mtune=core2 -mmmx -msse -msse2 -msse3 -mssse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -mno-sse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase -mtune=core2 -mmmx -msse -msse2 -msse3 -mssse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer"
EMERGE_DEFAULT_OPTS="--quiet-build=n --keep-going --autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aacs aalib accessibility acpi additions addressbook aften alsa amd64 amr animgif apm apng archive aspell audiofile autoipd autotrace avahi bash-completion berkdb binary-drivers binfilter bluetooth bluray branding bzip2 c++0x cairo canvas caps ccache cdda cddb cdio cdparanoia cdr cdrdao cdrom cgi chipcard chroot cjk clamav cli clucene compressed-lumas consolekit corefonts cover cracklib crypt css cups custom-cpuopts cvs cvsgraph cxx daemon dar64 dbus dc1394 declarative dhcpcd dia dirac disk-partition djbfft djvu dri dts dv dvd dvdnav dvdr dvi dynamic editor emboss emovix enca encode enscript excel exif extensions extrafilters extras fam fame fat ffmpeg fftw finger firefox firefox3 flac flash flv fmod fontconfig foomaticdb fortran fortran2003 fpx frei0r fuse g3dvl gallium gcj gd gdbm geolocation gif gimp glew glib glut gnokii gpac gphoto2 gpm graphviz gsl gstreamer gtk gtk3 gzip hddtemp hdri howl-compat html http httpd iconv icq id3 id3tag ieee1394 image imagemagick imap imlib inkjar inotify introspection ios iostats ipc iptv ipv6 irc ivtv jabber java java6 javacomm javascript jbig jce jingle joystick jpeg jpeg2k juju kde kdepim kdm kexiv2 kig-scripting kino kipi kmail kontact ladspa lame lcdfilter lcms ldap lensfun libcaca libnotify librrd libsamplerate libv4l libv4l2 libvisual lightning live llvm lm_sensors logrotate logwatch loop-aes lua lzma lzo mad marble math matroska max-idx-128 mdnsresponder-compat melt metric midi mikmod mime mjpeg mmx mng modplug modules mono mouse mozdevelop mozilla mp3 mp3rtp mp4 mpd mpeg mpg123 mpi mpi-threads mplayer mpu401 mtp mudflap muine multilib multimedia multiprocess musepack music musicbrainz mysql mysqli nano-syntax nas ncurses network network-cron networkmanager nfs nfsdcld nfsidmap nfsv4 nfsv41 nls nntp normalize nptl nsplugin nss ntfs nut nuv obex ocean odk ofa ogg ogg123 ogm okular openctl openexr opengl openmedia openmp openssl opensslcrypt oss pam pango pch pcm pcre pda pdf pdfimport perforce perl pg-intdatetime phonon php physfs pipe plasma player plotutils pmount pmu png pnm podcast policykit pop postgis postproc ppds prison private-headers profile profiler proj ps pstoedit pvr python python3 q32 qalculate qos qt3support qt4 quesoglc quicktime quodlibet radio rar raw readline redeyes rle romio rsh rss rtc rtmp rtsp ruby scale0tilt scanner schedule schroedinger sdl sdl-image sdl-sound sdlaudio search secure-delete semantic-desktop sensord session sftp shaders shine shorten shout sift skins slideshow smp sms sndfile sound soundextract soundtouch soup source spamassassin speex spell sql sqlite srt srtp sse sse2 sse2check sse3 ssh ssl ssse3 startup-notification statistics stats stk stream suid svg svgz sysfs syslog szip t1lib tbb tcl tcmalloc tcpd teletext templates tga tgif themes theora threads threadsafe thumbnail thumbnails tiff timidity tk toolame tools transcode tremor truetype tv_check tv_combiner tv_pick_cgi twolame type3 udev udisks umfpack unicode unzip upower urlpicpreview usb utempter utils uudeview v4l v4l2 vaapi vamp vcd vcdinfo vcdx vdpau vdr video vim vim-syntax virtuoso visibility vlm vorbis vpx vrml vxml wav wavpack weather-metar weather-xoap webcam webdav webgl webkit webm webp windeco winpopup wma wma-fixed wmf word-perfect wordperfect wxwidgets wxwindows x11vnc x264 xanim xattr xcb xcf xcomposite xface xforms xine xinerama xml xmlreader xmlwriter xmp xorg xpm xscreensaver xsl xslt xterm xulrunner xv xvid xvmc xwax_decoders_aac xwax_decoders_cd xwax_decoders_flac xwax_decoders_misc xwax_decoders_mp3 xwax_decoders_ogg youtube yv12 zeroconf zip zlib zvbi" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en de_DE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="nvidia v4l2" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 2 shinydoofy 2013-10-15 18:17:10 UTC
I'm also affected by this. It doesn't hog a CPU or waits for IO (according to htop), it just doesn't seem to do anything.
Comment 3 SpanKY gentoo-dev 2013-10-15 19:49:32 UTC
if you unpack findutils and run `./configure` manually, does it hang ?
Comment 4 Randy Andy 2013-10-15 20:40:55 UTC
Hi SpanKY.

Confusingly, I guess your post should be placed in the findutils bug report, right. (No. 487782)

So I unpacked findutils and run /.configure manually, but it halt at the same step.
In this way I tried it out now, also without success.

How to go on?
Comment 5 Randy Andy 2013-10-15 21:22:08 UTC
In the meantime I found a very simple workaround for me.

Compiling the package in a native tty console does the trick ;-)

Before, when it fails, I tried to compile it in a X-terminal (konsole) within my KDE desktop environment, as I do it usually.

I hope this helps to improve the ebuild for future versions to sort this out.

Best, Andy.
Comment 6 Anthony Ryan 2013-10-16 04:48:27 UTC
Just throwing in another confirmation.
Comment 7 SpanKY gentoo-dev 2013-10-16 06:14:28 UTC

*** This bug has been marked as a duplicate of bug 487700 ***