Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 487014 - =x11-drivers/nvidia-drivers-331.13 - ?
Summary: =x11-drivers/nvidia-drivers-331.13 - ?
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-05 15:45 UTC by tman
Modified: 2013-10-06 17:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/portage/x11-drivers:nvidia-drivers-331.13:20131006-173710.log (20131006-173710.log,107.47 KB, application/octet-stream)
2013-10-06 17:40 UTC, tman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2013-10-05 15:45:33 UTC
make[3]: *** Waiting for unfinished jobs....
In file included from /usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess.h:539:0,
                 from /usr/src/linux-3.11.3-gentoo/include/linux/poll.h:11,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/nv-linux.h:97,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/os-registry.c:15:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h: In function ‘copy_from_user’:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h:62:6: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
In file included from /usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess.h:539:0,
                 from /usr/src/linux-3.11.3-gentoo/include/linux/poll.h:11,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/nv-linux.h:97,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/os-smp.c:15:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h: In function ‘copy_from_user’:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h:62:6: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
In file included from /usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess.h:539:0,
                 from /usr/src/linux-3.11.3-gentoo/include/linux/poll.h:11,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/nv-linux.h:97,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/nv_uvm_interface.c:21:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h: In function ‘copy_from_user’:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h:62:6: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
In file included from /usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess.h:539:0,
                 from /usr/src/linux-3.11.3-gentoo/include/linux/poll.h:11,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/nv-linux.h:97,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel/os-usermap.c:15:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h: In function ‘copy_from_user’:
/usr/src/linux-3.11.3-gentoo/arch/x86/include/asm/uaccess_64.h:62:6: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
make[2]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel] Error 2
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/usr/src/linux-3.11.3-gentoo'
NVIDIA: left KBUILD.
 nvidia.ko failed to build!
make: *** [nvidia.ko] Error 1
 * ERROR: x11-drivers/nvidia-drivers-331.13::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-331.13::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-331.13::gentoo'`.
 * The complete build log is located at '/var/log/portage/x11-drivers:nvidia-drivers-331.13:20131005-153538.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-331.13/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-331.13/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-331.13/work/'

 * Messages for package x11-drivers/nvidia-drivers-331.13:

 * Package:    x11-drivers/nvidia-drivers-331.13


Reproducible: Always




Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.11.3-gentoo x86_64)
=================================================================
System uname: Linux-3.11.3-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24696148 total,  21160204 free
KiB Swap:   25081852 total,  25081852 free
Timestamp of tree: Sat, 05 Oct 2013 15:10:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r5::gnome
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo qt mva gnome Techwolf luman wavilen lokal
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/X11/Sessions/awesome /etc/X11/Sessions/dwm /etc/conf.d/consolefont /etc/conf.d/hostname /etc/conf.d/hwclock /etc/conf.d/keymaps /etc/default/grub /etc/eix-sync.conf /etc/fstab /etc/hosts /etc/locale.gen /etc/make.conf /etc/timezone /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-10-05 15:58:12 UTC
Please provide the complete build log.
Comment 2 Jeroen Roovers gentoo-dev 2013-10-05 16:02:52 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 3 Jeroen Roovers gentoo-dev 2013-10-05 16:03:18 UTC
(The complete build log would have told us that kernel 3.11 is not supported.)
Comment 4 tman 2013-10-06 17:40:09 UTC
Created attachment 360256 [details]
/var/log/portage/x11-drivers:nvidia-drivers-331.13:20131006-173710.log