Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 486940 - net-im/skype-4.2.0.11-r1: 'fontconfig' directory created in home directory
Summary: net-im/skype-4.2.0.11-r1: 'fontconfig' directory created in home directory
Status: RESOLVED DUPLICATE of bug 486338
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ben de Groot (RETIRED)
URL: http://cgit.freedesktop.org/fontconfi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-04 06:38 UTC by BT
Modified: 2013-10-26 10:39 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BT 2013-10-04 06:38:22 UTC
Skype creates a 'fontconfig' (not hidden) directory in my home directory. It is populated with 13 '*.cache-3' files. If I delete the directory it is recreated at Skype start up. This is recent behaviour and I don't know what triggered it. It seems to be harmless but it's quite annoying.

emerge --info
Portage 2.2.1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.15-r3, 3.10.7-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.10.7-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-3570K_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16104468 total,    492448 free
KiB Swap:    1048572 total,    206132 free
Timestamp of tree: Thu, 03 Oct 2013 22:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.2rc1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r2, 3.2.5-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo amak79
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=corei7-avx -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.internode.on.net/pub/gentoo"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="X a52 aac acpi alsa amd64 berkdb bluetooth bzip2 cairo caps cdda cdinstall cdr cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dv dvd dvdr encode exif ffmpeg flac fortran gdbm gif gpm iconv ieee1394 joystick jpeg kde kipi lcms mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline scanner sdl session spell sse sse2 ssl svg taglib tcpd theora threads tiff truetype udev udisks unicode upower usb vorbis x264 xcb xcomposite xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 BT 2013-10-05 01:31:46 UTC
I tried the suggestion from bug #458104 by adding ABI_X86="32 64" to make.conf but that doesn't appear to do anything. fontconfig still builds with ABI_X86="(64) (-32) (-x32)".

The other suggestion to manually create a '~/.fontconfig' directory also doesn't help.
Comment 2 BT 2013-10-05 01:37:06 UTC
I just realised that I had to rename the auto created 'fontconfig' directory to '.fontconfig'. This does "fix" the issue as the 'fontconfig' directory is no longer created.
Comment 3 Rafał Mużyło 2013-10-05 13:30:56 UTC
Just a guess, but could this be a problem that was fixed in fontconfig in "Do not create a config dir for migration when no config files nor dirs" commit (first after 2.10.95 tag) ?
Comment 4 BT 2013-10-05 23:29:03 UTC
(In reply to Rafał Mużyło from comment #3)
> Just a guess, but could this be a problem that was fixed in fontconfig in
> "Do not create a config dir for migration when no config files nor dirs"
> commit (first after 2.10.95 tag) ?

Yes it does appear that the issue is fixed with that commit. I haven't been able to test it as there are too many changes since 2.10.93 to create a simple patch.
Comment 5 Samuel Bauer 2013-10-17 23:40:16 UTC
Seems to be the same symptom related here:
http://forums.debian.net/viewtopic.php?f=6&t=87548

FIX: sed -i '/prefix="xdg"/d' /etc/fonts/fonts.conf
Comment 6 Ben de Groot (RETIRED) gentoo-dev 2013-10-21 04:16:53 UTC
Please test fontconfig-2.11.0 and tell us whether this issue has been solved.
Comment 7 BT 2013-10-21 09:29:01 UTC
(In reply to Ben de Groot from comment #6)
> Please test fontconfig-2.11.0 and tell us whether this issue has been solved.

Unfortunately the issue is still present with fontconfig-2.11.0.
Comment 8 Ben de Groot (RETIRED) gentoo-dev 2013-10-26 10:39:46 UTC

*** This bug has been marked as a duplicate of bug 486338 ***