Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 486790 - x11-misc/arandr-0.1.7.1 stable request
Summary: x11-misc/arandr-0.1.7.1 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 475480
  Show dependency tree
 
Reported: 2013-10-02 13:06 UTC by Nico Suhl
Modified: 2013-10-08 05:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Suhl 2013-10-02 13:06:48 UTC
arandr depends on xrandr in version 1.2 or 1.3, but RDEPEND in ebuild allows all versions.
So using the latest stable xrandr 1.4.1 will cause arandr to fail.

Reproducible: Always




diff --git a/arandr-0.1.6.ebuild b/arandr-0.1.6.ebuild
index 1d84f4a..7389387 100644
--- a/arandr-0.1.6.ebuild
+++ b/arandr-0.1.6.ebuild
@@ -20,7 +20,7 @@ KEYWORDS="amd64 x86"
 IUSE=""
 
 RDEPEND=">=dev-python/pygtk-2
-       x11-apps/xrandr"
+       <x11-apps/xrandr-1.4.0"
 DEPEND=">=dev-python/docutils-0.6"
 
 PYTHON_MODNAME=screenlayout
Comment 1 Jeroen Roovers gentoo-dev 2013-10-03 14:54:38 UTC
Downgrading is not a solution. What is the problem with the current arandr and the new xrandr?
Comment 2 Jeroen Roovers gentoo-dev 2013-10-03 17:21:39 UTC
Oh this?

> arandr
Traceback (most recent call last):
  File "/usr/bin/arandr-2.7", line 42, in <module>
    main()
  File "/usr/lib64/python2.7/site-packages/screenlayout/gui.py", line 318, in main
    force_version=options.force_version
  File "/usr/lib64/python2.7/site-packages/screenlayout/gui.py", line 157, in __init__
    self.widget = widget.ARandRWidget(display=randr_display, force_version=force_version)
  File "/usr/lib64/python2.7/site-packages/screenlayout/widget.py", line 48, in __init__
    self._xrandr = XRandR(display=display, force_version=force_version)
  File "/usr/lib64/python2.7/site-packages/screenlayout/xrandr.py", line 42, in __init__
    raise Exception("XRandR 1.2/1.3 required.")
Exception: XRandR 1.2/1.3 required.

Note that `arandr --force-version' still works fine.

Let's stabilise 0.1.7.1 instead.

Arch teams, please test and mark stable:
=x11-misc/arandr-0.1.7.1
Targeted stable KEYWORDS : amd64 x86
Comment 3 Agostino Sarubbo gentoo-dev 2013-10-05 06:19:33 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2013-10-08 05:10:37 UTC
x86 stable. Last arch, closing