Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 486266 - app-editors/vim-7.4.41 - Can't locate object method "new" via package "ExtUtils::ParseXS" at /usr/bin/xsubpp line 53.
Summary: app-editors/vim-7.4.41 - Can't locate object method "new" via package "ExtUti...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-28 06:25 UTC by Vasco Gervasi
Modified: 2013-10-01 13:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,30.71 KB, text/x-log)
2013-09-28 06:26 UTC, Vasco Gervasi
Details
emerge --info (emerge,15.94 KB, text/plain)
2013-09-28 14:03 UTC, Vasco Gervasi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasco Gervasi 2013-09-28 06:25:04 UTC
Hi all,
I am trying to update vim to 7.4.41 but I get this error:
/usr/bin/perl -e 'unless ( $] >= 5.005 ) { for (qw(na defgv errgv)) { print "#define PL_$_ $_\n" }}' > auto/if_perl.c
/usr/bin/perl /usr/bin/xsubpp -prototypes -typemap \
    /usr/lib/perl5/5.16.3/ExtUtils/typemap if_perl.xs >> auto/if_perl.c
Can't locate object method "new" via package "ExtUtils::ParseXS" at /usr/bin/xsubpp line 53.
make[1]: *** [auto/if_perl.c] Errore 255
make[1]: *** Attesa dei processi non terminati....
make[1]: Leaving directory `/tmp/portage/app-editors/vim-7.4.41/work/vim74/src'
make: *** [first] Errore 2

my emerge --info: http://pastebin.com/raw.php?i=2gyegXpP
Comment 1 Vasco Gervasi 2013-09-28 06:26:48 UTC
Created attachment 359662 [details]
build.log
Comment 2 Jeroen Roovers gentoo-dev 2013-09-28 13:50:31 UTC
Please post your `emerge --info' output in a comment.
Comment 3 Vasco Gervasi 2013-09-28 14:03:10 UTC
Created attachment 359690 [details]
emerge --info
Comment 4 Thorsten 2013-09-29 21:38:35 UTC
I encountered the same bug. 
I re-emerged ExtUtils-ParseXS and vim compiled successfully after that.
Comment 5 Vasco Gervasi 2013-09-29 21:55:07 UTC
Thank you very much cuban8@web.de. Now it works also for me.
Comment 6 Jeroen Roovers gentoo-dev 2013-10-01 13:35:22 UTC
(In reply to Thorsten from comment #4)
> I encountered the same bug. 
> I re-emerged ExtUtils-ParseXS and vim compiled successfully after that.

*** This bug has been marked as a duplicate of bug 41124 ***