Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 485724 - x11-drivers/nvidia-drivers: please convert to multilib-build
Summary: x11-drivers/nvidia-drivers: please convert to multilib-build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Jeroen Roovers (RETIRED)
URL:
Whiteboard:
Keywords:
: 545582 (view as bug list)
Depends on:
Blocks: gx86-multilib
  Show dependency tree
 
Reported: 2013-09-23 08:52 UTC by Michał Górny
Modified: 2018-05-09 04:31 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch against nvidia-drivers-346.35 (nvidia-drivers-multilib.patch,2.76 KB, patch)
2015-02-23 18:59 UTC, nE0sIghT
Details | Diff
Patch against nvidia-drivers-346.47 (nvidia-drivers-346.47-multilib.patch,2.81 KB, patch)
2015-03-05 18:38 UTC, nE0sIghT
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-09-23 08:52:17 UTC
Instead of using IUSE=multilib and multilib.eclass magic, please switch to the verbose-and-explicit multilib-build eclass or the multilib-minimal eclass, whichever suits you better.

Afterwards, please add [${MULTILIB_USEDEP}] on your package to virtual/opencl.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2013-12-31 15:58:55 UTC
Do you have an example patch?
Comment 2 Matthew Schultz 2014-03-10 14:31:46 UTC
Can we get this fixed?  This is a major blocker now that ABI_X86 is unmasked:

emerge -av nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-emulation/emul-linux-x86-baselibs-20131008-r6  USE="development" ABI_X86="(-32)" 0 kB
[ebuild  N     ] app-emulation/emul-linux-x86-xlibs-20131008  USE="(development) opengl" ABI_X86="(-32)" 0 kB
[ebuild  N     ] app-emulation/emul-linux-x86-opengl-20131008  USE="development" ABI_X86="(-32)" 0 kB
[ebuild   R   ~] x11-drivers/nvidia-drivers-334.21  USE="X acpi (multilib) tools -pax_kernel -uvm" 0 kB
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking media-libs/libpng-1.6.9)
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking sys-libs/zlib-1.2.8-r1)

Total: 4 packages (3 new, 1 reinstall), Size of downloads: 0 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
    sys-libs/zlib required by @selected

  (app-emulation/emul-linux-x86-baselibs-20131008-r6::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20131008 required by (app-emulation/emul-linux-x86-xlibs-20131008::gentoo, ebuild scheduled for merge)

  (media-libs/libpng-1.6.9::gentoo, installed) pulled in by
    media-libs/libpng required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Comment 3 Matthew Schultz 2014-03-10 18:12:26 UTC
(In reply to Matthew Schultz from comment #2)
> Can we get this fixed?  This is a major blocker now that ABI_X86 is unmasked:
> 
> emerge -av nvidia-drivers
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild  N     ] app-emulation/emul-linux-x86-baselibs-20131008-r6 
> USE="development" ABI_X86="(-32)" 0 kB
> [ebuild  N     ] app-emulation/emul-linux-x86-xlibs-20131008 
> USE="(development) opengl" ABI_X86="(-32)" 0 kB
> [ebuild  N     ] app-emulation/emul-linux-x86-opengl-20131008 
> USE="development" ABI_X86="(-32)" 0 kB
> [ebuild   R   ~] x11-drivers/nvidia-drivers-334.21  USE="X acpi (multilib)
> tools -pax_kernel -uvm" 0 kB
> [blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
> ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking
> media-libs/libpng-1.6.9)
> [blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
> ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking
> sys-libs/zlib-1.2.8-r1)
> 
> Total: 4 packages (3 new, 1 reinstall), Size of downloads: 0 kB
> Conflict: 2 blocks (2 unsatisfied)
> 
>  * Error: The above package list contains packages which cannot be
>  * installed at the same time on the same system.
> 
>   (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
>     sys-libs/zlib required by @selected
> 
>   (app-emulation/emul-linux-x86-baselibs-20131008-r6::gentoo, ebuild
> scheduled for merge) pulled in by
>     ~app-emulation/emul-linux-x86-baselibs-20131008 required by
> (app-emulation/emul-linux-x86-xlibs-20131008::gentoo, ebuild scheduled for
> merge)
> 
>   (media-libs/libpng-1.6.9::gentoo, installed) pulled in by
>     media-libs/libpng required by @selected
> 
> 
> For more information about Blocked Packages, please refer to the following
> section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
> 
> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Never mind, just had to unmask abi_x86_32 use flag.
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-03-22 22:15:15 UTC
A few days ago vapier removed the multilib USE flag from package.use.force on amd64 (bug #435094), so this issue has just become very important.
Comment 5 nE0sIghT 2015-02-23 18:59:32 UTC
Created attachment 397342 [details, diff]
Patch against nvidia-drivers-346.35

Here is patch against nvidia-drivers-346.35
Comment 6 nE0sIghT 2015-03-05 18:38:11 UTC
Created attachment 398184 [details, diff]
Patch against nvidia-drivers-346.47
Comment 7 nE0sIghT 2015-03-26 18:24:14 UTC
Comment on attachment 398184 [details, diff]
Patch against nvidia-drivers-346.47

Works for me with nvidia-drivers-349.12
Comment 8 Mike Gilbert gentoo-dev 2015-04-05 03:12:29 UTC
*** Bug 545582 has been marked as a duplicate of this bug. ***
Comment 9 siebz0r 2018-04-20 16:48:29 UTC
This seems like an old bug as the latest stable (and the unstables) use the multilib-minimal eclass.
This can be closed, right?
Comment 10 Matt Turner gentoo-dev 2018-05-09 04:31:23 UTC
(In reply to siebz0r from comment #9)
> This seems like an old bug as the latest stable (and the unstables) use the
> multilib-minimal eclass.
> This can be closed, right?

I don't see why not.