Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 485418 - app-office/akonadi-server need to set USE="sqlite" by default
Summary: app-office/akonadi-server need to set USE="sqlite" by default
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-19 15:50 UTC by Keepun
Modified: 2013-09-19 17:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keepun 2013-09-19 15:50:40 UTC
For app-office/akonadi-server need to set USE="sqlite" by default.

.xsession-errors:

QSqlDatabase: QSQLITE3 driver not loaded
QSqlDatabase: available drivers: QSQLITE ASSERT: 
"database.driver()->hasFeature( QSqlDriver::LastInsertId )" in file ../../server/src/storage/dbconfigsqlite.cpp, line 117 "[ 0: akonadiserver() [0x805bee5] 1: akonadiserver() [0x805c22a] 2: [0xb773e400] 3: [0xb773e424] 4: /lib/i386-linux-gnu/libc.so.6(gsignal+0x4f) [0xb6e07b1f] 5: /lib/i386-linux-gnu/libc.so.6(abort+0x143) [0xb6e0b0b3] 6: /usr/lib/i386-linux-gnu/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x13c) [0xb748c7fc] 7: /usr/lib/i386-linux-gnu/libQtCore.so.4(+0x5cc09) [0xb748cc09] 8: /usr/lib/i386-linux-gnu/libQtCore.so.4(_Z6qFatalPKcz+0x18) [0xb748cd28] 9: /usr/lib/i386-linux-gnu/libQtCore.so.4(_Z9qt_assertPKcS0_i+0x35) [0xb748cdb5] 10: akonadiserver() [0x80d86d4] 11: akonadiserver() [0x805f06d] 12: akonadiserver() [0x8060aa5] 13: akonadiserver() [0x8061566] 14: akonadiserver() [0x8055b6a] 15: /lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0xb6df2935] 16: akonadiserver() [0x8056681] ] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)

Reproducible: Always
Comment 1 Johannes Huber gentoo-dev 2013-09-19 15:55:39 UTC
Please read the warning of the ebuild...

> ewarn
> ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
> ewarn "user configuration. This is the backend recommended by KDE upstream."
> ewarn "In particular, kde-base/kmail-4.10 does not work properly with the sqlite"
> ewarn "backend anymore."
> ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
> ewarn "Available drivers are:${AVAILABLE}"
> ewarn
Comment 2 Keepun 2013-09-19 17:03:15 UTC
This warning can be ignored or invisible.
When not adjusted MySQL and SQLite missing desktop can not run.