Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 483990 - Systemd-206-r3 should depend on XML::parser
Summary: Systemd-206-r3 should depend on XML::parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-06 13:28 UTC by Peter Asplund
Modified: 2013-09-06 13:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
log output (file_483990.txt,10.42 KB, text/plain)
2013-09-06 13:29 UTC, Peter Asplund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Asplund 2013-09-06 13:28:53 UTC
I'm failing to build systemd-206-r3 with the attached output. But I think the gist of it is:
...
checking for perl >= 5.8.1... 5.18.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

The change seems to be that xattr has been added as a default useflag (I don't _think_ I've enabled it, but who am I to remember? ;))

root@skare$ emerge -utavN systemd

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/systemd-206-r3  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit python tcpd xattr* -audit -cryptsetup -doc -gcrypt -http -lzma -openrc -qrcode (-selinux) {-test} -vanilla" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB

Reproducible: Always




root@skare$ emerge --info
Portage 2.2.1 (default/linux/amd64/13.0/desktop/gnome, gcc-4.8.0, glibc-2.17, 3.10.9-gentoo x86_64)
=================================================================
System uname: Linux-3.10.9-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.2
KiB Mem:    12306040 total,   5335624 free
KiB Swap:   12418208 total,  12418208 free
Timestamp of tree: Thu, 05 Sep 2013 18:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.8.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x11 multimedia sunrise seden dotnet qt steam-overlay AzP
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=8 --load-average=19 --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ http://ftp.uoi.gr/mirror/OS/gentoo/"
LANG="en_EN.UTF-8"
LDFLAGS="-Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/multimedia /var/lib/layman/sunrise /var/lib/layman/seden /var/lib/layman/dotnet /var/lib/layman/qt /var/lib/layman/steam /usr/local/portage"
USE="32bit 3dnow 3dnowext 64bit S3TC X a52 aac aalib acl acpi alsa amazon amd64 amr amrnb amrwb apng asf aspell autoipd avahi avi bash-completion bidi binary-drivers bineditor bluetooth bookmarks branding bzip2 c++0x cairo ccache cdda cdr cg cgi cleartype cli clutter cmake colord cover coverart cracklib crypt css cue cups curl custom-optimization cxx daap dbus dconf debugger device-mapper devil dga dirac divx dmx dns dri dts dvd dvdr dvdread emboss encode evo exif fakevim fam fastcgi fat fbcon ffmpeg firefox flac fluidsynth fontconfig fortran fpm freeimage ftp fuse g3dvl gaim gbm gd gdbm gdu gflags ggi gif gimp git glamor glib glut gmail gmailtimestamps gmedia gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk2 gtk3 gtkhtml gvim gzip h224 h281 h323 howl-compat hpijs iconv icq icu idn imap inotify introspection iphone ipod ipv6 jabber java java6 jingle jpeg jpeg2k kde kdrive lame lcms ldap libnotify libsecret libsexy libssh2 libv4l libv4l2 lm_sensors mad madwifi mbox md5sum mdnsresponder-compat mh midi mikmod mime minizip mmx mmxext mng moc mod modplug modules mozembed mozilla moznocompose moznoirc moznomail moznoroaming mozsha1 mozsvg mp2 mp3 mp4 mp4live mpeg msn mudflap multilib multimedia musepack musicbrainz nas nautilus ncurses nemesi new-hpcups nls nptl nsplugin ntfs ntfsprogs nx ofa ogg openal opencore-amr opengl openmp openssl opensslcrypt openvg optimization pam pango pcntl pcre pdf pdflib perl php pidgin pipechan png pnm policykit pop ppds private-headers pulseaudio pvr python python3 qml qt3support qt4 qtscript quicktime radio raw rdesktop readline realmedia reiser4 reiserfs rtc s3tc samba sasl schroedinger scintilla sdl secure-delete session sid sip sndfile socialweb sockets spell sql sqlite srt sse sse2 sse4.1 sse4.2 ssh ssl ssse3 startup-notification steamruntime subtitles subversion suid svg systemd tcpd telepathy teletext tga theora threads tiff tls transcode truetype udev udisks unicode upcall upnp upower usb v4l v4l2 vaapi valgrind vdpau video videos vim vim-pager vim-syntax vim-with-x vorbis vte wav wavpack webdav webdav-neon webdav-serf webkit webkit2 webm wifi winbind wma wma-fixed wmf wmp wxwidgets x264 xanim xattr xcb xcomposite xdmcp xext xfs xinerama xml xrandr xulrunner xv xvid xvmc zeitgeist zeroconf zip zlib zoran" ABI_X86="64" ALSA_CARDS="emu10k1 hda_intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en sv" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3" QEMU_SOFTMMU_TARGETS="i386 arm x86_64" QEMU_USER_TARGETS="i386 arm x86_64" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
Comment 1 Peter Asplund 2013-09-06 13:29:50 UTC
Created attachment 358058 [details]
log output
Comment 2 Jeroen Roovers gentoo-dev 2013-09-06 13:30:30 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 3 Peter Asplund 2013-09-06 13:35:32 UTC
But I just discovered a very strange thing, I already have it installed:

root@skare$ emerge -s XML-parser
*  dev-perl/XML-Parser
      Latest version available: 2.410.0-r1
      Latest version installed: 2.410.0-r1
      Size of files: 232 kB
      Homepage:      http://search.cpan.org/dist/XML-Parser/
      Description:   A Perl extension interface to James Clark's XML parser, expat
      License:       || ( Artistic GPL-1 GPL-2 GPL-3 )
Comment 4 Peter Asplund 2013-09-06 13:35:51 UTC
Aah, I'll run perl-cleaner then!