Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 482686 - nvidia-drivers-319.32 do not compile under 3.10.7 kernel
Summary: nvidia-drivers-319.32 do not compile under 3.10.7 kernel
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-27 16:04 UTC by Erik Dobak
Modified: 2013-08-27 18:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Dobak 2013-08-27 16:04:06 UTC
did build the new kernel 3.10.7 kernel but the latest unmasked nvidia-drivers-319.32 fail to compile with this error:

"void value not ignored as it ought to be"

after unmasking nvidia-drivers-325.15 i could compile sucessfully.
should not that version be unmasked now when the 3.10 kernel is out?
Comment 1 Jeroen Roovers gentoo-dev 2013-08-27 16:06:37 UTC
Try 319.49.

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 2 Erik Dobak 2013-08-27 17:47:13 UTC
yes 319.49 compiles fine too. thanks.

but the question is that if gentoo unmasks a new kernel should not gentoo also unmask a new/working driver?
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-08-27 18:16:40 UTC
The driver is not a dependency of the kernel; therefore, no.

It is the responsibility of the user to use compatible kernels and drivers; because, we cannot test the external modules throughout entire Portage tree whether they are stable with what we want to stabilize. That's impossible.

At best, the maintainer of the external module can try to follow with stabilization in a timely manner to minimize this problem; in any case, historically nvidia-drivers has not blocked stabilization and I don't see any plans on changing this.

What we did change, though, is that we keep older kernels around in a masked manner; such that in the event that it doesn't work with a newer kernel, an user can opt to unmask the older kernel.