Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 482372 - =dev-libs/boost-1.53.0 with =sys-libs/glibc-2.18 - ./boost/atomic/atomic.hpp:166:16: error: ‘uintptr_t’ was not declared in this scope
Summary: =dev-libs/boost-1.53.0 with =sys-libs/glibc-2.18 - ./boost/atomic/atomic.hpp:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard:
Keywords:
: 482108 (view as bug list)
Depends on:
Blocks: glibc-2.18
  Show dependency tree
 
Reported: 2013-08-24 22:13 UTC by Yixun Lan
Modified: 2013-11-14 09:48 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (build.log.xz,35.96 KB, application/x-xz)
2013-08-24 22:13 UTC, Yixun Lan
Details
emerge info (emerge-info.txt,4.80 KB, text/plain)
2013-08-24 22:14 UTC, Yixun Lan
Details
patch for fix this (01-boost-cstdint.patch,780 bytes, patch)
2013-08-25 13:09 UTC, Yixun Lan
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yixun Lan archtester gentoo-dev 2013-08-24 22:13:13 UTC
./boost/iterator/iterator_adaptor.hpp: In function ‘void boost::detail::iterator_adaptor_assert_traversal()’:
./boost/static_assert.hpp:125:21: warning: typedef ‘boost_static_assert_typedef_224’ locally defined but not used [-Wunused-local-typedefs]
          BOOST_JOIN(boost_static_assert_typedef_, __LINE__)
                     ^
./boost/iterator/iterator_adaptor.hpp:224:7: note: in expansion of macro ‘BOOST_STATIC_ASSERT’
       BOOST_STATIC_ASSERT((is_convertible<Tr1, Tr2>::value));
       ^
In file included from ./boost/mpl/aux_/integral_wrapper.hpp:22:0,
                 from ./boost/mpl/int.hpp:20,
                 from ./boost/mpl/lambda_fwd.hpp:23,
                 from ./boost/mpl/aux_/na_spec.hpp:18,
                 from ./boost/mpl/if.hpp:19,
                 from ./boost/mpl/eval_if.hpp:17,
                 from ./boost/iterator/iterator_categories.hpp:15,
                 from ./boost/iterator/iterator_adaptor.hpp:14,
                 from ./boost/iterator/reverse_iterator.hpp:12,
                 from ./boost/wave/util/flex_string.hpp:86,
                 from ./boost/wave/wave_config.hpp:229,
                 from libs/wave/src/instantiate_cpp_grammar.cpp:14:
./boost/concept_check.hpp: In function ‘void boost::function_requires(Model*)’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check45’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:45:7: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
       BOOST_CONCEPT_ASSERT((Model));
       ^
./boost/concept_check.hpp: In destructor ‘boost::AdaptableGenerator<Func, Return>::~AdaptableGenerator()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check453’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:453:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<result_type, Return>));
           ^
./boost/concept_check.hpp: In destructor ‘boost::AdaptableUnaryFunction<Func, Return, Arg>::~AdaptableUnaryFunction()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check465’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:465:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<result_type, Return>));
           ^
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check466’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:466:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<Arg, argument_type>));
           ^
./boost/concept_check.hpp: In destructor ‘boost::AdaptableBinaryFunction<Func, Return, First, Second>::~AdaptableBinaryFunction()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check484’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:484:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<result_type, Return>));
           ^
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check485’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:485:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<First, first_argument_type>));
           ^
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check486’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:486:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<Second, second_argument_type>));
           ^
./boost/concept_check.hpp: In destructor ‘boost::InputIterator<TT>::~InputIterator()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check517’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:517:9: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
         BOOST_CONCEPT_ASSERT((SignedInteger<difference_type>));
         ^
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check518’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:518:9: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
         BOOST_CONCEPT_ASSERT((Convertible<iterator_category, std::input_iterator_tag>));
         ^
./boost/concept_check.hpp: In destructor ‘boost::ForwardIterator<TT>::~ForwardIterator()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check551’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:548:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<
           ^
./boost/concept_check.hpp: In destructor ‘boost::BidirectionalIterator<TT>::~BidirectionalIterator()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check579’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^
./boost/concept/assert.hpp:44:5: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT_FN’
     BOOST_CONCEPT_ASSERT_FN(void(*)ModelInParens)
     ^
./boost/concept_check.hpp:576:11: note: in expansion of macro ‘BOOST_CONCEPT_ASSERT’
           BOOST_CONCEPT_ASSERT((Convertible<
           ^
./boost/concept_check.hpp: In destructor ‘boost::RandomAccessIterator<TT>::~RandomAccessIterator()’:
./boost/concept/detail/general.hpp:71:20: warning: typedef ‘boost_concept_check609’ locally defined but not used [-Wunused-local-typedefs]
       BOOST_PP_CAT(boost_concept_check,__LINE__)
                    ^
./boost/preprocessor/cat.hpp:29:34: note: in definition of macro ‘BOOST_PP_CAT_I’
 #    define BOOST_PP_CAT_I(a, b) a ## b
                                  ^
./boost/concept/detail/general.hpp:71:7: note: in expansion of macro ‘BOOST_PP_CAT’
       BOOST_PP_CAT(boost_concept_check,__LINE__)
       ^


Reproducible: Always
Comment 1 Yixun Lan archtester gentoo-dev 2013-08-24 22:13:58 UTC
Created attachment 356916 [details]
full build log
Comment 2 Yixun Lan archtester gentoo-dev 2013-08-24 22:14:42 UTC
Created attachment 356918 [details]
emerge info
Comment 3 Yixun Lan archtester gentoo-dev 2013-08-24 22:17:31 UTC
would be great to setup a tracker for glibc-2.18, just like #448860

also I can confirm, downgrading to glibc-2.17, boost builds fine
Comment 4 Yixun Lan archtester gentoo-dev 2013-08-25 13:09:57 UTC
Created attachment 356970 [details, diff]
patch for fix this

upstream report
https://svn.boost.org/trac/boost/ticket/8731

upstream fix
https://svn.boost.org/trac/boost/changeset/84950
Comment 5 microcai 2013-08-27 20:13:42 UTC
also boost 1.54 is in tree hard masked, boost 1.54 is also affected.
Comment 6 Sascha Cunz 2013-09-21 13:22:29 UTC
This is a duplicate of #482108.
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2013-09-28 06:22:47 UTC
*** Bug 482108 has been marked as a duplicate of this bug. ***
Comment 8 Tolga Dalman 2013-10-28 23:22:09 UTC
The patch looks good to me and should be applied to Boost 1.53.0 and 1.54.0.
Comment 9 Sergey Popov (RETIRED) gentoo-dev 2013-11-14 09:48:41 UTC
+  14 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> boost-1.53.0.ebuild,
+  +files/boost-1.53.0-glibc-2.18-compat.patch, boost-1.54.0.ebuild:
+  Add compatibility with glibc 2.18, wrt bug #482372

Thanks everyone, fix commited without revbump(buildtime only issue).