Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 481832 - sys-power/apcupsd-3.14.8-r1 - In file included from drv_rfc1628.c:27:0: snmp.h:82:10: error: expected unqualified-id before numeric constant
Summary: sys-power/apcupsd-3.14.8-r1 - In file included from drv_rfc1628.c:27:0: snmp....
Status: RESOLVED DUPLICATE of bug 430894
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Matthew Marlowe
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-21 08:09 UTC by Vladislav Poluhin
Modified: 2013-09-11 12:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,17.19 KB, text/x-log)
2013-08-21 08:10 UTC, Vladislav Poluhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav Poluhin 2013-08-21 08:09:33 UTC
Errors from log:

In file included from drv_rfc1628.c:27:0:
snmp.h:82:10: error: expected unqualified-id before numeric constant
snmp.h:82:9: error: expected ';' at end of member declaration
snmp.h:82:10: error: expected unqualified-id before numeric constant
drv_rfc1628.c: In function 'int rfc_1628_check_alarms(UPSINFO*)':
drv_rfc1628.c:35:40: error: expected unqualified-id before numeric constant
drv_rfc1628.c:35:40: error: expected ',' or ';' before numeric constant
drv_rfc1628.c: In function 'int rfc1628_snmp_ups_read_static_data(UPSINFO*)':
drv_rfc1628.c:79:40: error: expected unqualified-id before numeric constant
drv_rfc1628.c:79:40: error: expected ',' or ';' before numeric constant
drv_rfc1628.c: In function 'int rfc1628_snmp_ups_read_volatile_data(UPSINFO*)':
drv_rfc1628.c:101:40: error: expected unqualified-id before numeric constant
drv_rfc1628.c:101:40: error: expected ',' or ';' before numeric constant


Reproducible: Always




Portage 2.1.12.2 (hardened/linux/amd64, gcc-4.6.3, glibc-2.15-r3, 3.4.34-gentoo x86_64)
=================================================================
System uname: Linux-3.4.34-gentoo-x86_64-Intel-R-_Atom-TM-_CPU_K410_@_1.66GHz-with-gentoo-2.2
KiB Mem:     1015188 total,    156996 free
KiB Swap:    4192252 total,   4110268 free
Timestamp of tree: Tue, 20 Aug 2013 19:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5, 3.2.5-r1
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo nuklea sunrise drevilt local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/python2.7/site-packages/buildbot/status/web /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -msse3"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg buildsyspkg config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/nuklea /var/lib/layman/sunrise /var/lib/layman/drevilt /usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip acl acpi amd64 async bash-completion berkdb bzip2 charconv cli cracklib crypt cups cxx dbus device-mapper dri epoll flac fontconfig gd gdbm geoip gpm hardened iconv idn iproute2 ipv6 isc jpeg justify kerberos ldap lm_sensors logrotate lvm2 md5sum mmx modules mp3 mudflap multilib ncurses nls nptl openmp pam pax_kernel pcre png python quota readline samba session slang slp snmp socks5 sse sse2 ssl syslog tcpd tiff truetype unicode urandom userlocales vhosts vim vim-syntax win32codecs xattr xml xpm zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_connect proxy_http" APACHE2_MPMS="peruser" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi ssi upstream_ip_hash userid uwsgi split_clients auth_pam" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Vladislav Poluhin 2013-08-21 08:10:53 UTC
Created attachment 356574 [details]
build.log
Comment 2 Thomas Beutin 2013-09-01 11:16:56 UTC
The problem still exists in sys-power/apcupsd-3.14.10-r2.
Comment 3 Thomas Beutin 2013-09-01 12:28:39 UTC
(In reply to Thomas Beutin from comment #2)
> The problem still exists in sys-power/apcupsd-3.14.10-r2.

btw: i assume this bug is a dupe of 430894
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2013-09-11 12:08:15 UTC

*** This bug has been marked as a duplicate of bug 430894 ***