Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 481744 - [qt overlay] dev-qt/declarative:5 compilation fails with undefined reference to glClearDepth
Summary: [qt overlay] dev-qt/declarative:5 compilation fails with undefined reference ...
Status: RESOLVED DUPLICATE of bug 489278
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-20 11:57 UTC by Maksim 'max_posedon' Melnikau
Modified: 2013-10-27 19:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
qtdeclarative-5.1.0.build.log (qtdeclarative-5.1.0.build.log,209.32 KB, text/x-log)
2013-08-20 12:04 UTC, Maksim 'max_posedon' Melnikau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim 'max_posedon' Melnikau 2013-08-20 11:57:31 UTC
dev-qt/declarative compilation fails on linking (see below), looks like -lGL forgotten. But I'm not sure where it should be added.

[ebuild   R    ] dev-qt/qtcore-5.1.0:5::qt  USE="c++11 glib icu -debug {-test}" 0 kB
[ebuild   R    ] media-libs/mesa-9.1.6  USE="classic egl gallium gbm gles1 gles2 llvm nptl openvg osmesa shared-glapi vdpau wayland xa xorg xvmc -bindist -debug -pax_kernel -pic (-r600-llvm-compiler) (-selinux)" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" VIDEO_CARDS="i915 i965 intel nouveau -r100 -r200 -r300 -r600 -radeon (-radeonsi) -vmware" 0 kB
[ebuild   R    ] dev-qt/qtgui-5.1.0:5::qt  USE="c++11 eglfs evdev gif gles2 glib jpeg kms opengl png udev xcb -accessibility -debug {-test}" 0 kB
[ebuild   R    ] dev-qt/qtopengl-5.1.0:5::qt  USE="c++11 -debug {-test}" 0 kB
[ebuild  NS    ] dev-qt/qtdeclarative-5.1.0:5::qt [4.8.5:4::gentoo] USE="c++11 localstorage -debug {-test}" 0 kB

x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,--no-undefined -shared -Wl,-Bsymbolic-functions -Wl,-soname,libQt5Quick.so.5 -o libQt5Quick.so.5.1.0 .obj/release-shared/qquickapplication.o ... .obj/release-shared/moc_designerwindowmanager_p.o  -L/var/tmp/portage/dev-qt/qtdeclarative-5.1.0/work/qtdeclarative-opensource-src-5.1.0_build/lib -lQt5Qml -lQt5Network -lQt5Gui -lQt5Core -lpthread -lQt5Network -lQt5Core -lQt5V8 -lpthread -lGLESv2 
.obj/release-shared/qsgdefaultrenderer.o: In function `QSGDefaultRenderer::renderNodes(QSGNode* const*, int)':
/var/tmp/portage/dev-qt/qtdeclarative-5.1.0/work/qtdeclarative-opensource-src-5.1.0/src/quick/scenegraph/coreapi/qsgdefaultrenderer.cpp:430: undefined reference to `glClearDepth'
.obj/release-shared/qsgdefaultrenderer.o: In function `QSGDefaultRenderer::render()':
/var/tmp/portage/dev-qt/qtdeclarative-5.1.0/work/qtdeclarative-opensource-src-5.1.0/src/quick/scenegraph/coreapi/qsgdefaultrenderer.cpp:186: undefined reference to `glClearDepth'
collect2: error: ld returned 1 exit status
make[2]: *** [../../lib/libQt5Quick.so.5.1.0] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-qt/qtdeclarative-5.1.0/work/qtdeclarative-opensource-src-5.1.0_build/src/quick'
make[1]: *** [sub-quick-make_first-ordered] Error 2
make[1]: Leaving directory `/var/tmp/portage/dev-qt/qtdeclarative-5.1.0/work/qtdeclarative-opensource-src-5.1.0_build/src'
make: *** [sub-src-make_first] Error 2


Reproducible: Always

Steps to Reproduce:
1. emerge -1 qtcore:5 qtgui:5 qtopengl:5
2. emerge -1 dev-qt/qtdeclarative:5
Actual Results:  
compilation (linking) fails

Expected Results:  
compilation shoudn't fail

# emerge --info
Portage 2.2.0 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.1, glibc-2.17, 3.10.7-gentoo x86_64)
=================================================================
System uname: Linux-3.10.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-2617M_CPU_@_1.50GHz-with-gentoo-2.2
KiB Mem:     8153896 total,    755536 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 20 Aug 2013 05:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.10 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo systemd sunrise kde x11 sabayon qt local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe -ggdb"
DISTDIR="/home/gentoo/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles installsources merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/home/gentoo/m11xr3"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/systemd /var/lib/layman/sunrise /var/lib/layman/kde /var/lib/layman/x11 /var/lib/layman/sabayon /var/lib/layman/qt /usr/local/portage"
USE="X a52 aac aalib acl acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups curl cxx dbus declarative djvu dri dts dv dvd dvdr emboss encode exif fam ffmpeg firefox flac ftp gdbm gif gnutls gpm gps gsm gstreamer iconv icu imagemagick ios ipod ipv6 jingle jpeg jpeg2k kde kipi lame latex lcms ldap libcaca libnotify lm_sensors lzma lzo mad mmx mng modules mp3 mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses netboot networkmanager nls nptl ogg openal opengl openmp oscar pam pango pcre pdf phonon plasma png policykit portaudio postgres ppds pulseaudio qt3support qt4 rdesktop readline ruby samba sdl semantic-desktop session smp speex spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg systemd taglib tcpd theora tiff truetype udev udisks unicode upower usb v4l v4l2 vaapi vim-syntax vnc vorbis wayland wifi wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zeroconf zlib zsh-completion" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386 arm" QEMU_USER_TARGETS="x86_64 i386 arm" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="dummy fbdev intel nouveau nvidia i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Maksim 'max_posedon' Melnikau 2013-08-20 12:04:16 UTC
Created attachment 356476 [details]
qtdeclarative-5.1.0.build.log

few useless compilation (g++ invokes) lines was removed to fit 1M limit
Comment 2 Davide Pesavento gentoo-dev 2013-10-27 19:50:13 UTC

*** This bug has been marked as a duplicate of bug 489278 ***