Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479890 - gnome-base/gnome-panel-3.6.2-r1 fails to compile with automake-1.13.1
Summary: gnome-base/gnome-panel-3.6.2-r1 fails to compile with automake-1.13.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-08-06 03:14 UTC by Joe Sapp (RETIRED)
Modified: 2013-09-08 17:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,19.58 KB, text/plain)
2013-08-06 03:14 UTC, Joe Sapp (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Sapp (RETIRED) gentoo-dev 2013-08-06 03:14:44 UTC
Created attachment 355206 [details]
emerge --info

Trying to compile gnome-base/gnome-panel-3.6.2-r1 with automake-1.13.1 installed results in the following error (in temp/aclocal.out).  However, it compiled fine with automake-1.13.4, so I'm not sure this is a problem any more.

***** aclocal *****
***** PWD: /var/tmp/portage/gnome-base/gnome-panel-3.6.2-r1/work/gnome-panel-3.6.2
***** aclocal -I m4

/usr/share/aclocal/log4c.m4:7: warning: underquoted definition of AM_PATH_LOG4C
/usr/share/aclocal/log4c.m4:7:   run info Automake 'Extending aclocal'
/usr/share/aclocal/log4c.m4:7:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.ac:3: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:3: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Output of emerge -pqv '=gnome-base/gnome-panel-3.6.2-r1::gentoo':

[ebuild     U ] gnome-base/gnome-panel-3.6.2-r1 [3.6.2] USE="introspection networkmanager -eds"
Comment 1 Samuli Suominen gentoo-dev 2013-08-06 07:56:55 UTC
(In reply to Joe Sapp from comment #0)
> Created attachment 355206 [details]
> emerge --info
> 
> Trying to compile gnome-base/gnome-panel-3.6.2-r1 with automake-1.13.1
> installed results in the following error (in temp/aclocal.out).  However, it
> compiled fine with automake-1.13.4, so I'm not sure this is a problem any

AM_CONFIG_HEADER was restored to 1.13.x series but it's still obsolete and not present in automake-2.x so this should be fixed regardless
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-09-08 17:54:15 UTC
+  08 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+  gnome-panel-2.32.1-r3.ebuild, -gnome-panel-3.6.2.ebuild,
+  gnome-panel-3.6.2-r1.ebuild:
+  Automake-1.13 fix, bug #479890.
+
Thanks for reporting.